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figPanel web application provides a graphical user interface to configure the 

ystem. The application can be operated from any supported web browser 
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System requirements
System requirements

The web application ConfigPanel has been successfully tested with the following web 
browsers:

 Apple Safari 26
 Google Chrome 140
 Microsoft Edge 134
 Mozilla Firefox 144

Supported operating systems
 Microsoft Windows
 macOS
 Linux
 Android
 iOS

Recommended resolutions
 A minimum resolution of 1280 × 800 pixels is recommended.
 The web application is optimized to display the content in landscape mode.
 Portrait mode is supported. In this mode, not all contents may be visible.

IMPORTANT: Before starting the web application via web browser, connect the 
device from which you want to load the web application to the local network. The 
Installation manual of the device provides more information.

If not already done, adjust the network settings as described on page 3.
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Initial configuration of the network  settings
Initial configuration of the network 
 settings

To access the web application, the network settings of the device on which the web 
application is operated need to be configured.

How to configure the network settings before integrating the device into the local 
network:

1. Use a category 5 (or better) twisted pair cable to connect the network interface of 
any computer to the device’s Network A interface.

2. Ensure that the IP address of the computer’s network interface is part of the 
subnet to which the device’s IP address belongs to.

3. Switch on the device.

4. Start the computer’s web browser and enter 192.168.0.1 in the address bar.

5. Configure the network interface(s) and the global network settings as described in 
the paragraph Network settings on page 19 f.

6. Remove the twisted pair cable connection between computer and device.

7. Implement the device in the local network.

NOTE: In the defaults, the following settings are pre-selected:

 IP address of network interface A: 192.168.0.1
 IP address of network interface B: address obtained using DHCPv4
 Global network settings: obtain settings dynamically

NOTE: Use the IP address 192.168.0.100, for example.

IMPORTANT: It is not possible to operate both network interfaces within one 
subnet!
G&D ControlCenter-Compact · 3



Getting started
Getting started
This chapter introduces you to the basic operation of the web application.

Starting the web application

How to start the web application

1. Enter the following URL in the address line:

https://[IP address of the device]

2. Enter the following data in the login mask:    

NOTE: For a detailed explanation of the functions and configuration settings, refer 
to the following chapters of this manual.

NOTE: Information on the system requirements of the web application can be 
found on page 2.

Agree to the terms 
of use:

Click on the text to read the terms of use. Click on the 
checkbox to accept the terms of use.

Username: Enter a username.

Password: Enter a password for your user account.

2-Factor Auth Code 
(TOTP):

Enter the 2-Factor Auth Code (TOTP) from  
two-factor authentication.

IMPORTANT: Change the administrator account's default password.

To do this, log into the web application with the administrator account 
and then change the password (see page 72).

The default access data to the administrator account are:

 Username: Admin
 Password: see login information on the label on the bottom of the device

NOTE: The default admin password for devices manufactured before 
November 2020 is 4658.

NOTE: The terms of use only appear if a corresponding configuration has been 
made (see Showing terms of use on page 13 ff.).

NOTE: The 2-Factor Auth Code (TOTP) is only requested if  
two-factor authentication has been configured (see page 53 f.)  
and activated (see page 68 ff.).
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Getting started
3. Click on Login.

4. Click on the Config Panel 21 icon.

NOTE: As an alternative to the Config Panel 21 you can open the EasyControl
(see page 340) tool after login, if you have activated the IP-Control-API feature 
for a fee.
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Operating the web application

User interface

The user interface of the web application consists of several areas:

The different areas of the user interface serve different tasks. The following table lists 
the purpose of each area:

Figure 1: User interface of the web application

Menu : In the menu the different functions of the web application 
are summarised in various topics.

Breadcrumb 

navigation :

The breadcrumb navigation shows you the path to the  
currently opened dialog.

To quickly return to a higher-level dialog, you can click  
on it in the breadcrumb navigation.

Filter function : You can use the filter function to narrow down the items 
displayed in the main view.

In the text box, enter part of the name of the element you 
want to find. Only elements that contain this text in one of 
the displayed columns are displayed in the main view. The 
names are not case-sensitive during filtering.

To delete the filter, click on the [X] icon.

Main view : After selecting a topic in the menu, the contents of this 
topic are displayed here.















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Shortcuts : Language selection: The language identifier (for example EN 
for English) shows the currently active language in the web 
application.

To switch the language, click the language identifier. This 
opens a submenu that shows the supported languages and 
the corresponding identifiers.

Switch the language by clicking on the desired language.

User: A click on the user icon opens a submenu:

 The name of the active user is displayed in the submenu.
 Click on User to access the user settings of the active user.
 Click on Logout to exit the active session.

Monitoring status: This icon shows you at a glance whether 
all monitoring values are within the normal range (green 
icon) or if at least one monitoring value is outside the 
normal range (yellow or red icon).

The Monitoring status icon always takes the colour of the most 
critical monitoring value

If the icon is displayed in yellow or red, you can access the 
Active alarms dialog by clicking on the icon.

Buttons : Depending on the dialog shown, different buttons are  
displayed in this area.
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Frequently used buttons

The user interface uses various buttons to perform operations. The following table 
informs you about the names and functions of the buttons used in many dialog masks:

Configuring table columns

You can adapt the table columns to be displayed under Matrix systems and Users to 
your requirements.

By default, the columns Name, Device type, Comment and Monitoring overview are shown 
under Matrix systems: 

Configuration: Show configuration settings of the selected element (device, user, ...)

Service  
tools:

If you select a device in the main view, you can use the service 
tools to perform certain tasks (for example, update, backup, show 
syslog).

Save: Saving of the entered data. The opened dialog is still displayed.

Cancel: The data you have entered will be discarded and the dialog will be 
closed.

Close: The entered data is cached and the dialog is closed. 

Only after clicking on Save or Cancel the data is permanently stored 
or discarded.

Figure 2: Table columns (selection) of a matrix switch

NOTE: Click the chain icon in the Name column to display grouped devices as a 
unit or list each device individually.
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How to change the columns to be displayed:

1. Click on the gears icon ( ) above the table.

2. To add a column, select it from the Columns drop-down box and click 
on Add column.

3. To delete a column, click on the red button ( ) below the column header.

4. Click on the green check mark ( ) to save your settings or klick on the 
red Discard button ( ).

How to change the column order:

1. Click on the gears icon above the table.

2. To move a column to the left, click on the arrow left icon ( ) of this column.

3. To move a column to the right, click on the arrow right icon ( ) of this column.

4. Click on the green check mark ( ) to save your settings or click on the  
red Discard button ( ).

How to reset the table configuration to the default settings

1. Click on the Table configuration reset icon ( ) above the table.

2. Confirm the security prompt by clicking on Yes.

NOTE: The Name column is always shown as the first column of the table.

Figure 3: Table configuration

NOTE: The Name column is always shown as the first column of the table.
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Language settings

Selecting the language of the web application

How to change the language of the web application:

1. Click the language identifier of the current language in the upper right 
corner.

2. Switch the language to be used by clicking on the desired language.

Selecting the system language

The specified system language is assigned to all user accounts by default. 

If required, you can permanently assign a (different) language to each user account.

How to set the system language:

1. Click System on the menu.

2. Click System language.

3. Select the desired language.

4. Click Save.

NOTE: The selected language is saved in the user settings of the active user. The 
next time this user logs on, the previously selected language setting is applied.

NOTE: All language settings apply to the web application as well as to the  
on-screen display (OSD) of the device and the user interface of a DynamicWork-
place-CON.

If the OSD does not support the selected language, the OSD will be displayed in 
English.
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Selecting the language for a specific user account

How to set the language of a specific user account:

1. On the menu, click Users.

2. Click the user account you want to configure, and then click Configuration.

3. Click the KVM matrix systems tab, and then click the Personal profile area selection.

4. In the Language field, choose between the following options:

5. Click Save.

System: Use the system language (see above).

[Selection] Use the selected language.
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Automatic logout
The Automatic logout function is used to automatically log out the user of the web 
application if no activity is detected for a certain period of time.

It is also possible to select whether the user is shown a timer (time counting down in 
minutes:seconds until automatic logout).

Define this period by entering a value between 1 and 60 minutes.

How to (de)activate the Auto logout function:

1. Click System on the menu.

2. Click Automatic logout.

3. In the Automatic logout of the Config Panel (0-60 minutes) field, you can define the time 
of inactivity before automatic logout between 1 and 60 minutes.

4. In the Show timer field, you can select between the following options: 

5. Click Save.

NOTE: To disable the function, enter the value 0.

NOTE: If user activity is detected, the timer is reset.

When an update process is started via the web application, the timer is also 
reset and only runs again once the update process has been completed.

On: The timer is displayed to the user at the top right of the web 
application if the entry in the Automatic logout of the Config Panel 
(0-60 minutes) is not 0 (default).

Off: No timer is displayed to the user.
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Showing terms of use
If the terms of use are displayed, they must be accepted before each (new) device 
access.

How to configure the display of terms of use:

1. Click System on the menu.

2. Click Terms of use.

3. In the Show terms of use field, you can select between the following options: 

4. If you selected User defined in the previous step, go to the Short text field and enter 
the text that a user is shown before accepting the terms of use  
(example: I have read the terms of use and hereby agree to them).  
This text field is limited to 70 characters.

5. Now enter the desired terms of use in the Long text field.  
This field is limited to 1,500 characters.

6. Click Save.

Off: No terms of use are displayed during log in (default).

User defined: Individual terms of use are displayed during log in.
G&D ControlCenter-Compact · 13



Getting started
Password complexity
You can configure password complexity to comply with your individual password 
guidelines and improve security.

How to configure the password complexity:

1. Click System on the menu.

2. Click Password complexity.

3. In the Minimum password length field, enter the desired minimum password lenght 
(Default: 3)

4. In the Minimum number of capital letters (e.g. ABCDEF) field, enter the desired minimum 
number of capital letters within a password (Default: 0)

5. In the Minimum number of lowercase letters (e.g. abcdef) field, enter the desired mini-
mum number of lowercases within a password (Default: 0)

6. In the Minimum number of digits (e.g. 012345) field, enter the desired minimum num-
ber of digits within a password (Default: 0)

7. In the Minimum number of special characters (e.g. !#%&?@) field, enter the desired 
minimum number of special characters within a password (Default: 0)

8. In the Minimum number of characters of the previous password to be changed field, enter 
the desired minimum number of characters that must be differnt compared with 
the previous password (Default: 0)

9. Click Save.

IMPORTANT: Changes in the section of password complexity have no effect on 
existing passwords, but are only taken into account when a password is changed 
(see Changing the password of a user account on page 72 ff.) and a new user account 
is created (see Creating a new user account on page 67). You should therefore 
configure the password complexity as early as possible.

IMPORTANT: Changes in the section of password complexity have no effect on user 
authentication with external directory services. The directory services have their 
own configuration options.

NOTE: The minimum number of different characters compared with the 
previous password must not be higher than the minimum password length.
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Login options
To improve security, further configuration options are available in the login options 
area.

You can specify how many failed attempts are accepted when entering a password 
and how long a user is locked out after exceeding the maximum number of failed 
attempts.

How to configure the Login options:

1. Click System on the menu.

2. Click Login optionsy.

3. In the Number of consecutive invalid login attempts up to the time of blocking (0=off) field, 
enter the desired maximum number of failed attempts when entering the 
password (Default: 0 = off/unlimited number of failed attempts, max. 1,000)

4. In the Locking time (in minutes) field, enter the desired locking time in minutes for 
which a user is locked after exceeding the maximum number of failed password 
entry attempts (Default: 1 (if max. failed attempts > 0), max. 1,440 minutes)

5. In the Limit the number of simultaneous sessions with superuser rights field, enter the 
desired number of maximum simultaneous superuser sessions  
(Default: 0 = off/unlimited number of superuser sessions, max. 1,024)

6. Click Save.

NOTE: The maximum number of simultaneous superuser sessions is effectiv per 
interface (device/OSD and ConfigPanel).
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Showing the version number of the web application 
and general information

How to show the version number of the web application and general information:

1. In the menu, click on Information.

2. The General tab provides you with information about the ConfigPanel version.

Closing the web application
Use the Close button to end the active session of the web application.

How to close the web application:

1. Click on the user icon at the top right.

2. Click on Logout to exit the active session.

ADVICE: Here you will also find a list of the IP addresses per interface.

IMPORTANT: To protect the web application against unauthorised access, always 
use the Logout function after finishing your work with the web application.
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Port administration
You can connect compatible computer or console modules or DynamicWorkplace-
CONs to each DynamicPort of the matrix switch.

In the default settings, the matrix switch autorecognizes any modules connected to 
the ports and configures the ports accordingly.

Cascading the matrix switch lets you connect more computers to the matrix switch.

For cascading, connect more matrix switches to the ports configured for this 
purpose. To facilitate installing the KVM system, switch the LEDs at the ports into 
the special port mode (see page 18).

You can change the port assignment to your requirements, but make sure to follow 
these instructions:

 Configure all ports of an IO card either as Up or as Down port.
 Configure at least one port as Up or as Down port.

Configuring ports

You can reconfigure the ports at any time. However, make sure to follow the 
instructions given in the previous paragraph.

How to configure the port mode:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Port configuration.

4. Activate the checkbox Cascade configuration enabled.

IMPORTANT: The ports that connect modules are autoconfigured. When cascaded 
(see page 223), make sure to consider the preset port mode and change it, if 
necessary.

ADVICE: The figure in the dialog shows the port configuration. 
You can switch between the port modes Up and Down.
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5. Mark the port whose mode you want to change and click Port mode to select the 
desired mode.

6. Click on Save.

Showing port modes

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the matrix switch whose port mode you want to signal.

3. Click Service Tools > Port LEDs and select Show port type.

4. The port LEDs show the current port mode:

5. To restore the default signaling, click again on Service Tools > Port LEDs and select 
Show status.

NOTE: Select multiple ports by pressing Shift or Ctrl and the left mouse key.

IMPORTANT: The matrix switch restarts after you change the port assignment.

LED Port mode

Yellow Up mode

Green Down mode

NOTE: The active Portfunction LEDs of the IO cards indicate that the port mode 
is shown.
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Basic configuration of the 
web  application

Network settings
The device provides two network interfaces (Network A and Network B). The network 
interfaces lets you integrate a device into up to two separate networks.

Configuring the network interfaces

To connect the device to a local network, you need to configure the settings of the 
network.

How to configure the settings of a network interface:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Network.

4. Go to the paragraph Interfaces.

IMPORTANT: Note the separate instructions about the Initial configuration of the net-
work  settings on page 3.

NOTE: These are the default settings:

 IP address of the network interface A: 192.168.0.1
 IP address of network interface B: Obtain address via DHCPv4
 Global network settings: Obtain settings dynamically

IMPORTANT: It is not possible to use both network interfaces within the same 
subnet.

NOTE: The Link Local address space 169.254.0.0/16 is reserved for internal 
communication between devices in accordance with RFC 3330. It is not possible 
to assign an IP address of this address space.

IMPORTANT: Configuration of IPv6 should only be performed by technically 
experienced users. While IPv6 offers advanced features and a larger address space, it 
also introduces more complex requirements regarding network structure, security, and 
compatibility. Incorrect settings may lead to connectivity issues or unexpected network 
behavior. If you are not familiar with the IP addressing and network topology specific 
to IPv6, we recommend that you thoroughly inform yourself about the implications 
before enabling IPv6, or consult with your network administration.
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5. Enter the following values under Interface A or Interface B:

6. Click on Save.

NOTE: Each network interface is assigned a unique zone ID in addition to its 
name, which specifies the interface number. This is required to uniquely 
identify the corresponding interface when using IPv6 link-local addresses.

Operating mode: Select the operational mode of Interface A or Interface B:

 Off: Disable network interface.
 Static IPv4: A static IPv4 address is assigned.
 DHCPv4: Obtain IPv4 address from a DHCP server

IPv4 address: Enter the IPv4 address of the interface (only when operating 
mode Static IPv4 is selected).

Netmask: Enter the netmask of the network (only when operating 
mode Static IPv4 is selected).

IPv6: Click the toggle switch to enable IPv6 (green/right = enabled).

Click the toggle switch to disable IPv6 (grey/left = disabled 
(default)).

IPv6 address: Enter the static IPv6 address of the interface.

Subnet prefix 
length:

Specify the prefix length (default: 64) for the interface 
according to the notation rules defined in RFC 5952.

The drop-down list shows the text Link aggregation active if the interface has 
been added to a network interface group.

In this case, configure the network interfaces under »Link aggregation«.

NOTE: When IPv6 is enabled, a link-local IPv6 address is automatically 
generated based on the MAC address of the interface by default, in accord-
ance with RFC 4921. This link-local IPv6 address cannot be modified by 
the user.
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Configuring global network settings

Even in complex networks global network settings ensure that the web application is 
available from all subnetworks.

How to configure global network settings:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Network.

4. Now go to Global network settings.

5. Enter the following values:

Operating mode: Enter the desired operating mode:

 Static: Use of static settings.
 Dynamic: Partial automatic retrieval of the settings 

described below from a DHCP server (IPv4) or via 
SLAAC (IPv6).

Hostname: Enter the hostname of the device.

Domain: Enter the domain to which the device should belong.

Gateway IPv4: Enter the IPv4 address of the gateway.

Gateway IPv6: Enter the IPv6 address of the gateway.

DNS server 1: Enter the IP address of the DNS server.. 

DNS server 2: Optionally, enter the IP address of another DNS server.. 

Prioritization of 
IPv6:

Click the toggle switch if IPv6 should be preferred when a 
destination has both an IPv6 and an IPv4 address 
(green/right = IPv6 is preferred).

Click the toggle switch if IPv6 should not be preferred 
(grey/left = IPv6 is not preferred, default).

Use IPv6 
Stateless 
Address Auto-
configuration 
(SLAAC):

Click the toggle switch if SLAAC should be used 
(green/right = SLAAC is used, default). 

Click the toggle switch if SLAAC should not be used 
(grey/left = SLAAC is not used).

NOTE: If a link-local IPv6 address is entered, the zone ID of the interface 
must be specified. The zone ID is appended to the link-local IPv6 address, 
separated by the percent sign %.

NOTE: If a link-local IPv6 address is entered, the zone ID of the interface 
must be specified. The zone ID is appended to the link-local IPv6 address, 
separated by the percent sign %.
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6. Click on Save.

Send ICMP Echo 
Reply to Echo 
Request from a 
Multicast/anycast 
address (IPv6):

Click the toggle switch if ICMPv6 Echo Requests should be 
answered (green/right = Echo Requests are answered, 
default). 

Click the toggle switch if ICMPv6 Echo Requests should not 
be answered (grey/left = Echo Requests are not answered).

Send ICMP 
destination 
unreachable 
messages (IPv6):

Click the toggle switch if an ICMPv6 error message should 
be sent to the sender when a packet cannot be delivered 
(green/right = error message is sent, default).

Click the toggle switch if no ICMPv6 error messages should 
be sent (grey/left = error message is not sent).

Process redirect 
messages (IPv6):

Click the toggle switch if redirect messages should be 
accepted and processed (green/right = redirect messages are 
processed, default). 

Click the toggle switch if redirect messages should not be 
processed (grey/left = redirect messages are not processed).

Duplicate 
Address 
Detection (IPv6):

Click the toggle switch if a check for duplicate IPv6 
addresses should be performed before an address is used 
(green/right = duplicate address check is performed, default). 

Click the toggle switch if no check for duplicate IPv6 
addresses should be performed (grey/left = no duplicate 
address check is performed).
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Increasing the reliability of network connections by link 
aggregation

By default, you can use both network interfaces at the same time to acees the web 
application from two different network segments, for example

To increase reliability, the entwork interfaces can be grouped via link aggregation. 
Within a group, only one interface is active at a time. Another interface only 
becomes active if the active interface fails.

Two different modes are available for monitoring the interfaces:

 MII mode: The carrier status of the network interface is monitored via the 
media independent interface. In this mode, only the functionality of the network is 
tested.

 ARP mode: Using the address resolution protocol, requests are sent to an ARP target on 
the network. The response from the ARP target confirms both the functionality of 
the network interface and a proper network connection to the ARP target.

If the ARP target is connected to the network but temporarily offline, the requests 
cannot be answered. For this reason, you should determine several ARP targets in 
order to obtain a response from at least one target even if an ARP target fails.

How to configure the settings of grouped network interfaces:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Network.

4. Go to the paragraph Link aggregation.

NOTE: It is not possible to combine MII and ARP mode.

NOTE: The Link Local address space 169.254.0.0/16 is reserved for internal 
communication between devices in accordance with RFC 3330. It is not possible 
to assign an IP address of this address space.
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5. Enter the following values under Network:

NOTE: The network interface is assigned a unique zone ID in addition to its 
name, which specifies the interface number. 

Name: Enter the name of the network interface group.

Operating mode: Select the operating mode for grouped network interfaces:

 Off: Disable link aggregation.
Go to »Interfaces« to configure the network interfaces (see Configuring 
the network interfaces on page 19 ff.).

 Static IPv4: A static IPv4 address is assigned.
 DHCPv4: Obtain IPv4 address from a DHCP server.

IPv4 address: Enter the IPv4 address of the interface  
(only when operating mode Static IPv4 is selected).

Netmask: Enter the netmask of the network  
(only when operating mode Static IPv4 is selected).

IPv6: Click the toggle switch to enable IPv6 (green/right = enabled).

Click the toggle switch to disable IPv6 (grey/left = disabled 
(default)).

IPv6 address: Enter the static IPv6 address of the interface.

Subnet prefix 
length:

Specify the prefix length (default: 64) for the interface 
according to the notation rules defined in RFC 5952.

NOTE: When IPv6 is enabled, a link-local IPv6 address is automatically 
generated based on the MAC address of the interface by default, in 
accordance with RFC 4921. This link-local IPv6 address cannot be 
modified by the user.
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6. Enter the following values under Parameter:

7. Click on Save.

Primary  
Follower:

Select whether data traffic should preferably be transmitted 
via the interface Network A (Interface A) or the interface 
Network B (Interface B). As soon as the selected interface is 
available, this interface is used for data traffic.

If you select the option None, the data traffic is sent via any 
interface. A switch-over occurs only if the active interface 
fails.

Link monitoring: Select whether you want to use the MII or the ARP mode  
(see explanation above) to monitor the interface.

MII down delay: Waiting period in milliseconds before a failed network 
interface is disabled.

The entered value must be a multiple of 100 ms  
(the MII link monitoring frequency).

MII up delay: Waiting period in milliseconds before a reset network 
interface is activated.

The entered value must be a multiple of 100 ms  
(the MII link monitoring frequency).

ARP interval: Enter the interval (100 to 10,000 milliseconds) after which 
the system checks for incoming ARP packets of the network 
interfaces.

ARP validate: The validation ensures that the ARP packet for a particular 
network interface has been generated by one of the specified 
ARP targets.

Select whether or which of the incoming ARP packets 
should be validated:

 None: ARP packets are not validated (default).

 Active: Only the ARP packets of the active network 
interface are validated.

 Backup:  Only the ARP packets of the inactive network 
interface are validated

 All: The ARP packets of all network interfaces of the group 
are validated.

ARP target: The table contains a list of all configured ARP targets.

Use the buttons New, Edit and Delete to manage the ARP targets.
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Reading out the status of the network interfaces

The current status of both network interfaces can be read out in the web application.

How to detect the status of the network interfaces:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Information.

4. Go to the paragraph Link status.

5. The paragraphs Interface A and Interface B include the following values:

6. Click on Save.

NOTE: The network interface is assigned a unique zone ID in addition to its 
name, which specifies the interface number. This is required to uniquely 
identify the corresponding interface when using IPv6 link-local addresses.

Link detected: Connection to the network established (yes) or interrupted 
(no).

Auto-negotiation: Both the transmission speed and the duplex method have 
been configured automatically (yes) or manually by the 
administrator (no).

Speed: Transmission speed

Duplex: Duplex mode (full or half)
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Creating and administrating netfilter rules
By default, all network computers have access to the web application ConfigPanel 
(open system access).

Once a netfilter rule has been created, open system access is disabled and all 
incoming data packets are compared with the netfilter rules. The list of netfilter rules 
is processed in the stored order. As soon as a rule applies, the corresponding action 
is executed and the following rules are ignored.   

Creating new netfilter rules

How to create a new netfilter rule:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Network.

4. Go to the paragraph Netfilter.

NOTE: The open system access allows unrestricted connections via ports 
80/TCP (HTTP), 443/TCP (HTTPS) and 161/UDP (SNMP).

NOTE: As soon as a netfilter rule is used, the Default DROP policy takes effect.

If certain IP addresses are to be accepted, it is sufficient to assign the Accept filter 
rule to them. Data packets via all other IP addresses are not processed (“dropped”) 
due to the Default DROP policy.

IMPORTANT: If data packets are only not to be processed (“dropped”) via certain
IP addresses, the Drop filter rule must be assigned to these IP addresses. The Accept
filter rule must then be assigned to the IP addresses that are to be accepted, as 
further data packets via other IP addresses will otherwise also not be processed 
(“dropped”) due to the Default DROP policy. If all other IP addresses are to be 
accepted, the Accept rule can be applied to all IP addresses (0.0.0.0/0).
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5. Enter the following values:

Interface: In the pull-down menu, select on which network interfaces 
the data packets are to be intercepted and manipulated:

 All
 Interface A
 Interface B
 Link-Aggregation group

Option: In the pull-down menu, select how to interpret the sender 
information of the rule:

 Normal: The rule applies to data packets whose sender 
information corresponds to the IP address or  
MAC address specified in the rule.

 Inverted: The rule applies to data packets whose sender 
information does not correspond to the IP address or  
MAC address specified in the rule.

IP address/ 
Prefix length:

Enter the IP address of the host or, by specifying the  
Prefix length, define the network segment.

Examples IPv4:
 192.168.150.187/32: for IP address 192.168.150.187 

If only an IP address is entered without specifying a  
prefix length, the system will automatically apply / 
32 as the prefix in the background.

 192.168.150.0/24: IP addresses of section 192.168.150.x
 192.168.0.0/16: IP addresses of section 192.168.x.x
 192.0.0.0/8: IP addresses of section 192.x.x.x
 0.0.0.0/0: all IPv4 addresses
Examples IPv6:
 2001:db8::222:4dff:fe84:3cb6/128: Only this IP address 

If only an IP address is entered without specific a  
prefix length, the system will automatically apply  / 
128 as the prefix in the background.

 fe80::/64: all link local IP addresses
 2001:db8::/64: IP addresses of space 2001:db8::/64
 ::/0: all IPv6 addresses      

MAC address: Enter the MAC address to be considered in this filter rule.

NOTE: The IP address and/or a MAC address can be specified within a rule.

NOTE: Enter link local IPv6 addresses here without a zone ID, if applicable.

NOTE: The IP address and/or a MAC address can be specified within a rule.
28 · G&D ControlCenter-Compact



Basic configuration of the web  application
6. Click on Add to save the values in a new filter rule.

The new filter rule is added to the end of the list of existing filter rules.

7. Click on Save.

Editing existing netfilter rules

How to edit an existing netfilter rule:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Network.

4. Go to the paragraph Netfilter.

5. In the list of existing netfilter rules, select the rule you want to change.

Filter rule:  Drop: Data packets whose sender information matches the 
IP address or MAC address are not processed.

 Accept: Data packets whose sender information matches 
the IP address or MAC address are processed.

Service: Select a specific service for which this rule is used 
exclusively, or choose (All).

NOTE: The new nefilter rule is not applied to active connections. Restart the device 
if you want to disconnect the active connections and then apply all the rules.
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6. The current rule settings are displayed in the upper part of the dialog. Check and 
change the following settings.

Interface: In the pull-down menu, select on which network interfaces 
the data packets are to be intercepted and manipulated:

 All
 Interface A
 Interface B
 Link-Aggregation group

Option: In the pull-down menu, select how to interpret the sender 
information of the rule:

 Normal: The rule applies to data packets whose sender 
information corresponds to the IP address or MAC 
address specified in the rule.

 Inverted: The rule applies to data packets whose sender 
information does not correspond to the IP address or MAC 
address specified in the rule.

IP address/ 
Prefix length:

Enter the IP address of the host or, by specifying the Prefix 
length, define the network segment.

Examples IPv4:
 192.168.150.187/32: for IP address 192.168.150.187 

If only an IP address is entered without specifying a prefix 
length, the system will automatically apply /32 as the 
prefix in the background.

 192.168.150.0/24: IP addresses of section 192.168.150.x
 192.168.0.0/16: IP addresses of section 192.168.x.x
 192.0.0.0/8: IP addresses of section 192.x.x.x
 0.0.0.0/0: all IPv4 addresses
Examples IPv6:
 2001:db8::222:4dff:fe84:3cb6/128: Only this IP address 

If only an IP address is entered without specific a prefix 
length, the system will automatically apply  /128 as the 
prefix in the background.

 fe80::/64: all link local IP addresses
 2001:db8::/64: IP addresses of space 2001:db8::/64
 ::/0: all IPv6 addresses        

MAC address: Enter the MAC address to be considered in this filter rule.

NOTE: The IP address and/or a MAC address can be specified within a rule.

NOTE: Enter link local IPv6 addresses here without a zone ID, if applicable.

NOTE: The IP address and/or a MAC address can be specified within a rule.
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7. Click on Apply to save your settings.

8. Click on Save.

Filter rule:  Drop: Data packets whose sender information matches the 
IP address or MAC address are not processed.

 Accept: Data packets whose sender information matches 
the IP address or MAC address are processed.

Service: Select a specific service for which this rule is used 
exclusively, or choose (All).

NOTE: The new nefilter rule is not applied to active connections. Restart the device 
if you want to disconnect the active connections and then apply all the rules.
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Deleting existing netfilter rules

How to delete existing netfilter rules:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Network.

4. Go to the paragraph Netfilter.

5. In the list of existing netfilter rules, select the rule you want to delete.

6. Click on Delete.

7. Confirm the confirmation prompt by clicking on Yes or cancel the process by 
clicking on No.

8. Click on Save.

Changing the order or priority of existing netfilter rules

The list of netfilter rules is processed in the stored order. As soon as a rule applies, 
the corresponding action is executed and the following rules are ignored.

How to change the order or priority of existing netfilter rules:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Network.

4. Go to the paragraph Netfilter.

5. In the list of existing netfilter rules, select the rule whose order/priority you want 
to change.

6. Click the button Arrow up to increase the priority or the button Arrow down to 
decrease the priority.

7. Click on Save.

IMPORTANT: Pay attention to the order or priority of the individual rules, 
especially when adding new rules.
32 · G&D ControlCenter-Compact



Basic configuration of the web  application
Creating an SSL certificate
Use the free implementation of the SSL/TLS protocol OpenSSL to create an 
SSL certificate.

The following websites provide detailed information about operating OpenSSL:

 OpenSSL project: https://www.openssl.org/ 
 Win32 OpenSSL: http://www.slproweb.com/products/Win32OpenSSL.html

The instructions on the following pages explain exemplarily how to create an 
SSL certificate.

In principle, a certificate is created in 5 steps:

1. Creating a Private Key

2. Creating a Certificate Signing Request (CSR)

3. Submitting the CSR to the CA

4. Receiving the certificate from the CA

5. Creating the PEM file

IMPORTANT: For security reasons, network certificates for the web application 
(see page 33 ff.) and, if used, additional user certificates for the KVM connection are 
not included in a backup and may have to be stored again after a restore.

IMPORTANT: Creating an SSL certificate requires the software OpenSSL. If necessary, 
follow the instructions on the websites mentioned above to install the software.
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Special features for complex KVM systems

If different G&D devices are to communicate with each other within a KVM system, 
the identical Certificate Authority (see page 34) must be used when creating certificates for 
these devices.

Alternatively, the identical PEM file (see page 38) can also be used for all devices. 
Inthis case, all characteristics of the certificates are identical.

Creating a Certificate Authority

A Certificate Authority enables the owner to create digital certificates (e. g. for a matrix 
switch.

How to create a key for the Certificate Authority:

1. Enter the following command into the command prompt and press Enter:

2. OpenSSL creates the key and stores it in a file named ca.key.

How to create the Certificate Authority:

1. Enter the following command into the command prompt and press Enter:

IMPORTANT: The following steps describe how to create keys that are not coded. 
If necessary, read the OpenSSL manual to learn how to create a coded key.

openssl genrsa -out ca.key 4096

openssl req -new -x509 -days 3650 -key ca.key -out ca.crt
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2. Now, OpenSSL queries the data to be integrated into the certificate.

The following table shows the different fields and an exemplary entry:

Enter the data you want to state, and confirm each entry by pressing Enter.

3. OpenSSL creates the key and stores it in a file named ca.crt.

Field Example

Country Name (2 letter code) DE

State or Province Name NRW

Locality Name (e.g., city) Siegen

Organization Name (e.g., company) Guntermann & Drunck GmbH

Organizational Unit Name 
(e.g., section)

Common Name (e.g., YOUR name) Guntermann & Drunck GmbH

Email Address

IMPORTANT: The device's IP address must not be entered under Common Name.

IMPORTANT: Distribute the certificate ca.crt to the web browsers using the 
web application. The certificate checks the validity and the trust of the 
certificate stored in the device.
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Creating any certificate

How to create a key for the certificate to be created:

1. Enter the following command into the command prompt and press Enter:

2. OpenSSL creates the key and stores it in a file named server.key.

How to create the certificate request:

1. Enter the following command into the command prompt and press Enter:

2. Now, OpenSSL queries the data to be integrated into the certificate.

The following table shows the different fields and an exemplary entry:

Enter the data you want to state, and confirm each entry by pressing Enter.

3. If desired, the Challenge Password can be defined. This password is needed if you 
have lost the secret key and the certificate needs to be recalled.

4. Now, the certificate is created and stored in a file named server.csr.

IMPORTANT: The following steps describe how to create keys that are not coded. 
If necessary, read the OpenSSL manual to learn how to create a coded key.

openssl genrsa -out server.key 4096

openssl req -new -key server.key -out server.csr

Field Example

Country Name (2 letter code) DE

State or Province Name NRW

Locality Name (e.g., city) Siegen

Organization Name (e.g., company) Guntermann & Drunck GmbH

Organizational Unit Name 
(e.g., section)

Common Name (e.g., YOUR name) 192.168.0.10

Email Address

IMPORTANT: Enter the IP address of the device on which the certificate is to be 
installed into the row Common Name.
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Creating and signing an X509 certificate

1. Enter the following command into the command prompt and press Enter:

2. OpenSSL creates the certificate and stores it in a file named server.crt.   

openssl req -x509 -days 3650 -in server.csr -CA ca.crt -CAkey ca.key -set_serial 01 -out 
server.crt

IMPORTANT: If you do not create the certificats as explained in the previous 
sections, but use your own certificates with certificate extensions, the 
command to be entered must be adapted or extended accordingly.

EXAMPLE: If you use Extended Key Usage to restrict the permitted use of the key, 
at least the serverAuth and clientAuth extensions must be activated or taken into 
account: 

openssl req -x509 -days 3650 -in server.csr -CA ca.crt -CAkey ca.key -set_serial 01 -out 
server.crt -addext 'extendedKeyUsage = serverAuth, clientAuth'

ADVICE: To check which certificate extensions are used, use: 

openssl x509 -text -in ca.crt
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Creating a PEM file

1. Enter the following command(s) into the prompt and press Enter:

a. Linux

b. Windows

2. The gdcd.pem file is created while copying. It contains the created certificate and its 
key as well as the Certificate Authority.

NOTE: The .pem file contains the following three components:

 server certificate
 private server key
 certificate of the certification authority

If these three components are available separately, enter them successively to the 
Clear text entry before updating the certificate stored in the device.

cat server.crt > gdcd.pem
cat server.key >> gdcd.pem
cat ca.crt >> gdcd.pem

copy server.crt + server.key + ca.crt gdcd.pem
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Selecting an SSL certificate
By default, each G&D device with integrated web application stores at least one 
SSL certificate. The certificate has two functions:

 The connection between web browser and web application can be established via 
an SSL-secured connection. In this case, the SSL certificate allows the user to 
authenticate the opposite side.
If the device’s IP address does not match the IP address stored in the certificate, 
the web browser sends a warning message.

 The communication between G&D devices within a system is secured via the 
devices’ certificates.

How to select the SSL certificate you want to use:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Network.

4. Go to the paragraph Certificate.

ADVICE: You can import a user certificate so that the device’s IP address 
matches the IP address stored in the certificate.

IMPORTANT: Communication between devices is possible only if all devices 
within a KVM system use certificates of the same Certificate Authority
(see page 34).

IMPORTANT: After activating another certificate, close the currently active 
»Config Panel« sessions and start new sessions.
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5. Select the certificate you want to use:

6. Click on Save.

G&D certificate #1: This certificate is enabled for new devices.

G&D certificate #2: This certificate is supported by some older G&D devices 
with integrated web application.

User certificate: Select this option if you want to use a certificate purchased 
from a certificate authority or if you want to use a user 
certificate.

Now you can import and upload the certificate:

 Click on Import certificate from file and use the file dialog to 
select the .pem file you want to import.
You can also copy the plain text of the server certificate, 
the server’s private key and the certificate of the 
certificate authority to the text box.

 Click on Upload and activate to store and activate the 
imported certificate for the device.

IMPORTANT: For security reasons, network certificates for the web application (see 
page 33 ff.) and, if used, additional user certificates for the KVM connection are not
included in a backup and may have to be stored again after a restore.

NOTE: Make sure that you use the same certificate for all devices within the 
KVM system.
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Firmware update
The firmware of each device of the KVM system can be updated via the 
web application.

Firmware update of a single device

How to execute a firmware update of a single device:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to update.

3. Open the menu Service tools and select the entry Firmware update.

4. Click on Supply firmware image files.

Select the firmware file on your local disk and click on Open.

The firmware file is transferred to the internal storage and can then be selected 
for the update.

5. Select the firmware files to be used from the internal storage and click on Continue.

6. Select the Intended version of the devices if you selected more than one firmware 
files for one device.

7. Move the Update slider to the right (green) in the rows of all devices to be updated.

8. Click on Start update.

IMPORTANT: This function only updates the firmware of the device on which the 
web application was started.

NOTE: If the firmware file is already available in the internal storage, you can skip 
this step.

NOTE: Multiple selection of firmware files is possible by simultaneously 
pressing the Shift or Ctrl key and the left mouse button.

IMPORTANT: Do not close the browser session while the device is being updated! 
Do not turn off the product or disconnect it from the power supply during the 
update.
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Firmware update of multiple KVM system devices

How to execute a firmware update of multiple KVM system devices:

1. In the menu, click on System.

2. Click on System update.

3. Select the devices whose firmware you want to update and click Firmware update.

4. Click on Supply firmware image files.

Select the firmware file on your local disk and click Open.

The firmware file is transferred to the internal storage and can then be selected 
for the update.

5. Select the firmware files to be used from the internal storage and click Continue.

6. Select the Intended version of the devices if you selected more than one firmware 
files for one device.

7. Move the Update slider to the right (green) in the rows of all devices to be updated.

8. Click on Start update.

NOTE: For devices for which a firmware update is currently not possible, the 
reason for this is displayed in the Status field.

NOTE: If the firmware file is already in the internal storage, you can skip this step.

NOTE: Multiple selection of firmware files is possible by simultaneously 
pressing the Shift or Ctrl key and the left mouse button.

NOTE: In order to ensure the transfer of updates to the end devices for larger data 
volumes, the end devices are updated in groups as required.

IMPORTANT: Do not close the browser session while the devices are being updated! 
Do not turn off the products or disconnect them from the power supply during the 
update.
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Restoring the system defaults
With this function, the system defaults of the device on which the web application is 
operated can be restored.

How to restore the system defaults:

1. In the menu, click on System.

2. Click on System defaults.

3. Select the scope of the recovery:

4. Click on Set system defaults.

Restarting the device
This function restarts the device. Before restarting, you will be prompted for 
confirmation to prevent an accidental restart.

How to restart the device using the web application:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the desired device.

3. Open the menu Service tools and select the entry Restart.

4. Confirm the confirmation prompt with Restart.

Reset all settings: Reset all settings of the device.

Reset only local network settings: Reset only local network settings.

Reset only KVM application 
settings:

Reset all settings except the local network 
settings.
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Network functions of the devices
The devices within the KVM system provide separate network functions.

The following functions can be configured for each device within the KVM system:

 Authentication against directory services (LDAP, Active Directory, RADIUS)
 Time synchronisation via NTP server
 Forwarding of log messages to syslog servers
 Monitoring and control of computers and network devices via Simple Network 

Management Protocol (see page 58 ff.)

NTP server
The date and time of a device can be set either automatically by time 
synchronization with an NTP server (Network Time Protocol) or manually.

Time sync with an NTP server

How to change the NTP time sync settings:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Network.
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4. Go to the paragraph NTP server and enter the following values:

5. Click on Save.

General

NTP time sync: By selecting the corresponding entry in the pull-down menu, 
you can enable or disable the time synchronization:

 Disabled (default)
 Enabled

Time zone: Use the pull-down menu to select the time zone of your 
location.

NTP server 1

Address: Enter the IP address of a time server.

Authentication: By selecting the corresponding entry in the pull-down menu, 
you can enable or disable the authentication:

 Disabled (default)
 SHA1

Key ID: After enabling the authentication, enter the key ID that can 
be used for key authentication with the NTP server.

Key: Enter the key in the form of up to 40 hex digits.

NTP server 2

Address: Optionally enter the IP address of a second time server.

Authentication: By selecting the corresponding entry in the pull-down menu, 
you can enable or disable the authentication:

 Disabled (default)
 SHA1

Key ID: After enabling the authentication, enter the key ID that can 
be used for key authentication with the NTP server.

Key: Enter the key in the form of up to 40 hex digits.
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Manual setting of time and date

How to manually set the time and date of the device:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Network.

4. Go to the paragraph NTP server.

5. Go to the entry Time under Time/date to enter the current time (hh:mm:ss).

6. Go to the entry Date under Time/date to enter the current time (DD.MM.YYYY).

7. Click on Save.

IMPORTANT: If necessary, disable the NTP time sync option. Otherwise, 
you might not be able to set time and date manually.

ADVICE: Click on Accept local date to copy the current system date of the 
computer on which the web application was opened to the Time and Date
fields.
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Logging syslog messages
The syslog protocol is used to transmit log messages in networks. The log messages 
are transmitted to a syslog server that logs the log messages of many devices in the 
computer network.

Among other things, eight different severity codes have been defined to classify the 
log messages:

The web application enables you to configure whether the syslog messages are to be 
locally logged or sent to up to two syslog servers.

 0: Emergency
 1: Alert
 2: Critical

 3: Error
 4: Warning
 5: Note

 6: Info
 7: Debug

EXAMPLE: When using severity code 6 (default), the following events are logged 
with time stamp (ISO8601) and other information, for example:

 User login: Which user has logged on to which device and is the user already 
logged on to another device (usercount N)

 Login failure: An incorrect login attempt was made on which device  
(even when using severity level 5)

 User rights change: Which user has made a change to rights via which device
 Connection to a remote target: Which user has connected to which remote 

target on which device via which RemoteAccess-IP-CPU
 (Auto)backup failure: For which device has an (auto)backup failed  

(even when using severity level 3)

NOTE: The selected severity and all lower severity levels are logged.
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Local logging of syslog messages

How to locally log syslog messages:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Network.

4. Go to the paragraph Syslog enter the following data under Syslog local:

5. Click on Save.

Syslog local: By selecting the corresponding entry in the pull-down menu, 
you can enable or disable the local logging of syslog 
messages:

 Disabled
 Enabled (default)

Log level: In this pull-down menu, select the severity from which a log 
message is to be logged (Default: 6 - Info).

The selected severity and all lower severity levels are logged.

If you select the severity 2 - Critical, messages for this code as well as for the 
severity levels 1 - Alert and 0 - Emergency are logged.
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Sending syslog messages to a server

How to send syslog messages to a server:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Network.

4. Go to the paragraph Syslog and enter the following values under Syslog server 1 or 
Syslog server 2:

5. Click on Save.

Syslog server: By selecting the corresponding entry in the pull-down 
menu, you can enable or disable the sending of syslog 
messages to a server:

 Disabled (default)
 Enabled

Log level: In this pull-down menu, select the severity level from 
which a log message is to be logged.

The selected severity level and all lower severity levels 
are logged.

IP address/ 
DNS name:

Enter the IP address or the FQDN of the destination 
server for the syslog messages.

Port: Enter the port - usually 514 - on which the syslog server 
accepts incoming messages.

Protocol: Select the protocol - usually UDP - on which the syslog 
server accepts incoming messages:

 TCP
 UDP

If you select the severity 2 - Critical, messages for this code as well as for the 
severity levels 1 - Alert and 0 - Emergency are logged.
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Viewing and saving local syslog messages

If the function to log the local syslog messages is activated, these syslog messages 
can be viewed and, if necessary, stored in the information dailog.

How to view and store local syslog messages:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to configure.

3. Open the menu Service tools and select the entry Syslog.

4. Click on Retrieve syslog.

The local syslog messages are now retrieved and displayed in the text field.

5. Click on the red [X] to close the window.

User authentication with directory services
In internal corporate networks, user accounts are often managed centrally by a 
directory service. The device can access such a directory service and authenticate 
users against the directory service.

The directory service is used exclusively to authenticate a user. Rights are granted by 
the database of the KVM system. The following paragraphs describe the different 
scenarios:

 The user account exists in the directory service and in the KVM system
The user can log on with the password stored in the directory service. After a 
successful login, the rights of the account with the same name are assigned to the 
user in the KVM system.

ADVICE: Click on Save syslog to save the messages in a text file.

NOTE: If the directory service fails to authenticate the user account Admin, the user 
account is authenticated against the database of the device.

NOTE: The password with which the user has successfully logged on is transferred 
to the database of the KVM system.
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 The user account exists in the directory service, but not in the KVM system
A user who has been successfully authenticated against the directory service but 
does not have an account of the same name in the KVM system's database will be 
granted the rights of a RemoteAuth user.
If required, change the rights of this particular user account to set the rights for 
users without a user account.

 The user account exists in the KVM system, but not in the directory service
If the directory service is available, it reports that the user account does not exist. 
Access to the KVM system is denied to the user.
If the server is not available but the fallback mechanism is activated, the user can 
log on with the password stored in the KVM system.

How to configure the authentication of user accounts:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Network.

4. Go to the paragraph Authentication.

ADVICE: Deactivate the RemoteAuth user to prevent users without user accounts 
to log on to the KVM system.

IMPORTANT: In order to prevent the logon of a user locked or deactivated in 
the directory service when the connection to the directory service fails, please 
observe the following security rules:

 If a user account is deactivated or deleted in the directory service, this action 
must also be carried out in the user database of the KVM system!

 Activate the fallback mechanism only in exceptional cases.

IMPORTANT: When using two-factor authentication  
(see Setting up two-factor authentication on the device (optional) on page 53),  
the fallback mechanism cannot be used.

NOTE: If no directory service is used, the user accounts are managed by the device.
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5. Enter the following values under Authentication service:

6. Click on Save.

Authentication 
server:

Select the Local option if the user administration is to be carried 
out by the KVM system.

If you want to use a certain external directory service, 
select the corresponding entry from the pull-down menu:

 LDAP
 Active Directory
 Radius

After selecting a external directory service, enter the settings 
of the directory service server in the corresponding dialog 
box.

Fallback: Activate this option if you want to use the local user 
administration of the KVM system if the directory service is 
temporarily unavailable.

IMPORTANT: When using two-factor authentication, the fallback mechanism 
cannot be used 
(see Setting up two-factor authentication on the device (optional) on page 53).

NOTE: User names can be subject to a naming convention when using 
external directory services (see Creating a new user account on page 67).

ADVICE: When using LDAP or Active Directory, enter the path from which the 
respective search should be started in the Base DN/SearchScope field. This saves 
time and prevents an unnecessarily long search.

IMPORTANT: In order to prevent the logon of a user locked or deactivated 
in the directory service when the connection to the directory service fails, 
please observe the following security rules:

 If a user account is deactivated or deleted in the directory service, this 
action must also be carried out in the user database of the KVM system!

 Activate the fallback mechanism only in exceptional cases.
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Setting up two-factor authentication on the device 
(optional)
Standard user authentication involves querying a password. To provide a greater level 
of security, optional two-factor authentication (2FA) can be used to query a second 
factor based on a device in the user’s possession. 2FA makes use of a time-based  
one-time password (TOTP). Authenticator apps or hardware tokens can be used.

To enable use of 2FA, support for it must first be activated on the relevant device.

How to activate 2FA on the device:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Double-click the device that is to be configured.

3. Click on the tab Network.

4. Select the section 2-factor authentication (2FA).

IMPORTANT: If you no longer have access to your possession-based factor or if it is 
broken, you will lose access to the system. Take precautions by, for example, 
keeping the emergency codes in a safe place if you are using the internal OTP 
server and configuring settings that will minimise the risk of losing access 
(see Activating two-factor authentication (optional) on page 68). 
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5. In the sector 2-factor authentication, enter the following data:

6. Click on Save.

Information on activating two-factor authentication is provided on page 68.

2FA support:  Disabled (default)
 Enabled

OTP server: Select the option Internal (default), if you will be using an 
authentication server that is provided in the device.

If you want to use a specific external directory service, select 
the corresponding entry from the pull-down menu:

 LDAP
 Active Directory
 Radius

Once you have selected a directory service, enter the settings 
for the directory service server in the dialogue screen that 
opens.

Login only for 
users with  
configured  
2FA:

If the internal OTP server is used, you can specify whether 
login for users without activated 2FA will permitted (default) 
or prevented. This option can be used to set up a transition 
period for setting up the OTPs, for example.

 No (default)
 Yes

IMPORTANT: Use time sync with an NTP server (see page 44). Alternatively, 
you can set the time and date manually (see page 46).

NOTE: Note that usernames may be subject to a naming convention if a direc-
tory service is used (see Creating a new user account on page 67).

IMPORTANT: If an external directory service is used, the second factor will be 
required for every user profile on login.
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Monitoring functions
Under Matrix systems and System monitoring you can view the monitoring values of any 
devices connected to the KVM system.

The following exemplary figure shows the monitoring values Status, Main power and 
Temperature of a device:

The values configured for the table view (see Configuring table columns on page 8) are 
listed in the table.

You can see immediately from the colour whether the status is correct (green) or 
critical (red). The text displayed in the column also provides information about the 
current status.

Viewing all monitoring values
You can see the list of all monitoring values under Matrix systems.

How to show a list of all monitoring values:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to check and then click on Configuration.

3. Click on the tab Monitoring.

The displayed table contains a list of all available monitoring values.

4. Click on Close.

Figure 4: Detailed view of an exemplary monitoring table
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Enabling/disabling monitoring values

You can switch each monitoring value on and off separately or you can switch all 
monitoring values on or off together.

Deactivated monitoring values are not displayed in the web application.

How to enable/disable an individual monitoring value:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Monitoring.

4. Turn the slider in the column Enabled of the desired monitoring value to the right 
(enabled) or to the left (disabled).

5. Click on Save.

How to enable/disable all monitoring values:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Monitoring.

4. Mark or unmark the Enabled checkbox in the column header to switch all values 
on or off.

5. Click on Save.

IMPORTANT: The web application does not give any warnings about deactivated 
monitoring values and does also not send any SNMP traps for these values.
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Advanced features for managing critical devices
The Monitoring status icon (see User interface on page 6) shows you at a glance whether 
all monitoring values are within the normal range (green icon) or if at least one 
monitoring value is outside the normal range (yellow or red icon).

The Monitoring status icon always takes the colour of the most critical monitoring value

Displaying the list of critical monitoring values

If the Monitoring status icon is displayed in yellow or red, you can access  
the Active alarms dialog by clicking on the icon.

The Active alarms dialog shows any critical values.

Confirm the alarm of a critical device

Many alarm messages require immediate action by the administrator. Other alarms 
(for example, the failure of the redundant power supply), on the other hand, indicate 
possibly uncritical circumstances.

In such a case, you can confirm the alarm message of a value. The value is thus 
downgraded from Alarm (red) to Warning (yellow).

How to acknowledge the monitoring message of a device:

1. Click on the red Monitoring status icon at the top right.

2. Select the alarm you want to acknowledge.

3. Click on Confirm.
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Monitoring devices via SNMP
The Simple Network Management Protocol (SNMP) is used to monitor and control 
computers and network devices.

Practical use of the SNMP protocol
A Network Management System (NMS) is used to monitor and control computers and 
network devices. The system queries and collects data from the agents of the 
monitored devices.

If an agent detects a serious event on the device, it can automatically send a trap
packet to the Network Management System. This ensures that the administrator is 
informed about the event at short notice.

Configuring an SNMP agent

How to configure an SNMP agent:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Network.

4. Go to the paragraph SNMP agent.

IMPORTANT:  Chinese and Cyrillic characters are not supported by many network 
management systems.

Therefore, make sure that the passwords you use do not contain such characters!

NOTE: An agent is a program that runs on the monitored device and determines its 
status. The determined data is transmitted to the Network Management System via 
SNMP.
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5. Enter the following values under Global:

6. If you want to process packets of protocol version SNMPv2c, enter the data listed 
on the following page in the section with the same name.

Status: Select the particular entry to either switch the SNMP agent 
off (Disabled) or on (Enabled).

Protocol: Select the protocol (TCP or UDP) – usually UDP – to be used 
to transmit the SNMP packets.

Port: Define the port – usually 161 – on which the incoming SNMP 
packets are to be accepted.

SysContact: Enter the admin’s contact data (e.g. direct dial or e-mail 
address).

SysName: Enter the device name.

SysLocation: Enter the location of the device.

Access: Activate read access (View), write access (Full) or deny access 
(No) via the SNMPv2c protocol.

Source IPv4: Enter the IP address of the host or the network segment from 
which SNMP packets should be received.

Examples:
 192.168.150.187/32: Only IP address 192.168.150.187
 192.168.150.0/24: IP addresses of space 192.168.150.x
 192.168.0.0/16: IP addresses of space 192.168.x.x
 192.0.0.0/8: IP addresses of space 192.x.x.x

Source IPv6: Enter the IP address of the host or the network segment from 
which SNMP packets should be received.

Examples:
 2001:db8::222:4dff:fe84:3cb6/128: Only this IP address
 2001:db8::/64: IP addresses of space 2001:db8::/64
 fe80::/64: all link local IP addresses  

Read-only 
community:

Enter the name of the Community which has also been 
selected in the Network Management System.

IMPORTANT: The password (Community) of the packages of protocol version 
SNMPv2c is transmitted unencrypted and can therefore be easily tapped.

If necessary, use the protocol version SNMPv3 (see below) and a high 
security level to ensure secure data transmission.

NOTE: Enter link local IPv6 addresses here without a zone ID, if applicable.
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7. If you want to process packets of protocol version SNMPv3c, enter the data in the 
section with the same name:

Access: Activate read access (View) or deny access (No) via the 
SNMPv3c protocol.

User: Enter the username for the communication with the 
Network Management System.

Authentication 
protocol:

Select the authentication protocol which has been activated 
in the Network Management System:

 SHA-1
 SHA-224
 SHA-256
 SHA-384
 SHA-512 (default)
 MD5

Authentication 
passphrase:

Enter the authentication passphrase for the communication 
with the Network Management System.

Security level: Select one of the following options:

 NoAuthNoPriv: user authentication and Privacy protocol 
deactivated

 AuthNoPriv: user authentication activated, Privacy protocol 
deactivated

 AuthPriv: user authentication and Privacy protocol 
activated

Privacy protocol: Select the privacy protocol which has been activated in the 
Network Management System:

 AES128
 AES192
 AES256 (default)
 DES.

Privacy 
passphrase:

Enter the privacy passphrase for secure communication with 
the Network Management System.

NOTE: As it is now known that MD5 does not offer collision resistance it is not 
recommended to use it.

NOTE: Due to the short key length of DES, its use is not recommended.
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8. Click on Save.

Adding and Configuring SNMP traps

How to add a new trap or edit an existing trap:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the tab Network.

3. Go to the paragraph SNMP trap.

4. Click on Add or on Edit.

5. Enter the followng values under Global:

Engine ID method: Select how the SnmpEngineID should be assigned:

 Random: The SnmpEngineID is re-assigned with every 
restart of the device.

 Fix: The SnmpEngineID is the same as the MAC address of 
the device’s network interface.

 User: The string entered under Engine ID is used as 
SnmpEngineID.

Engine ID: When using the Engine ID method User, enter the string that 
is used as Engine ID.

Server: Enter the IP address of the Network Management Server.

Protocol: Select the protocol (TCP or UDP) – usually UDP – to be used 
to transmit the SNMP packets.

Port: Enter the port – usually 162 – on which outgoing SNMP packets 
are transmitted.

Retries: Enter the number of retries to send an SNMP Inform.

Timeout: Enter the timeout (in seconds) after which an SNMP Inform
will be resent if no confirmation is received.

NOTE: Inputs are only possible if the Inform option is selected in the Notification 
type field.

NOTE: Inputs are only possible if the Inform option is selected in the field 
Notification type.
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6. If you selected protocol version SNMPv2c in the last step, enter the name of the 
Community, which was also selected in the Network Management System.

7. If you selected protocol version SNMPv3 in step 5, enter the following data in the 
section with the same name:

Log level: Select the severity of an event from which an SNMP trap is 
to be sent.

The selected severity and all lower severity levels are logged.

Version: Select if the traps are to be created and sent according to the 
SNMPv2c (v2c) or SNMPv3 (v3) protocol.

Notification type: Select if events are sent as Trap or Inform packet.

IMPORTANT: The password (Community) of the packages of protocol version 
SNMPv2c is transmitted unencrypted and can therefore be easily tapped.

If necessary, use the protocol version SNMPv3 (see below) and a high 
security level to ensure secure data transmission.

Username: Enter the username for the communication with the Network 
Management System.

Authentication 
protocol:

Select the authentication protocol which has been activated 
in the Network Management System:

 SHA-1
 SHA-224
 SHA-256
 SHA-384
 SHA-512
 MD5 (default) 

Authentication 
passphrase:

Enter the authentication passphrase for secure 
communication with the Network Management System.

NOTE: If you select the severity 2 - Critical, SNMP traps will be sent for 
events of this severity level as well as for events of the severity levels 
1 - Alert and 0 - Emergency.

NOTE: Inform packets require a confirmation of the Network Management 
System. If this confirmation is not available, transmission is repeated.

NOTE: As it is now known that MD5 does not offer collision resistance it is not 
recommended to use it.
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8. Click on Save.

How to delete an existing trap:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the tab Network.

3. Go to the paragraph SNMP trap.

4. In the row of the receiver you want to delete, click on Delete.

5. Click on Save.

Security level: Select one of the following options:

 NoAuthNoPriv: user authentication and Privacy protocol 
deactivated

 AuthNoPriv: user authentication activated, Privacy protocol 
deactivated

 AuthPriv: user authentication and Privacy protocol activated

Privacy protocol: Select the privacy protocol which has been activated in the 
Network Management System:

 AES128
 AES192
 AES256
 DES (default).

Privacy 
passphrase:

Enter the privacy passphrase for secure communication with 
the Network Management System.

Engine ID: Enter the Engine ID of the trap receiver.

NOTE: Due to the short key length of DES, its use is not recommended.
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Users and groups

Efficient rights administration
The web application administrates up to 1,024 user accounts as well as the same 
amount of user groups. Any user within the system can be a member of up to 
20 groups.

User accounts and user groups can be provided with different rights to operate the 
system.

The effective right

The effective right determines the right for a particular operation.

EXAMPLE: The user JDoe is member of the groups Office and ComputerModuleConfig. 

The following table shows the user account rights, the rights of the assigned groups 
and the resulting effective right:

ADVICE: Rights administration can be carried out almost completely through user 
groups. Therefore, user groups and the assigned rights have to be planned and 
implemented beforehand. 

This way, user rights can be changed quickly and efficiently.

IMPORTANT: The effective right is the maximum right, which consists of the user 
account’s individual right and the rights of the assigned group(s).

Right User
JDoe

Group
Office

Group
Computer-

ModuleConfig

Effective 
right

Computer  
module config 

No No Yes Yes

Change own 
password 

No Yes No Yes

(Computer  
module) Access 

Yes View No Yes
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The settings of the Computer module config and Change own password rights result from 
the rights assigned to the user groups. The (Computer module) Access right is given 
directly in the user account.

The dialogue windows of the web application additionally display the effective right 
for every setting.

Efficient user group administration

User groups let you create a shared right profile for multiple users with identical 
rights. Furthermore, any user accounts included in the member list can be grouped 
and therefore no longer have to be individually configured. This facilitates the rights 
administration within the system.

If the rights administration takes place within user groups, the user profile only stores 
general data and user-related settings (key combinations, language settings, …).

When initiating the system, it is recommended to create different groups for users 
with different rights (e. g. »Office« and »IT«) and assign the respective user accounts to 
these groups.

EXAMPLE: Create more groups if you want to divide the user rights even further. If, 
for example, you want to provide some users of the »Office« group with the Change 
device configuration right, you can create a user group for these users:

 Create a user group (e. g., »Office_Change device configuration«) with identical settings 
for the »Office« group. The Change device configuration right is set to Yes. Assign the 
respective user accounts to this group.

 Create a user group (e. g., »Change device configuration«) and set only the Change device 
configuration right to Yes. In addition to the »Office« group, also assign the respective 
user accounts to this group. 

In both cases, the user is provided with the Yes effective right for Change device 
configuration.

ADVICE: Click on the i button to get a list of the groups and rights assigned to the 
user account.

ADVICE: The user profile lets you provide extended rights to a group member.
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Administrating user accounts
User accounts let you define individual rights for every user. The personal profile 
also provides the possibility to define several user-related settings.

IMPORTANT: The administrator and any user assigned with the Superuser right are 
permitted to create and delete user accounts and edit rights and user-related settings.
66 · G&D ControlCenter-Compact



Users and groups
Creating a new user account

The web application manages up to 1,024 user accounts. Each user account has 
individual login data, rights and user-specific settings for the KVM system.

How to create a new user account:

1. In the menu, click on User.

2. Click on Add user.

3. Enter the following values in the dialog box:

4. Click on Save.

5. If two-factor authentication is activated on the device (see page 53), the settings 
for the user account must be made in the next step (see page 68).

IMPORTANT: If an individual password policy is to be taken into account, you 
must configure the password complexity (see Password complexity on page 14) 
before creating a new user account.

Name: Enter a user name.

Password: Enter the user account password.

Confirm password: Repeat the password.

Clear text: If necessary, mark this entry to view and check both 
passwords.

Full name: If desired, enter the user’s full name.

Comment: If desired, enter a comment regarding the user account.

Enabled: Mark this checkbox to activate the user account.

IMPORTANT: After the user account has been created, it does not have any rights 
within the KVM system.

NOTE: User names can be subject to a naming convention when using  
external directory services  
(see User authentication with directory services on page 50 ff.).

NOTE: If the user account is deactivated, the user is not able to access the 
KVM system.
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Activating two-factor authentication (optional)

If the internal OTP server is used for 2FA, it can be activated for almost any user 
profile (exception: user RemoteAuth and user SyncSwitching). To generate the security 
key for activation, various controlling parameters are used in addition to the key 
itself, which can be generated automatically. The key and the controlling 
parameters can be modified by the user. This is necessary for setting up hardware 
tokens. If authenticator apps are used, the parameters do not generally need to be 
modified.

NOTE: To use optional two-factor authentication, it first needs to be set up on the 
device (see page 53).

IMPORTANT: If an external directory service is used  
(see Setting up two-factor authentication on the device (optional) on page 53 ff.),  
2FA is activated automatically for each user profile in the database. This means 
that login from the device is only possible if the external OTP server has identical 
user profiles and the second factor is validated successfully.

IMPORTANT: To activate or deactivate 2FA for a user profile, the user needs 
superuser rights (see page 82), or the user must be logged in with the 
corresponding user profile (see page 82) and have the right Change own password
(see page 83).

IMPORTANT: Use time sync with an NTP server (see page 44). Alternatively, you 
can set the time and date manually (see page 46).

NOTE: 2FA can be activated for almost all user profiles. The only exception are the 
user RemoteAuth and the user SyncSwitching.
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How to activate 2FA in the user account:

1. In the menu, click on User.

2. Click on the user account that is to be configured and then click on Configuration.

3. Click on Edit in the line 2-factor authentication.

4. Select Enabled in the section 2FA for this user.

5. Enter the following data in the menu:

Encryption key: When the parameter 2FA for this user is changed from Disabled
to Enabled, a encryption key is generated and displayed 
automatically.

Click on Generate to obtain a new encryption key.

Hash algorithm:  SHA1
 SHA256 (default)
 SHA512

Validity period 
(secs):

Enter how long the 2-Factor Auth Code (TOTP) should 
remain valid. The value entered must be between 10 and 200
seconds (default: 30 seconds).

Length of  
2-Factor Auth 
Code (TOTP):

 6 digits (default)
 8 digits

2-Factor Auth 
Code (TOTP)  
window width:

The window width specifies how many previous 2-Factor Auth 
Codes (TOTP) are valid in addition to the current one. It is not
possible to allow future 2-Factor Auth Codes (TOTP). The 
value entered must be between 1 and 20 (default: 1).

Show QR code & 
copy security key:

Clicking the button validates the entries that have been made. 
A security key is generated and a QR code is displayed that 
contains the generated security key and that can be used to 
scan in with an authenticator app. The security key is copied 
to the clipboard.

Verification code: Enter a verification code here that you receive from a hardware 
token or an authenticator app that you are using. Only numbers 
can be entered in this field.

IMPORTANT: Base32 format must be used for the entry.

ADVICE: It is a good idea to avoid selecting a validity period that is too short, 
as access problems could otherwise occur if the time is not synchronised 
correctly.

ADVICE: To avoid access problems from occurring as the result of the time not 
being synchronised correctly, it can be a good idea to permit several previous 
2-Factor Auth Codes (TOTP).
G&D ControlCenter-Compact · 69



Users and groups
6. Click on Save.

Once 2FA has been activated in the user acoount, the 2-Factor Auth Code (TOTP) 
will be queried in addition to the username and password on login (see Starting the 
web application on page 4).

IMPORTANT: Following successful activation of 2FA, it the internal OTP server is 
used, the additional button Emergency codes is displayed in the line 2-factor 
authentication. If you click this button, five emergency codes will be displayed. Each 
of these emergency codes enables a user account to be accessed once only. These 
codes are not limited to a specific time period. The codes should be kept in a safe 
place. The emergency codes can be used, for example, if a hardware token is lost 
to enable continued access to the system.

Click on Get new codes to create five new codes.

NOTE: A user who has been successfully authenticated against the directory 
service but who does not have an account with the same name in the database of 
the KVM system will be given the rights of the user RemoteAuth. 

The 2-Factor Auth Code (TOTP) is validated by the configured external OTP 
server.

Change the rights of this special user account to configure the rights of users without 
their own account (see Changing the user account rights on page 73).

Deactivate the user RemoteAuth to prevent users from logging in to the 
KVM system without their own user acoount (see Enabling or disabling a user account
on page 76).
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Renaming a user account

How to change the name of a user account:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Enter the username under Name.

4. Optional: Enter the user’s full name under Full name

5. Click on Save.

NOTE: User names can be subject to a naming convention when using external 
directory services (see User authentication with directory services on page 50 ff.).
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Changing the password of a user account

How to change the password of a user account:

1. In the menu, click on Users.

2. Click on the user account you want to configure and then click on Configuration.

3. Change the following values in the dialog box:

4. Click on Save.

NOTE: The activated Superuser right  
(see Rights for unrestricted access to the system (Superuser) on page 82 ff.)  
or the right Change own password  
(see Rights to change your own password on page 83 ff.)  
are prerequisite for changing the password of a user account.

NOTE: When changing the password, any defined password policies  
(see Password complexity on page 14) are taken into account.

Current password: Enter the current password.

New password: Enter the new password.

Confirm password: Repeat the new password.

Clear text: Mark this entry to view and check entered passwords.

Verification code: Enter the 2-Factor Auth Code (TOTP) from  
two-factor authentication.

NOTE: No entry is required in this field for users with activated superuser 
rights (see page 82 ff.).

NOTE: The 2-Factor Auth Code (TOTP) is only requested if 
two-factor authentication has been configured (see page 53 f.) 
and activated (see page 68 ff.).
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Changing the user account rights

Any user account can be assigned with different rights.

The following tables lists the different user rights. Further information on the rights 
can be found on the indicated pages.

System rights

Global device rights

Name Right Page

Superuser right Unrestricted access to the configuration of the 
system

page 82

Config Panel Login Login to the ConfigPanel web application page 82

EasyControl Login Access to EasyControl tool page 83

Change own password Change own password page 83

Confirm monitoring 
alert

Confirmation of a monitoring alarm page 83

Name Right Page

Edit personal 
profile

Change personal user settings page 251

Computer module  
config

Configuration of computer modules page 100

Permission to replace 
device

Execution of the „Replace device“-function page 84

MultiAccess Access type when a computer module is  
simultaneously accessed

page 94

Access to exclusive 
signals

Access to exclusive signals page 122

Access to USB devices Access USB devices page 97
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Computer module rights and device group rights

Console module rights

Scripting rights and scripting group rights  

Name Right Page

Access Access to a computer module or a computer 
module group

page 91

Device power Switching the power outlets of a  
computer module or a computer module group

page 236

MultiAccess Access type when a computer module is  
simultaneously accessed

page 94

Access to exclusive 
signals

Access to exclusive signals page 122

Access to USB devices Access USB devices page 97

Name Right Page

Push-Get Carry out Push-Get function page 258

Name Right Page

Execution Execute scripts and script groups page 270
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Changing a user account’s group membership

How to change a user account’s group membership:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the Membership tab.

4. In the Members column, turn the slider of the group to which you want to add the 
user to the right (enabled).

5. In the Members column, turn the slider of the group from which the user is to be 
removed to the left in the (disabled).

6. Click on Save.

NOTE: Any user within the system can be a member of up to 20 user groups.

ADVICE: If necessary, use the Search field to limit the number of user groups to 
be displayed in the selection window.

ADVICE: If necessary, use the Search field to limit the number of user groups to 
be displayed in the selection window.
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Enabling or disabling a user account

How to enable or disable a user account:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Mark the check box Enabled to activate the user account.

If you want to block access to the system with this user account,  
unmark the checkbox.

4. Click on Save.

Deleting a user account

How to delete a user account:

1. In the menu, click on User.

2. Click on the user account you want to delete and then click on Delete.

3. Confirm the confirmation prompt by clicking on Yes or cancel the  
process by clicking on No.

IMPORTANT: If a user account is disabled, the user has no access to the 
KVM system.
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Administrating user groups
User groups enable the user to create a common rights profile for several users with 
the same rights and to add user accounts as members of this group.

This way, the rights of these user accounts do not have to be individually 
configured, which facilitates the rights administration within the KVM system.

Creating a new user group

The user can create up to 1,024 user groups within the system.

How to create a new user group:

1. In the menu, click on User groups.

2. Click on Add user group.

3. Enter the following values in the dialog box:

4. Click on Save.

NOTE: The administrator and any user with the Superuser right are authorised to 
create and delete user groups as well as edit the rights and the member list.

Name: Enter the username.

Comment: If desired, enter a comment regarding the user account.

Enabled: Mark this checkbox to activate the user account.

IMPORTANT: Directly after the new user group has been created, it contains no 
rights within the system

NOTE: If the user group is disabled, the group rights do not apply to the 
assigned members.
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Renaming a user group

How to rename a user group:

1. In the menu, click on User groups.

2. Click on the user group you want to configure and then click on Configuration.

3. Enter the group name under Name.

4. Click on Save.
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Changing the user group rights

The various user groups can be assigned with different rights.

The following tables lists the different user rights. Further information about the 
rights is given on the indicated pages.

System rights

Global device rights

Name Right Page

Superuser right Unrestricted access to the configuration of the 
system

page 82

Config Panel Login Login to the ConfigPanel web application page 82

EasyControl Login Access to EasyControl tool page 83

Change own password Change own password page 83

Confirm monitoring 
alert

Confirmation of a monitoring alarm page 83

Name Right Page

Edit personal 
profile

Change personal user settings page 251

Computer module  
config

Configuration of computer modules page 100

Permission to replace 
device

Execution of the „Replace device“-function page 84

MultiAccess Access type when a computer module is  
simultaneously accessed

page 94

Access to exclusive 
signals

Access to exclusive signals page 122

Access to USB devices Access USB devices page 97
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Users and groups
Computer module rights and device group rights

Console module rights

Scripting rights and scripting group rights  

Name Right Page

Access Access to a computer module or a computer 
module group

page 91

Device power Switching the power outlets of a  
computer module or a computer module group

page 236

MultiAccess Access type when a computer module is  
simultaneously accessed

page 94

Access to exclusive 
signals

Access to exclusive signals page 122

Access to USB devices Access USB devices page 97

Name Right Page

Push-Get Carry out Push-Get function page 258

Name Right Page

Execution Execute scripts and script groups page 270
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Users and groups
Administrating user group members

How to administrate user group members:

1. In the menu, click on User groups.

2. Click on the user group you want to configure and then click on Configuration.

3. Click on the Members tab.

4. In the Members column, click on the slider of the users  
you want to add to the group (enabled).

5. In the Members column, click on the slider of the users you want to delete from 
the group (disabled).

6. Click on Save.

(De)activating a user group

How to (de)activate a user group:

1. In the menu, click on User groups.

2. Click on the user group you want to configure and then click on Configuration.

3. Activate the Enabled slider to activate the user group. 

If you want to lock the access to the KVM system for members of this user group, 
deactivate the checkbox.

4. Click on Save.

Deleting a user group

How to delete a user group:

1. In the menu, click on User groups.

2. Click on the user group you want to delete and then click on Delete.

3. Confirm the confirmation prompt by clicking Yes or  
cancel the process by clicking No.

ADVICE: If necessary, use the Search field to limit the number of users to be 
displayed in the selection window.

ADVICE: If necessary, use the Search field to limit the number of users to be 
displayed in the selection window.
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Users and groups
System rights

Rights for unrestricted access to the system (Superuser)

The Superuser right allows a user unrestricted access to the configuration of the 
KVM system.

How to assign a user account with unrestricted access to the system:

1. In the menu, click on User or User groups.

2. Click on the user account or the user group you want to configure and then 
click on Configuration.

3. Click on the tab System rights.

4. Under Superuser right, select between the following options:

5. Click on Save.

Changing the login right to the web application

How to change the login right to the web application:

1. In the menu, click on User or User groups.

2. Click on the user account or the user group you want to configure and then 
click on Configuration.

3. Click on the tab System rights.

4. Under Config Panel Login, select between the following options:

5. Click on Save.

NOTE: The information about the user's previously assigned rights remains stored 
when the Superuser right is activated and is reactivated when the right is revoked.

Activated: Allow full access to the KVM system and the connected devices

Deactivated: Deny full access to the KVM system and the connected devices

Activated: Allow access to web application

Deactivated: Deny access to web application
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Users and groups
Rights to access the EasyControl tool

How to change the rights to access the EasyControl tool:

1. In the menu, click on User or User groups.

2. Click on the user account or the user group you want to configure and then 
click on Configuration.

3. Click on the tab System rights.

4. Under EasyControl Login, select between the following options:

5. Click on Save.

Rights to change your own password

How to change the right to change your own password:

1. In the menu, click on User or User groups.

2. Click on the user account or the user group you want to configure and then 
click on Configuration.

3. Click on the tab System rights.

4. Under Change own password, select between the following options:

5. Click on Save.

Authorization to confirm a monitoring alarm

How to change the authorization to confirm a monitoring alarm:

1. In the menu, click on User or User groups.

2. Click on the user account or the user group you want to configure and then 
click on Configuration.

3. Click on the tab System rights.

4. Under Confirm monitoring alert, select between the following options:

5. Click on Save.

Yes: Allow access to the EasyControl tool

No: Deny access to the EasyControl tool

Activated: Allow users to change their own password

Deactivated: Deny users the right to change their own password

Activated: Confirmation of monitoring alarms allowed

Deactivated: Confirmation of monitoring alarms denied
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Users and groups
Authorisation to execute the »Replace device« function

If a computer or a console module is replaced by new device, the previous config 
settings can be copied to the new device. After the config settings have been copied 
to the new device, it can be operated immediately.

In the default settings, the authorisation to execute the function is limited to the 
administrator and all users with activated superuser rights.

If desired, the authorization can be granted to other users.

How to change the right to change your own password:

1. In the menu, click on User or User groups.

2. Click on the user account or the user group you want to configure and then 
click on Configuration.

3. Click on the tab KVM matrix systems.

4. Go to the Global device rights section.

5. Under Permission to replace device, select between the following options:

6. Click on Save.

Activated: Allow users to execute the function

Deactivated: Deny users to execute the function
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Advanced functions of the KVM system
Advanced functions of the KVM system

Identifying a device by activating the 
Identification LED
Some devices provide an Identification LED.

Use the web application to switch the device LEDs on or off in order to identify the 
devices in a rack, for example.

How to (de)activate the Identification LED of a device:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to configure.

3. Open the menu Service tools and select the entry Ident LED.

4. Click on LED on or LED off.

5. Click on the red [X] to close the window.

Saving the configurations
The backup function lets you save your configurations. You can reset your 
configurations with the restore function.

How to save the configuration of the KVM system:

1. In the menu, click on System.

2. Click on Backup & restore.

3. Click the Backup tab.

4. Optional: Enter a Password to secure the backup file or a Comment.

5. Select the scope of data you want to back up: You can back up either  
the network settings and/or the application settings.

6. Click Backup.

IMPORTANT: For security reasons, network certificates for the web application and, 
if used, additional user certificates for the KVM connection are not included in a 
backup and may have to be stored again after a restore.
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Advanced functions of the KVM system
Saving the configurations with auto backup function
The device can save an automatic backup on a network drive at a defined interval. 
This means that you do not have to make a manual backup after a configuration 
option has been changed. You can reset your configurations with the restore 
function. 

How to use the auto backup function:

1. In the menu, click on System.

2. Click on Auto Backup.

3. Enter the following data:

Auto Backup: By selecting the corresponding entry in the pull-down menu, 
you can enable or disable the auto backup function:

 Disabled (default)
 Enabled

Filename prefix: Enter the filename prefix.

ADVICE: When the auto backup function is enabled, the 
filename prefix field is automatically filled with the UID of the 
device. You can change this entry.

IMPORTANT: Only letters (upper and lower case), numbers 
(0 to 9) and the characters - and _ are permitted. The prefix 
may contain a maximum of 25 characters.

Backup password: Optional: Enter a password to secure the backup file.

IMPORTANT: Double inverted commas („ and “) cannot be 
used here.

Backup scope: Select the scope of data you want to back up: You can back 
up either the network settings and/or the application settings.
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Advanced functions of the KVM system
Path: Enter the path for the backup files.

IMPORTANT: The syntax of the path depends on the selected 
protocol.

When using the NFS protocol, the URL format defined in 
RFC 2224 must be used – taking into account the general 
URL notation specified in RFC 3986.

When using the CIFS protocol, the URL format must follow 
RFC 3986.

Contrary to the specifications in RFC 2224 and RFC 3986, 
the protocol, port, username, and password must not be 
included in the path parameter. These values are taken 
exclusively from the separate parameters: Protocol, Port, User, 
and Password.

Examples: 

 NFS: name:/directory1/directory2
 CIFS: //name/directory1/directory2

Protocol: Choose between the following protocols:

 NFS (default)
 CIFS

Port: Enter the port. This field is filled automatically depending on 
the selection in the protocol field:

 2049 (when selected NFS)
 445 (when selected CIFS)

User: Optional: Enter the name of the user.

Password: Optional: Enter a password to secure the share.

Time: Enter the following data:

 Hour (numbers 0 to 23)
 Minute (numbers 0 to 59)

Selection of the 
day:

You can choose between the following options:

 1. to 31. day of the month
 Select all (every day of the month)
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Advanced functions of the KVM system
4. Click on Save & Test or Save. 

ADVICE: Use Save & Test and check whether a backup was successfully saved 
with the desired parameters.

IMPORTANT: You can see whether the test was successful in the syslog 
messages (see Logging syslog messages on page 47 ff.).

IMPORTANT: For security reasons, network certificates for the web application and, 
if used, additional user certificates for the KVM connection are not included in a 
backup and may have to be stored again after a restore.
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Advanced functions of the KVM system
Restoring the configurations

How to restore the configuration of the KVM system:

1. In the menu, click on System.

2. Click on Backup & restore.

3. Click on Restore tab.

4. Click Select file and open a previously created backup file.

5. Use the information given under Creation date and Comment to check if you selected 
the right backup file.

6. Select the scope of data you want to restore: You can restore either  
the network settings and/or the Application settings.

7. Click Restore.

NOTE: If one of these options cannot be selected, the data for this option was 
not stored.

NOTE: If a password was entered when the data was saved, it is requested here.

IMPORTANT: For security reasons, network certificates for the web application and, 
if used, additional user certificates for the KVM connection are not included in a 
backup and may have to be stored again after a restore.
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Advanced functions of the KVM system
Activating premium functions
With every purchase of a premium function (see Optional functions on page 252 ff.), 
you receive a feature key. This file contains a key to activate the purchased 
function(s).

The premium function(s) is/are activated by importing this key to the web application.

How to import a feature key to activate the purchased function(s):

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to configure.

3. Open the menu Service tools and select the entry Features.

4. Click on Import feature key from file... and import the feature key (file) via the  
file interface.

After the file is loaded, the clear text of the feature key is displayed in the  
text field.

5. Click on Save.

NOTE: The clear text of the feature key can also be copied into the text field.

ADVICE: You can display the activated functions in the respective overview table. 
For this, add the Active features column  
(see Configuring table columns on page 8 ff.)
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In the Matrix systems menu of the web application, you can configure various settings 
of the matrix switches and the devices connected.

The following pages provide a detailed description of these settings.

Computer modules
Computer modules connect computers to the KVM matrix system and can be 
accessed with console modules.

Adjusting access and configuration rights

Access rights to a computer module

In order to execute particular user settings which deviate from existing computer 
module groups, you can assign users with individual access rights in addition to 
group rights.

ADVICE: We recommend using computer module groups to help assign all computer
module access rights (see page 197).

This makes it easier to keep an overview of the KVM matrix system. It also benefits 
the operating performance of the system’s on-screen display (OSD).
2 Matrix system
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Computer modules
How to change computer module access rights:

1. In the menu, click on User or on User groups.

2. Click on the user account or the user group you want to configure and  
then click on Configuration.

3. Click on the tab KVM matrix systems and click on Individual rights in the  
selection area on the right-hand side.

4. In the Individual computer module rights field, you can select the desired  
computer module on the left-hand side.

5. In the Access field on the right-hand side of the dialogue, you can select between 
the following options:

6. Repeat steps 5 and 6 if you want to change the access rights for other computer 
modules.

7. Click on Save.

ADVICE: If necessary, use the Search field to limit the number of computer modules 
to be displayed in the selection window.

Yes: Allow full access to the computer connected to the  
computer module.

No: Deny access to the computer connected to the computer 
module.

View: View screen contents of the computer connected to the 
computer module
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Computer modules
Access rights to a computer module group

How to change the computer module group access rights:

1. In the menu, click on User or on User groups.

2. Click on the user account or the user group you want to configure and  
then click on Configuration.

3. Click on the tab KVM matrix systems and click on Device group rights in the  
selection area on the right-hand side.

4. In the Device group rights field, you can select the desired  
computer module group on the left-hand side.

5. In the Access field on the right-hand side of the dialogue,  
you can select between the following options:

6. Repeat steps 5 and 6 if you want to change the access rights for other computer 
modules.

7. Click on Save.

ADVICE: If necessary, use the Search field to limit the number of computer 
module groups to be displayed in the selection window.

Yes: Allow full access to the computer modules of the group.

No: Deny access the computer modules of the group.

View: View screen contents of a computer module of a group
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Computer modules
Access mode for simultaneous access to computer modules

In the default settings of the KVM matrix system only one user can access a computer 
module.

This restriction can be lifted by changing the MultiAccess right for a user account or a 
user group.

After being assigned with MultiAccess right, a user or a user group can access computer 
modules even if they are already accessed by another user.

You can either change the global settings to allow multiple users to access a computer 
module at the same time (for all computer modules to which a user or a user group has 
access) or you can change the rights for particular computer modules or computer 
module groups only.

How to change the MultiAccess right for all computer modules:

1. In the menu, click on User or on User groups.

2. Click on the user account or the user group you want to configure and  
then click on Configuration.

3. Click on the tab KVM matrix systems and click on Global device rights in the  
selection area on the right-hand side.

4. Select one of the options given under MultiAccess:

5. Click on Save.

NOTE: The right for simultaneous access to computer modules depends on the 
user’s effective right (see page 64). The effective right is the highest right and 
results from the individual right of a user account and the rights of the assigned 
group(s).

Yes: Allow access to a computer module already accessed by 
another user

No: Deny access to a computer module already accessed by 
another user

View: When connecting to a computer module with an already 
active connection, only the monitor image is displayed.

no inputs possible
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Computer modules
How to change the MultiAccess right for a particular computer module:

1. In the menu, click on User or on User groups.

2. Click on the user account or the user group you want to configure and  
then click on Configuration.

3. Click on the tab KVM matrix systems and click on Individual rights in the  
selection area on the right-hand side.

4. In the Individual computer module rights field, you can select the desired  
computer module on the left-hand side.

5. Select one of the options given under MultiAccess on the right-hand side:

6. Click on Save.

NOTE: MultiAccess rights can be configured and used only if a user or a user group 
is assigned with the required rights to access the computer module (see page 91 f.).

ADVICE: If necessary, use the Search field to limit the number of computer modules 
to be displayed in the selection window.

Yes: Allow access to a computer module already accessed by 
another user

No: Deny access to a computer module already accessed by 
another user

View: When connecting to a computer module with an already 
active connection, only the monitor image is displayed.

no inputs possible
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Computer modules
How to change the MultiAccess right for a particular computer module group:

1. In the menu, click on User or on User groups.

2. Click on the user account or the user group you want to configure and then  
click on Configuration.

3. Click on the tab KVM matrix systems and click on Device group rights in the  
selection area on the right-hand side.

4. In the Device group rights field, you can select the desired  
computer module group on the left-hand side.

5. Select one of the options given under MultiAccess on the right-hand side:

6. Click on Save.

NOTE: MultiAccess rights can be configured and used only if a user or a user group 
is assigned with the required rights to access the computer module (see page 91 f.).

ADVICE: If necessary, use the Search field to limit the number of computer 
module groups to be displayed in the selection window.

Yes: Allow access to a computer module of a computer 
module group already accessed by another user

No: Allow access to a computer module of a computer 
module group already accessed by another user

View: When connecting to a computer module with an already 
active connection, only the monitor image is displayed.

no inputs possible
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Computer modules
Access to USB devices

In the defaults of the matrix system, users have access to the USB devices of a channel 
group.

If required, this right can be denied by changing the right »Access to USB devices« of a 
user account or a user group.

You can either deny users the right to access USB devices of a particular computer 
module globally (for all computer modules to which a user or a user group has 
access) or you can change the rights for particular computer modules or computer 
module groups only.

How to change the right to access USB devices for all computer modules:

1. In the menu, click on User or on User groups.

2. Click on the user account or the user group you want to configure and then  
click on Configuration.

3. Click on the tab KVM matrix systems and click on Global device rights in the  
selection area on the right-hand side.

4. Select one of the options given in the Access to USB devices field:

5. Click on Save.

NOTE: The access right depends on the user’s effective right (see page 64). The 
effective right is the highest right and results from the individual right of a user 
account and the rights of the assigned group(s).

Yes: Allow access to USB devices.

No: Deny access to USB devices.
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Computer modules
How to change USB access rights for a particular computer module:

1. In the menu, click on User or on User groups.

2. Click on the user account or the user group you want to configure and then  
click on Configuration.

3. Click on the tab KVM matrix systems and click on Individual rights in the  
selection area on the right-hand side.

4. In the Individual computer module rights field, you can select the desired  
computer module on the left-hand side.

5. Select one of the options given in the Access to USB devices field:

6. Click on Save to save your settings.

NOTE: USB access rights can be configured and used only if a user or a user group 
is assigned with the required rights to access the computer module (see page 91 f.).

IMPORTANT: Configure USB access rights for the computer module that provides 
the main KVM channel of the channel group. The USB channel is assigned to the 
same channel group.

ADVICE: If necessary, use the Search field to limit the number of computer modules 
to be displayed in the selection window.

Yes: Allow access to USB devices.

No: Deny access to USB devices.
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Computer modules
How to change the right to access USB devices for a particular computer module 
group:

1. In the menu, click on User or on User groups.

2. Click on the user account or the user group you want to configure and then  
click on Configuration.

3. Click on the tab KVM matrix systems and click on Device group rights in the  
selection area on the right-hand side.

4. In the Device group rights field, you can select the desired  
computer module group on the left-hand side.

5. Select one of the options given in the Access to USB devices field:

6. Click on Save. 
 
 

NOTE: USB access rights can be configured and used only if a user or a user group 
is assigned with the required rights to access the computer module (see page 91 f.).

IMPORTANT: Configure USB access rights for the computer module that provides 
the main KVM channel of the channel group. The USB channel is assigned to the 
same channel group.

ADVICE: If necessary, use the Search field to limit the number of computer 
module groups to be displayed in the selection window.

Yes: Allow access to USB devices of computer module group.

No: Deny access to USB devices of computer module group.
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Computer modules
Rights to configure computer modules

How to change the right to view and edit the configuration of a computer module:

1. In the menu, click on User or on User groups.

2. Click on the user account or the user group you want to configure and then  
click on Configuration.

3. Click on the tab KVM matrix systems and click on Global device rights in the  
selection area on the right-hand side.

4. Select one of the options given under Computer module config:

5. Click on Save.

Basic configuration of computer modules

Changing the name of a computer module

During the start-up of the KVM matrix system any computer modules are named 
automatically.

How to change the name of a computer module:

1. In the menu, click on Matrix systems > [Name] > Computer modules.

2. Click on the computer module you want to configure and then  
click on Configuration.

3. Enter the name of the computer module in the Name field of the Device section.

4. Click on Save.

Yes: Allow user or user group to view and edit the computer module 
configuration.

No: Deny user or user group to view and edit the computer module 
configuration.
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Computer modules
Changing the comment of a computer module

The list field of the web application displays the name of a computer module as well 
as the comment entered.

How to change the comment of a computer module:

1. In the menu, click on Matrix systems > [Name] > Computer modules.

2. Click on the computer module you want to configure and then  
click on Configuration.

3. Enter any comment in the Comment field of the Device section.

4. Click on Save.

Deleting a computer module from a KVM matrix system

If the system is not able to find a computer module that has previously been 
integrated in the KVM system, the system assumes that the device is switched off. If 
a computer module has been permanently removed from the system, you can 
manually delete it from the list of computer modules.

How to delete a computer module that is switched off or disconnected from the 
system:

1. In the menu, click on Matrix systems > [Name] > Computer modules.

2. Click on the computer module you want to delete and then click on Delete.

3. Confirm the confirmation prompt by clicking on Yes or cancel the process  
by clicking on No.

ADVICE: For example, use the comment field to note where the computer module 
is placed.

NOTE: You can delete only computer modules that are switched off.
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Computer modules
Copying configuration settings to a new computer module

If a computer module of the KVM matrix system is replaced by another device, you 
can copy the configuration settings of the device to be replaced to the new device. 
After you copied the configuration settings to the new device, you can operate it 
immediately.

How to copy configuration settings to a new computer module:

1. In the menu, click on Matrix systems > [Name] > Computer modules.

2. Click on the new device.

3. Open the Service tools menu and select the item Replace device.

4. Select the device whose configuration settings you want to copy.

5. Click on Save.

Copying the configuration settings of a computer module

You can copy the configuration settings General, KVM connection, Channels, GPIO
(if supported by the device) and/or Monitoring) of a computer module to the settings 
of one or multiple other computer modules.

How to copy the configuration settings of a computer module:

1. In the menu, click on Matrix systems > [Name] > Computer modules.

2. Click on the computer module whose configuration you want to copy.

3. Click on Service tools and then click on Copy configuration.

4. In the upper area, you can select which settings of the computer module you 
want to copy (General,  and/or Monitoring).

5. In the lower area, select the computer modules to which you want to copy the data.

6. Click on Copy configuration.

IMPORTANT: The computer module whose settings you copy to a new device will 
then be deleted from the KVM matrix system.

NOTE: The name of and the comment about the computer module are not copied.
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Computer modules
Settings for special hardware

(De)Activating an USB keyboard mode the Generic USB mode

USB computer modules support different USB input devices. You can use the special 
features of a USB input device after selecting the specific USB keyboard mode.

As an alternative to the specific USB keyboard modes, you can also use the generic 
USB mode. In this mode, the data from the USB devices connected to the interface of 
the console module is transmitted to the active computer module.

 USB keyboards: In addition to the keys of standard keyboard layouts, the default 
USB keymode PC Multimedia supports several multimedia keys like Loud and Quiet.

When using Apple keyboards, special keyboard modes let you use the special keys of 
these keyboards.

The following table lists the supported USB keyboards:

IMPORTANT: The generic USB mode supports USB mass storage devices and many 
available HID device. However, being able to operate particular USB device in 
generic USB mode can not be guaranteed.

INPUT DEVICE SETTING

PC keyboard with standard keyboard layout  PC Standard:

PC keyboard with additional multimedia keys  Multimedia

Apple keyboard with numeric keypad (A1243)  Apple A1243
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Computer modules
 Displays and tablets: You can operate computers connected to the computer module 
with one of the supported displays or tablets (depending on model):

 Generic-USB mode: In this mode, data of the USB device connected to the interface 
of the console module is transmitted to the computer module without being altered.

INPUT DEVICE SETTING

HP 2310tk  HP 2310t

iiyama T1931  iiyama T1931

iiyama TF2415  iiyama TF2415

NOTTROT N170 KGE  NOTTROT N170 KGE

Wacom Cintiq 21UX Gen 1  Wacom Cintiq 21UX

Wacom Cintiq 21UX Gen 2  Wacom Cintiq 21UX Gen2

Wacom Cintiq Pro 24 Pen  Wacom Cintiq Pro 24 Pen

Wacom Cintiq Pro 27  Wacom Cintiq Pro 27

Wacom Cintiq Pro 32 Pen  Wacom Cintiq Pro 32 Pen

Wacom Cintiq Pro 32 Touch  Wacom Cintiq Pro 32 Touch

Wacom DTK-2451  Wacom DTK-2451

Wacom Intuos3  Wacom Intuos 3

Wacom Intuos4 S  Wacom Intuos 4 S

Wacom Intuos4 M  Wacom Intuos 4 M

Wacom Intuos4 L  Wacom Intuos 4 L

Wacom Intuos4 XL  Wacom Intuos 4 XL

Wacom Intuos5 S  Wacom Intuos 5 S

Wacom Intuos5 M  Wacom Intuos 5 M

Wacom Intuos5 L  Wacom Intuos 5 L

Wacom Intuos Pro L  Wacom Intuos Pro L

INPUT DEVICE SETTING

any USB mass storage or USB HID device  Generic USB

IMPORTANT: The generic USB mode supports many available USB mass storage 
devices and HID devices. However, being able to operate particular device in 
generic USB mode can not be guaranteed.
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 Controller: The ShuttlePRO v2 multimedia controller is used to control various audio 
and video programs. With a special USB keyboard mode, you can use the controller 
to operate the computer connected to the computer module:

 LK463-compatible keyboard: You can connect an LK463-compatible keyboard to the 
console module. The arrangement of the 108 keys of such keyboards corresponds to 
the OpenVMS keyboard layout.

A special USB keyboard mode ensures that the pressing of a special key on this 
keyboard is transmitted to the computer:

How to select a USB keyboard mode:

1. In the menu, click on Matrix systems > [Name] > Computer modules.

2. Click on the computer module you want to configure and then  
click on Configuration.

3. Select the desired option in the USB HID mode field of the Configuration paragraph 
(see table on page 103):.

4. Click on Save.

INPUT DEVICE SETTING

Contour ShuttlePRO v2  Contour Shuttle Pro 2

INPUT DEVICE SETTING

LK463-compatible keyboard  LK463

NOTE: Update the firmware of both the matrix switch and the computer module if 
the web application does not show all keyboard modes.
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Adjusting the operating mode of the RS232 interface

In the default setting of the computer module, you can connect any RS232-compatible 
device to the RS232 interface of the computer module (depending on model). The 
RS232 data stream is transmitted unchanged to the console module.

For transmitting RS422 signals, you can use two G&D RS232-422 adapters. Each of the 
adapters converts the RS232 interface of the console module and the computer module 
into RS422 interfaces.

How to set the operating mode of the RS232 interface of the computer module:

1. In the menu, click on Matrix systems > [Name] > Computer modules.

2. Click on the computer module you want to configure and then  
click on Configuration.

3. Click on the tab General.

4. Select one of the options of the Serial communication field under the  
paragraph Configuration:

5. Click on Save.

NOTE: This function is only available for computer modules of the digital Vision 
series and various variants of the VisionXS series and VisionXS 2.0 series!

IMPORTANT: If you want to transmit RS422 signals, in addition to using adapters, 
you also need to change the operating mode of the RS232 interfaces of both the 
console and the computer module.

RS232: The data stream of an RS232 device is transmitted from 
the computer module to the console module (default).

RS422: The data stream of an RS422 device is transmitted from 
the computer module to the console module via 
separately available G&D RS232-422 adapters.
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Defining the EDID profile to be used

The EDID information (Extended Display Identification Data) of a monitor inform the 
graphics card of the connected computer about various technical features of the 
device.

The EDID profile of the monitor connected to the console module is not available at the 
computer module. Therefore, the computer module transmits a standard profile to the 
computer. The EDID information of this profile is optimised for most graphics cards.

We provide additional profiles for special resolutions.

How to choose the EDID profile to be transmitted to the computer:

1. In the menu, click on Matrix systems > [Name] > Computer modules.

2. Click on the computer module you want to configure and then  
click on Configuration.

3. In the EDID profile field of the Configuration section, you can select either  
the default profile (Device specific default profile) or another profile from the list.

4. Click on Save.

ADVICE: In some cases it is recommended to read out the EDID profile of the console 
monitor and activate the configuration of the computer module afterwards.

NOTE: The names of G&D profiles provide information on the profile’s resolution 
and refresh rate.

For example, the profile GUD DVI1024D4 060 1280×1024/60 is provided for a 
resolution of 1280×1024 pixels at a 60 Hz refresh rate.
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Reducing the colour depth of image data to be transmitted

By default, the computer module transmits image information with a maximum colour 
depth of 24 bit to the console module.

When using a high image resolution and displaying moving images, it may happen in 
exceptional cases that some images are "skipped" on the console module.

In this case, reduce the colour depth of the image data to be transmitted to 18 bit. This 
can reduce the data volume to be transmitted.

How to reduce the colour depth of image data to be transmitted:

1. In the menu, click on Matrix systems > [Name] > Computer modules.

2. Click on the computer module you want to configure and then  
click on Configuration.

3. In the Colour depth field of the Configuration section, you can select one  
of the following options:

4. Click on Save.

NOTE: Depending on the content of the image, slight colour gradations may occur 
when reducing the colour depth.

24 Bit: Transmit image data with a maximum colour depth of 24 bits.

18 Bit: Reduce colour depth of image data to 18 bits.
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Advanced features

Wake On LAN

Wake on LAN (WoL) is a standardized method to start a computer that is powered 
off or in sleep mode via a network command. If a WoL-compatible and accordingly 
configured computer receives a so-called magic packet on the LAN connection, the 
network card and BIOS initiate the startup process. In addition to the network card 
and the BIOS, the computer's operating system also needs to be configured 
accordingly. 

The matrix switch also supports this function to use WoL in a KVM installation.

How to configure WoL function:

1. In the menu, click on Matrix systems > [Name] > Computer modules.

2. Click on the computer module you want to configure and then  
click on Configuration.

3. In the section Wake On LAN, enter the following data:

4. Click on Save.

How to send a WoL command to the defined computer:

1. In the menu, click on Matrix systems > [Name] > Computer modules.

2. Click on the computer module you want to configure.

3. Öpen the Service tools menu and click on Wake On LAN  
to send the WoL command to the defined computer.

Wake On LAN: Enable or disable the WoL function.

MAC-Adresse: Enter the MAC address of the WoL-compatible and 
configured computer connected to the selected computer 
module.

Password: Enter a password if a password has been stored on the 
computer at the WoL setup.

Automatic Wake On 
LAN on connection:

Enable or disable the automatic Wake On LAN when 
connection to the defined computer module.
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Sending a key combination after disconnecting all users

Use the Key Macros function to send a key combination to the computer connected to 
the computer module after having disconnected all users.

How to configure a key macro:

1. In the menu, click on Matrix systems > [Name] > Computer modules.

2. Click on the computer module you want to configure and then  
click on Configuration.

3. Under Key-Macros, select one of the following options:

4. Click on Save.

Enabling/disabling the keyboard signal

In the default settings, the signals of keyboard and mouse connected to the console 
are transmitted to a computer module.

In the settings of some computer modules, you can enable or disable the transmis-
sion of the keyboard signal.

How to enable/disable the transmission of the keyboard signal:

1. In the menu, click on Matrix systems > [Name] > Computer modules.

2. Click on the computer module you want to configure and then  
click on Configuration.

3. In the Keyboard activated field of the Configuration section,  
select one of the following options:

4. Click on Save.

NOTE: For example, send the key combination Win+L to lock a Windows computer 
after disconnecting all users.

Send a key  
combination after  
disconnecting all 
users:

Enable or disable the Key Macro function.

Key combination: Select up to three of the listed keys that are sent to the 
computer together as a key combination.

Enabled: Transmit keyboard signals to the computer module of this  
channel (default).

Disabled: Do not transmit keyboard signals to the computer module.
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Multi-user information

If multiple users are accessing a computer module (multi-user mode), multi-user
information can be activated. This way, all users accessing a computer module are 
provided at the console module with the information that at least one other user is 
currently accessing the same computer module.

How to enable or disable multi-user information for the entire system:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the matrix switch and then click on Configuration.

3. Select one of the options given under Multi-user display:

4. Click on Save.

How to enable or disable the display of multi-user information for a particular user 
account:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the tab KVM matrix systems and click on Personal profile in the selection area 
on the right-hand side.

4. Select one of the options given under Multi-user OSD info:

5. Click on Save.

NOTE: The setting to display this information is usually configured for the entire 
system and individually for each user account.

Both options are described on this page.

On: Enables the display of multi-user information

Off: Disables the display of multi-user information

Off: Disables the display of multi-user information

On: Enables the display of multi-user information

System: Apply global system settings (see above)
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Configure Mouse mode | CrossDisplay-Switching

If you want to use the CrossDisplay-Switching function, we recommend that you activate 
the function for the entire system (see Enabling CrossDisplay-Switching for the entire system
on page 291 ff.). This affects all computer modules that use the system-wide setting 
(default).

You can override the system-wide settings for each computer module and enable or 
disable CrossDisplay-Switching for certain computer modules only.

How the change CDS settings of a specific computer module:

1. In the menu, click on Matrix systems > [Name] > Computer modules.

2. Click on the computer module you want to configure and then  
click on Configuration.

3. Click on the General tab.

4. In the field Mouse mode | CrossDisplay-Switching, you can select  
between the following options:

5. Click on Save.

ADVICE: You can also disable the system settings and enable CrossDisplay-Switching
only in the settings of computer modules on which you want to use the function.

ADVICE: You can also configure the CDS settings of computer modules 
comfortably with a wizard (see Step 6: Configure CDS settings of computer modules on 
page 297 ff.).

System: Apply global system settings (default)

Relative mouse  
coordingates |  
CDS disabled:

Disable CrossDisplay-Switching.

Absolute mouse  
coordinates |  
CDS activatedt:

Enable CrossDisplay-Switching.
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How to change the mouse speed for a specific computer module:

1. In the menu, click on Matrix systems > [Name] > Computer modules.

2. Click on the computer module you want to configure and then  
click on Configuration.

3. Click on the General tab.

4. Move the CDS mouse speed slider to the desired value.

5. Click on Save.

How to adjust the CrossDisplay resolution of a specific computer module:

1. In the menu, click on Matrix systems > [Name] > Computer modules.

2. Click on the computer module you want to configure and then  
click on Configuration.

3. Click on the General tab.

4. Disable the Auto option in the CDS resolution field.

5. Enter the vertical and horizontal resolution in the input boxes.

6. Click on Save.

NOTE: With active CrossDisplay-Switching, the mouse speed is not controlled by the 
operating system of the computer but by the matrix switch.

If the cursor speed changes between horizontal and vertical mouse movements, 
the monitor resolution could not be auto detected.

In such cases, a resolution of 1680 × 1050 pixels applies. If the monitor’s 
resolution differs from this resolution, the mouse moves as described above.

In this case, you can adjust the monitor resolution manually.
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How to change the mouse position for a specific computer module:

1. In the menu, click on Matrix systems > [Name] > Computer modules.

2. Click on the computer module you want to configure and then  
click on Configuration.

3. Click on the General tab.

4. In the CDS mouse positioning field, you can select between the following options:

5. With activated CDS mouse positioning, you can select between the following 
options in the CDS mouse hideout field:

6. Click on Save.

System: Apply global system settings (default)

Off: The mouse cursor remains at the position at which the switching 
to the module of the next monitor takes place.

On: According to the CDS mouse hideout setting the mouse cursor is 
positioned so that it is barely visible.

Only during multi-user access, the cursor remains at the position at 
which the switching to the next monitor takes place.

On (multi 
access:

According to the CDS mouse hideout setting, even during multi-user 
access, the mouse cursor is positioned so that it is barely visible.

ADVICE: You can enable or disable this function for particular modules 
independently from the selected system setting (see below).

Right: The mouse cursor is placed on the right edge of the monitor so 
that it is barely visible.

Bottom: The mouse cursor is placed on the bottom edge of the monitor so 
that it is barely visible.
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Viewing status information of a computer module

How to view the status information of a computer module:

1. In the menu, click on Matrix systems > [Name] > Computer modules.

2. Click on the computer module you want to configure and then  
click on Configuration.

3. Click on the tab Information.

4. The following information is displayed in the dialog box that opens now 
(depending on model):

5. Click on Close.

Name: Name of computer module

Device ID: Unique ID of computer module

Status: Current status (Online or Offline) of computer module

Class: Device class

Firmware name: Firmware name

Firmware rev.: Firmware version

Hardware rev.: Hardware version

Serial number: Serial number of the module

SFP type: Name of the SFP module (fibre variant only)

Matrix switch: Name of the matrix switch to which the module is 
connected

Port: Port of the matrix switch to which the module is 
connected

NOTE: In addition, Active features and the Monitoring information of the device 
are displayed.
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Viewing the active connections of a computer module

How to view the active connections of a computer module:

1. In the menu, click on Matrix systems > [Name] > Computer modules.

2. Click on the desired computer module and then  
click on Service tools > Active connections.

A table informs you about all components (such as console modules,  
DWC channels, matrix switchs and computer modules) included in the  
active connection.

You can also view the medium (CAT/fibre) and the connected user.

3. Click on Close.

Restarting a computer module
Use this function to restart a computer module. Before restarting you will be prompted 
for confirmation to prevent an accidental restart.

How to restart a computer module using the web application:

1. In the menu, click on Matrix systems > [Name] > Computer modules.

2. Click on the computer module you want to restart.

3. Open the Service tools menu and select the item Restart.

4. Confirm the security prompt by clicking on Yes.
116 · G&D ControlCenter-Compact



Computer modules
Updating the firmware of computer modules
You can update the firmware of computer modules comfortably via web application.

How to update the firmware of computer modules:

1. In the menu, click on Matrix systems > [Name] > Computer modules.

2. Click on the computer module you want to update.

3. Click on Service tools and then click on Firmware update.

4. Click on Supply firmware image files.

Select the firmware file on your local data carrier and click on Open.

The firmware file is transferred to the internal device memory and can then be 
selected for the update.

5. Select the firmware files to be used from the internal device memory and  
click on Continue.

6. If required, select the Target version of the devices  if you have selected several 
firmware files for one device in step 5.

7. Click on the Update slider of all devices you want to update.

8. Click Run update.

NOTE: If the firmware file is already stored in the internal device memory, you 
can skip this step.

NOTE: Press the Shift key to select multiple firmware files using the left mouse 
key.

IMPORTANT: Do not close the browser session while devices are being updated. 
Do not turn off the devices or disconnect them from the power supply during 
the update.
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Console modules
The computers connected to the system are operated via the console modules of the 
KVM matrix system.

Operating modes of console modules
Depending on the intended use, you can select the console module’s operating 
mode from the following options:

Standard operating mode

The standard operating mode only permits the access to the KVM matrix system 
after users are authenticated with their username, password and optional 
2-factor authentication (see page 68) if set up.

The user rights can be individually adjusted in the settings of the user accounts.

OpenAccess operating mode

The access to the KVM matrix system is not password-protected.

For this console module, you can configure the same access rights as for a user account.

NOTE: The computers connected to the system can also be operated at a 
DynamicWorkplace-CON (DWC, see page 144).

NOTE: The standard operating mode is the default operating mode.

IMPORTANT: For the configuration of access rights, a user account is created for each 
console mdoule with activated OpenAccess mode.

The user account of an OpenAccess console applies to all users at this console module.

ADVICE: The user accounts of the OpenAccess console modules are marked with a 
OAC symbol.

The color of the symbol indicates whether the corresponding console is currently 
operating in OpenAccess mode (green) or is operating neither in OpenAccess mode nor 
in video mode (gray, the console module has been switched back to 
standard operating mode). 
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Video operating mode

A video console is only possible when combined with the optional Push-get function
(see page 256). It is especially suited when used with a projector since mouse and 
keyboard do not have to be connected.

If the video console is provided with mouse and keyboard, entires can be made on 
the on-screen display only.

You can configure the same access rights for this console as you can configure for a 
user account.

Selecting the console module’s operating mode

How to select the console module’s operating mode:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to configure and then click on Configuration.

3. Click on the General tab.

4. In the Operating mode field, you can select between the following options:

5. Click on Save.

IMPORTANT: The configured access rights apply for all users at this console module.

NOTE: A video console does not create an occupancy state. 

As a result, an accessing video console is not highlighted to other accessing users. 
A user without multiuser rights can therefore access the console module 
simultaneously to the video console.

Standard: Standard operating mode

OpenAccess 
console:

OpenAccess operating mode

Video: Video operating mode

NOTE: Selecting the OpenAccess or Video options activates further submenus to 
configure the access rights.
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Basic configuration of console modules

Changing names or comments of console modules

How to change names or comments of console module:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to configure and then click on Configuration.

3. Click on the General tab.

4. In the Name field, you can rename the console module.

5. In the Comment field, you can change or enter comments about the console module.

6. Click on Save.

Enabling or disabling console modules

You can disable a console module if you want to deny its access to the KVM matrix 
system.

How to enable or disable a console module:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to configure and then click on Configuration.

3. Click on the General tab

4. In the Enabled field, you can choose between the following options:

5. Click on Save.

NOTE: If the console module is disabled, the monitor displays the message 
»This console has been disabled«. It is therefore not possible to open the on-screen 
display or the login box.

If a user is accessing this console module, access is immediately withdrawn.

Enabled: Console module is enabled.

Disabled: Console module is disabled.
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Copying configuration settings to a new console module

If a console module of the KVM matrix system is replaced by another device, you 
can copy the configuration settings of the device to be replaced to the new device.

After you copied the configuration settings to the new device, you can operate it 
immediately.

How to copy configuration settings to a new console module:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the new device.

3. Open the Service tools menu and select the item Replace device.

4. Select the device whose configuration settings you want to copy.

5. Click on Save.

Copying the configuration settings of a console module

You can copy the configuration settings General, KVM connection, Channels, GPIO
(if supported by the device) and/or Monitoring of a console module to the settings of 
one or multiple other console modules.

How to copy the configuration settings of a console module:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module whose configuration you want to copy.

3. Click on Service tools and then click on Copy configuration.

4. In the upper area, you can select which settings of the console module you want 
to copy (General, Channels,GPIO and/or Monitoring).

5. In the lower area, select the console modules to which you want to copy the data.

6. Click on Copy configuration.

IMPORTANT: The console module whose settings you copied to a new device will 
be deleted from the KVM matrix system.

NOTE: The name of and the comment about the console module are not copied.
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Deleting a console module from the KVM matrix system

If the KVM matrix system is not able to detect a console module that already has 
been connected to the system, the console module is considered inactive.

Manually delete the console module you want to permanently remove from the system 
from the list of console modules.

How to delete a console module that is switched off or disconnected from the system:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to delete and click on Delete.

3. Confirm the confirmation prompt by clicking on Yes or cancel the process  
by clicking on No.

(De)Activating access to exclusive signals

There are signals that cannot be connected to several console modules or DWCs at 
the same time (e.g. Generic-HID, RS232, GPIO). In the default setting, the console 
module or DWC that connects to computer module first is given access to these 
exclusive signals.

It may be that the exclusive signals are not needed at this console module or that certain 
users should not have access to them. Therefore, access to the exclusive signals can be 
deactivated for console modules as well as users and user groups.

How to (de)activate access to exclusive signals for a console module:

1. In the menu, click on Matrix systems > [Name] > Console modules.

1. Click on the console module you want to configure and then  
click on Configuration.

2. Click on the tab General.

3. Select one of the options of the Access to exclusive signals field under  
the paragraph Configuratio

4. Click on Save.

NOTE: Only administrators and users with the superuser right can delete inactive 
console modules.

Enabled: Basically access to the exclusive signals (default)

Disabled: No access to the exclusive signals

IMPORTANT: The user only has access to the exclusive signals if the access is 
enabled at the corresponding console module and the user has the 
corresponding right (default).
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Rights for access to exclusive signals

You can either change the global settings to allow access to exclusive signals (for all 
computer modules to which a user or a user group has access) or you can change the 
rights for particular computer modules or computer module groups only.

How to change the rights to access exclusive signals for all computer modules:

1. In the menu, click on User or on User groups.

2. Click on the user account or the user group you want to configure and then  
click on Configuration.

3. Click on the tab KVM matrix systems and click on Global device rights in the  
selection area on the right-hand side.

4. Select one of the options given under Access to exclusive signals:

5. Click on Save.

NOTE: The right for access to exclusive signals depends on the user´s effective right 
(see page 64). The effective right is the highest right and results from the individual 
right of a user account and the rights of the assigned group(s).

Enabled: Basically access to the exclusive signals (default)

Disabled: No access to the exclusive signals

IMPORTANT: The user only has access to the exclusive signals if the user has 
the corresponding right and the access is enabled at the corresponding console 
module (Standard).
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How to change the rights to access exclusive signals for a particular computer 
module:

1. In the menu, click on Users or on User groups.

2. Click on the user account or the user group you want to configure and then  
click on Configuration.

3. Click on the tab KVM matrix systems and click on Individual rights in the  
selection on the right-hand-side.

4. In the Individual computer module rights field, you can select the desired  
computer module on the left-hand side.

5. Select one of the options given in the Access to exclusive signals field:

6. Click on Save.

ADVICE: If necessary, use the Search field to limit the number of computer modules 
to be displayed in the selection window.

Enabled: Basically access to the exclusive signals (default)

Disabled: No access to the exclusive signals

IMPORTANT: The user only has access to the exclusive signals if the user has 
the corresponding right and the access is enabled at the corresponding console 
module (Standard).
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How to change the rights to access exclusive signals for a particular computer 
module group:

1. In the menu, click on Users or on User groups.

2. Click on the user account or the user group you want to configure and then  
click on Configuration.

3. Click on the tab KVM matrix systems and click on Device group rights in the  
selection on the right-hand-side.

4. In the Device group rights field, you can select the desired  
computer module group on the left-hand side.

5. Select one of the options given in the Access to exclusive signals field:

6. Click on Save.

ADVICE: If necessary, use the Search field to limit the number of computer module 
groups to be displayed in the selection window.

Enabled: Basically access to the exclusive signals (default)

Disabled: No access to the exclusive signals

IMPORTANT: The user only has access to the exclusive signals if the user has 
the corresponding right and the access is enabled at the corresponding console 
module (Standard).
G&D ControlCenter-Compact · 125



Console modules
Settings for special hardware

Support of any USB devices

In Generic USB/Generic HID mode, the data from the USB devices connected to the 
interface of the console module is transmitted to the active computer module.

In Generic USB/Generic HID mode, you can connect USB hubs or USB composite 
devices to the Generic interface of the console module.

How to enable/disable the Generic USB/Generic HID mode of a console module:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to configure and then click on Configuration.

3. Click on the General tab.

4. In the Generic USB/Generic HID field, you can select between the following options:

5. Click on Save.

NOTE: When the Generic USB/Generic HID mode is enabled, it is not possible to operate 
the OSD with a keyboard connected to the Generic interface.

IMPORTANT: The Generic USB/Generic HID mode supports many available HID 
devices (including FIDO security keys, for example). However, the operation of a 
particular HID device in Generic USB/Generic HID mode can not be guaranteed.

NOTE: In multiuser mode, the generic USB device is available on the first active 
console module/the first active DWC. Once this console module/DWC logs off 
and another console module/another DWC logs in, the generic USB device of the 
other console module/the other DWC is available.

Disabled: You can connect either a USB keyboard or a USB mouse 
to the Generic interface of the console module.

Enabled: Data from any USB device connected to the Generic
interface is transmitted to the active computer module.

IMPORTANT: To use a generic USB device, enable the USB HID mode 
Generic USB of the computer modules you want to access (see page 103).
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Reinitialising USB input devices

After connecting a USB keyboard or mouse to the console module, the input devices 
are initialised and can be used immediately.

Some USB input devices require a reinitialisation of the USB connection. Enable 
the automatic reinitialisation of USB devices if a USB keyboard or mouse does not 
respond to your inputs during operation.

How to enable/disable the reinitialisation of USB devices:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to configure and then click on Configuration.

3. Click on the General tab.

4. Under USB Auto Refresh, you can choose between the following options:

5. Click on Save.

Off: The status of the USB devices is not monitored. 
If communication to a USB device is interrupted, the 
device is not reinitialised.

All devices: The status of the USB devices is monitored. 
If communication to one USB device is interrupted,  
all devices are reinitialised.

Only faulty devices: The status of USB devices is monitored.  
If the communication with a USB devices is interrupted, 
this device is reinitialised (recommended setting).
G&D ControlCenter-Compact · 127



Console modules
Advanced functions

Automatic user logout

A console module can be configured in a way that the access to the computer module is 
automatically disconnected after a user has been inactive for a certain amount of time. 
This way, the inactive user is automatically logged out of the KVM matrix system.

How to set the automatic user logout:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to configure and then click on Configuration.

3. Click on the General tab.

4. In the Auto logout (minutes) field, you can set the time (between 1 to 999 minutes)  
for the automatic logout.

5. Click on Save.

Configuring default execution after a user logon

After a user has logged on to a console module, the OSD usually opens on the 
screen of said console module.

The configuration setting Default execution allows you to define a computer module 
that is automatically accessed after a user logs on. As an alternative, you can also 
define a script that runs automatically.

How to select a default computer module that is automatically executed after a 
user logon:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the tab KVM matrix systems and click on Personal profile in the  
selection area on the right-hand side.

4. In the Default execution field, select the option Default computer module.

5. Scroll down to the Default computer module area.

NOTE: Entering the value »0« disables the automatic user logout.

IMPORTANT: If the Return to last computer module function (see page 130 f.) or the 
Restore last FreeSeating session function (see page 131 f.) is activated, the user‘s 
configured default action is ignored.
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6. Click on the slider of the desired default computer module in the column  
Default computer module (enabled).

7. Click on Save.

How to select a default script or a script group that is automatically executed 
after a user logon:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the tab KVM matrix systems and click on Personal profile in the  
selection area on the right-hand side.

4. In the Default execution field, select the option Default script/script group.

5. Scroll down to Default script/script group.

6. Click on the slider of the desired default script/script group in the  
column Default script/script group.

7. Click on Save.

How to disable the configured default action:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the tab KVM matrix systems and click on Personal profile in the  
selection area on the right-hand side.

4. In the Default execution field, select the option None.

5. Click on Save.

ADVICE: If necessary, use the Search field to limit the number of computer modules 
to be displayed in the selection window.

ADVICE: If necessary, use the Search field to limit the number of scripts and 
groups to be displayed in the selection window.
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Return to the last computer module

Enable the Return to last computer module function in your personal profile to remember 
the computer module you accessed before logging out of the system. After the next 
login, you will automatically be switched to this computer module.

How to enable automatic access to the last accessed computer module:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the tab KVM matrix systems and click on Personal profile in the  
selection area on the right-hand side.

4. Select the option Return to last computer module under Restore last session.

5. Click on Save.

NOTE: Turning off the console module or DWC on which the user is logged in is 
treated like a logout.

IMPORTANT: If the Return to last computer module function is activated, the user‘s 
configured default execution (see page 128 f.) and DWC default execution 
(see page 165 f.) are ignored.
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Restore the last FreeSeating session

Enable the Restore last FreeSeating session function in the personal profile to save the 
connection status of FreeSeating members. With this function, the last connection 
state can be restored when logging in again at the same workplace or another 
workplace that is set up and configured accordingly. By logging in or logging out to 
the Tradeswitch leader, all other FreeSeating members are automatically logged in 
with the same user (if no other user is logged in yet) or logged out (if the same user is 
logged in).

How to enable the restore last FreeSeating session function:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the tab KVM matrix systems and click on Personal profile in the  
selection area on the right-hand side.

4. Select the option Restore last FreeSeating session under Restore last session.

5. Click on Save.

Deactivation of the Restore last session function

How to disable the Restore last session function:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the tab KVM matrix systems and click on Personal profile in the  
selection area on the right-hand side.

4. Select the option Off under Restore last session.

5. Click on Save.

IMPORTANT: The prerequisite for this is the activation and configuration of the 
premium Tradeswitch function (see page 276 ff.).

NOTE: Turning off the console module or DWC on which the user is logged in is 
treated like a logout.

IMPORTANT: If the Restore last FreeSeating session function is activated, the user‘s 
configured default execution (see page 128 f.) and DWC default execution 
(see page 165 f.) are ignored.
G&D ControlCenter-Compact · 131



Console modules
Automatically disconnecting access to computer modules

Console modules can be configured in a way that the active access to a computer 
module is automatically disconnected after a user has been inactive for a certain 
amount of time.

If the OSD is opened at the moment of disconnection, it remains on the screen even 
after it has been automatically disconnected.

If the OSD is closed at the moment of disconnection, the 
message displayed on the right-hand side is shown on the 
screen of the console module.

How to automatically disconnect the access to a computer module:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to configure and then click on Configuration.

3. Click on the General tab.

4. In the Auto disconnect (minutes) field, you can set the time (between 1 to 999 minutes) 
for automatically disconnecting the access to a computer module.

5. Click on Save.

NOTE: The value 0 disables the automatic disconnection when a computer 
module is accessed.

CON-Admin
Not connected
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Adjusting the logoff procedure of CON-2/2C/2F console modules

You can connect CON-2/2C/2F console modules to up to two digital matrix switches 
of the ControlCenter-Digital or the ControlCenter-Compact series.

The button on the front panel of the console module (only with CON-2 variants) or 
configured key combinations (select keys) let you switch between the connected 
matrix switches.

In the defaults of the matrix switches, the existing connection between the first and 
the second matrix switch is disconnected via logout during a switching operation 
while the connection to the second matrix switch is established. Due to the logout 
users are required to logon again after each switching operation.

In the settings of the matrix switches connected to the console module you can 
adjust that the connection is not disconnected via logout when switching but that it 
should be held. If you switch back to the matrix switch at a later point, you can 
continue work without having to log on again.

How to adjust the logoff procedure of CON-2/2C/2F console modules:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to configure and then click on Configuration.

3. Under Stay connected to the matrix in the paragraph Dual cluster configuration,  
select one of the following options:

4. Click on Save.

IMPORTANT: Activating this option can pose a security risk since other users can 
switch your session at this console module without having to log on again!

IMPORTANT: Adjust this setting separately for both matrix switches connected to 
the console module.

No: When switching to the second channel of the console module, the 
existing connection is disconnected via logout (default).

Yes: When switching to the second channel of the console module, the 
existing connection is held. If you switch back to the matrix switch at a 
later point, you can continue work without having to log on again
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Channel auto-switching for CON-2/2C/2F console modules

You can connect CON-2/2C/2F console modules to up to two digital matrix switches 
of the ControlCenter-Digital or the ControlCenter-Compact series.

The button on the front panel of the console module (only with CON-2 variants) or 
configured key combinations (select keys) let you switch between the connected 
matrix switches.

You can configure the matrix switch to automatically switch to the other channel 
when a connection is lost on the channel selected by the user.

How to configure the channel auto-switching for CON-2/2C/2F console modules:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to configure and then click on Configuration.

3. Click on the Dual cluster configuration tab.

4. Under Channel auto-switching in the Dual cluster configuration,  
select one of the following options:

5. Click on Save.

ADVICE: For example, you can use this function to automatically switch to a 
redundant matrix switch when a connection to the matrix switch or to the computer 
module is terminated.

IMPORTANT: Change this setting separately for both matrix switches connected to 
the console module.

Never: The channel accessed by the user is maintained in case of 
a disconnection (default).

On error if device 
available:

If a connection is terminated, the device auto-switches to 
the other channel if this channel has an active connection.

Always on error: If a connection is terminated, the device auto-switches to 
the other channel regardless of the conenction status of 
the other channel.
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Following the Transmission Channel of CON-2/2C/2F console 
modules members of a channel group

A multichannel workstation can be built using CON-2/2C, or 2F console modules. 
These modules can be grouped into channel groups. If a member of the channel 
group switches to another transmission channel, the other CON-2/2C/2F members 
of the group also switch to the remaining transmission channel. Following a 
switching participant can be enabled (default) or disabled individually for each 
participant of the channel group on CON-2/2C/2F console modules.

How to configure the „Synchronize team transmission channels“ function:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to configure and then click on Configuration.

3. Click on the slider Synchronize team transmission channels in the  
paragraph Dual cluster configuration if the CON-2 or 2C/2F console  
module should follow other participants of a channel group.

4. Click on Save.

IMPORTANT: Change this setting separately for both matrix switches connected to 
the console module.
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Remembering a username in the login box

If the same users often works at a certain console module, their login can be used as 
default in the login box of the KVM matrix system.

After a user has logged out of the system, the login mask automatically remembers 
the username of the last active user.

How to remember the username in the login mask:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to configure and then click on Configuration.

3. Click on the General tab.

4. In the Remember last user field, you can select between the following options:

5. Click on Save.

Yes: The system remembers the last user.

No: The system does not remember the last user.
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Setting the hold time for the screensaver

The screensaver deactivates the screen display at the console module after the user 
has been inactive for an amount of time you can adjust.

How to set the hold time of the screensaver:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to configure and then click on Configuration.

3. Click on the General tab.

4. In the Screensaver (minutes) field, you can set the holding time (1 to 999 minutes) 
for activating the screensaver.

5. Click on Save.

Setting the hold time for the login screensaver

The screensaver deactivates the screen display at the console module after the user 
has been inactive for an amount of time you can adjust.

How to set the hold time of the screensaver:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to configure and then click on Configuration.

3. Click on the General tab.

4. In the Login screensaver (minutes) field, you can set the holding time (1 to 999 minutes) 
for activating the screensaver.

5. Click on Save.

NOTE: This setting operates independently from the screensaver settings of the 
computer.

NOTE: Entering the value 0 disables the screensaver of the console module.

NOTE: This setting operates independently from the screensaver settings of the 
computer.

NOTE: Entering the value 0 disables the screensaver of the console module.
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Enabling or disabling DDC/CI support

Most of the computer and console modules supported by the ControlCenter-Compact 
system are ready to support monitors with DDC/CI functionality.

After the function has been activated, the DDC/CI information is transparently
forwarded to the monitor in order to support as many monitors as possible. 
However, we cannot guarantee the support for all monitors.

You can set the DDC/CI support for the entire system. The system-wide setting is used 
by all console modules. In addition, you can define these settings for each console 
module individually.

How to configure the sytem-wide setting of the DDC/CI support:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the console module you want to configure and then click on Configuration.

3. Click on the General tab.

4. In the DDC/CI field, you can select between the following options:

5. Click on Save.

NOTE: The paragraph Technical data of the manuals of the computer and console 
modules shows the modules (after an update to the latest firmware) supporting 
DDC/CI.

Disabled: Disable transmission of DDC/CI signals (default).

CPU > monitor: Carry out transmission of DDC/CI signals exclusively  
from computer module to monitor.

Bidirectional: Carry out transmission of DDC/CI signals bidirectionally.
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How to configure the individual settings of the DDC/CI support of a console 
module:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to configure and then click on Configuration.

3. Click on the General tab.

4. In the DDC/CI support field, you can select between the following options:

5. Click on Save.

System: Use system-wide setting (see above).

Disabled: Disable transmission of DDC/CI signals (default).

CPU > monitor: Carry out transmission of DDC/CI signals exclusively  
from computer module to monitor.

Bidirectional: Carry out transmission of DDC/CI signals bidirectionally.
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Adjusting the operating mode of the RS232 interface

In the default setting of the console module, you can connect any RS232-compatible 
device to the RS232 interface of the console module (depending on model). The 
RS232 data stream is transmitted unchanged to the computer module.

Fro transmitting RS422 signals, you can use two G&D RS232-422 adapters. Each of the 
adapters converts the RS232 interface of the console module and the computer module 
into RS422 interfaces.

How to set the operating mode of the RS232 interface:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to configure and then click on Configuration.

3. Click on the General tab.

4. Select one of the options of the Serial communication field under the  
paragraph Configuration:

5. Click on Save.

NOTE: This function is only available for console modules of the digital 
Vision series and various variants of the VisionXS series and VisionXS 2.0 series!

IMPORTANT: If you want to transmit RS422 signals, in addition to using adapters, 
you also need to change the operating mode of the RS232 interfaces of both the 
console and the computer module.

RS232: The data stream of an RS232 device is transmitted 
from the console module to the computer module 
(default).

RS422: The data stream of an RS422 device is transmitted 
from the console module to the computer module 
via separately available G&D RS232-422 adapters.

Tradeswitch: With the tradeswitch mode you can use optional LED 
sets (see page 242). This facilitates locating the monitor 
(computer) to which the keyboard/mouse focus is 
switched to (see page 276).
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Viewing the active connections of a console module

How to view the active connections of a console module:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the desired console module and then click on 
Service tools > Active connections.

A table informs you about all components (such as console module,  
matrix switch and computer module) included in the active connection.

You can also view the medium (CAT/fibre) and the connected user.

3. Click on Close.

Restarting a console module

This function enables you to restart the console module. Before restarting the device 
you are requested to confirm your action to prevent accidental restarts.

How to restart a console module via web application:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to restart.

3. Click on Service tools and then click on Restart.

4. Confirm the security prompt with Yes.
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Updating the firmware of a console module
You can use the web application to update the firmware of a console module.

How to update the firmware of a console module:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to update.

3. Click on Service tools and then click on Firmware update.

4. Click on Supply firmware image files.

Select the firmware file on your local data carrier and click on Open.

The firmware file is transferred to the internal device memory and can then be 
selected for the update.

5. Select the firmware files to be used from the internal device memory and  
click on Continue.

6. If required, select the Target version of the devices if you have selected several  
firmware files for one device in step 5.

7. Click on the Update slider of all devices you want to update.

8. Click on Run update.

ADVICE: If the firmware file is already stored in the internal device memory, 
you can skip this step.

ADVICE: Press the Shift key to select multiple firmware files using the left mouse 
key.

IMPORTANT: Do not close the browser session while devices are being updated. 
Do not turn off the devices or disconnect them from the power supply during 
the update.
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Viewing status information of a console module

How to view the status information of a console module:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to configure and then click on Configuration.

3. Click on the Information tab.

4. Now you are provided with the following information:

5. Click on Close.

Name: Name of the console module

Device ID: Unique ID of the console module

Status: Current status (Online or Offline) of the console module

Klasse: Device class

Firmware name: Firmware name

Firmware rev: Firmware version

Hardware rev.: Hardware version

Serial number: Serial number of the module

SFP type: Name of the SFP module (fibre variant only)

Matrix switch: Name of matrix switch to which the module is connected.

Port: Matrix switch port to which the module is connected.

NOTE: In addition, Active features and the Monitoring information of the device 
are displayed.
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DynamicWorkplace-CONs
A DynamicWorkplace-CON (DWC) enables you to simultaneously display and 
operate several computer modules on one or several monitors. 

Operating modes of a DWC
Depending on the intended use, you can select the DWC operating mode from the 
following options:

Standard operating mode

The standard operating mode only permits the access to the KVM matrix system 
after users are authenticated with their username, password and optional 
2-factor authentication (see page 68) if set up.

The user rights can be individually adjusted in the settings of the user accounts.

Open access operating mode

The access to the KVM matrix system is not password-protected.

You can configure the same access rights for this DWC as you can configure for a 
user account.

NOTE: The computers connected to the system can also be operated at console 
modules (see page 118 ff.).

NOTE: The standard operating mode is the default operating mode.

IMPORTANT: For the configuration of access rights, a user account is created for each 
DWC with activated OpenAccess mode.

The user account of an OpenAccess console applies to all users at this DWC.

ADVICE: The user accounts of the OpenAccess DWCs are marked with a 
OAC symbol.

The color of the symbol indicates whether the corresponding DWC is currently 
operating in Open Access mode (green) or is operating standard mode (gray, the DWC 
has been switched back to standard operating mode). 
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Selecting the DWC operating mode

How to select the DWC operating mode:

1. In the menu, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the DWC you want to configure and then click on Configuration.

3. Click on the General tab.

4. In the Operating mode field, you can select between the following options:

5. Click on Save.

Standard: Standard operating mode

OpenAccess 
console:

OpenAccess operating mode

NOTE: Selecting the Open Access option activates further submenus to configure 
the access rights.
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Basic configuration of a DWC

Changing names or comments of a DWC

How to change names or comments of a DWC:

1. In the menu, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the DWC you want to configure and then click on Configuration.

3. Click on the General tab.

4. In the Name field, you can rename the DWC.

5. In the Comment field, you can change or enter comments about the DWC.

6. Click on Save.

Changing names or comments of a DWC transmission channel

How to change names or comments of a DWC transmission channel:

1. In the menu, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the DWC you want to configure and then click on Configuration.

3. Click on the Transmission tab.

4. In the Name field of the desired transmission channel, you can rename the  
DWC transmission channel.

5. In the Comment field of the desired transmission channel, you can change or enter 
comments about the DWC transmission channel.

6. Click on Save.

NOTE: The configuration of a specific DWC transmission channel is only possible 
after a connection between the matrix switch and the DWC transmission channel 
has been established at least once. Prior to this, the transmission channel is not in 
the database, is not displayed and cannot be configured as a result.
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Enabling or disabling a DWC

You can disable a DWC if you want to deny its access to the KVM matrix system.

How to enable or disable console module:

1. In the menu, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the DWC you want to configure and then click on Configuration.

3. Click on the General tab

4. In the Enabled field, you can choose between the following options:

5. Click on Save.

NOTE: If the DWC is disabled, the monitors display the message 
»Console disabled - This console has been disabled«. It is therefore not possible to open the 
login box.

If a user is accessing this DWC, access is immediately withdrawn.

Enabled: DWC is enabled.

Disabled: DWC is disabled.
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Transfer configuration settings to a new DWC

If a DWC of the KVM matrix system is replaced by another device, you can copy 
the configuration settings of the device to be replaced to the new device.

After you copied the configuration settings to the new device, you can operate it 
immediately.

How to copy configuration settings to a new DWC:

1. In the menu, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the new device.

3. Open the Service tools menu and select the item Replace device.

4. Select the device whose configuration settings you want to copy.

5. Click on Save.

IMPORTANT: If there are fewer DWC transmission channels on the DWC to 
which the configuration settings are to be transferred than on the original DWC, 
the additional DWC transmission channels are deleted from the configuration 
during the transfer.

IMPORTANT: The DWC whose settings you copied to a new device will be deleted 
from the KVM matrix system.
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Copying the configuration settings of a DWC

You can copy the configuration settings General and/or Monitoring of a DWC to the 
settings of one or multiple other DWCs.

How to copy the configuration settings of a DWC:

1. In the menu, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the DWC whose configuration you want to copy.

3. Click on Service tools and then click on Copy configuration.

4. In the upper area, you can select which settings of the DWC you want to copy 
(General and/or Monitoring).

5. In the lower area, select the DWCs to which you want to copy the data.

6. Click on Copy configuration.

NOTE: The name of and the comment about the DWC are not copied.

IMPORTANT: If there are fewer DWC transmission channels on the DWC to 
which the configuration settings are to be transferred than on the original DWC, 
the additional DWC transmission channels are deleted from the configuration 
during the transfer.
G&D ControlCenter-Compact · 149



DynamicWorkplace-CONs
Deleting a DWC from the KVM matrix system

If the KVM matrix system is not able to detect a DWC that already has been 
connected to the system, the DWC is considered inactive.

Manually delete the DWC you want to permanently remove from the system from the 
list of DWCs.

How to delete a DWC that is switched off or disconnected from the system:

1. In the menu, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the DWC you want to delete and click on Delete.

3. Confirm the confirmation prompt by clicking on Yes or cancel the process by 
clicking on No.

Deleting a DWC transmission channel from the KVM matrix system

If the KVM matrix system is not able to detect a DWC transmission channel that 
already has been connected to the system, the DWC transmission channel is 
considered offline.

Manually delete the DWC transmission channel you want to permanently remove from 
the system from the list of DWC transmission channels.

How to delete a DWC transmission channel that is disconnected from the system:

1. In the menu, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the DWC transmission channel you want to delete and click on Delete.

3. Confirm the confirmation prompt by clicking on Yes or cancel the process by 
clicking on No.

NOTE: Only administrators and users with the superuser right can delete inactive 
DWCs.

IMPORTANT: Deleting a DWC also deletes the associated DWC transmission 
channels from the KVM matrix system.

NOTE: Only administrators and users with the superuser right can delete a 
DWC transmission channel that is offline.
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Arrange monitors/displays

The Arrange displays dialog is used to define the display area of the DWC by 
specifying the resolution per monitor and arranging the monitors appropriately.  
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The monitor connections available on the device are listed at the top of the dialog 
and numbered according to the interface designation. 

There are two drop-down menus for each monitor connection. The first drop-down 
menu is used to select the resolution of the respective monitor (default: Native 
monitor resolution). The second drop-down menu can be used to define for each 
monitor whether the display should be rotated on this monitor.

The arrangement of the monitors is carried out in the lower area of the dialog. The 
individual monitors are arranged within a large rectangle. 

A monitor is placed in the box as a rectangle. The size of the box corresponds to the 
resolution of the monitor. If a rotation of the monitor has been configured, the 
rectangle rotates accordingly.

Each monitor is always visible in the positioning box. By default, all monitors are 
arranged in ascending order of number. By holding down the mouse button on a 
monitor, it can be moved. 

A button Identify displays temporarily displays the monitor numbers on the 
DWC monitors for 10 seconds.

How to select the resolution of the monitors:

1. In the menu, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the DWC you want to configure and then click on Configuration.

3. Click on the General tab.

4. Click on the Arrange displays button.

5. Select the desired resolution in the drop-down menu of the corresponding monitor. 

6. Click on Save.

NOTE: The monitors must form a continuous surface.

NOTE: Within the web application, save the arrangement of the monitors as it 
corresponds to the conditions of the workplace.
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How to select the rotation of a monitor display:

1. In the menu, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the DWC you want to configure and then click on Configuration.

3. Click on the General tab.

4. Click on the Arrange displays button.

5. Select the desired rotation in the drop-down menu of the corresponding monitor. 

6. Click on Save.

How to move monitors within the display area:

1. In the menu, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the DWC you want to configure and then click on Configuration.

3. Click on the General tab.

4. Click on the Arrange displays button.

5. Move the mouse over the rectangle of the monitor you want to move.

6. Press and hold the left mouse key while dragging the rectangle to the  
desired position.

If the frame of the rectangle turns red while dragging it, the current position is 
(partly) occupied and therefore the rectangle cannot be placed there.

Drag the handle beyond the right or left edge if the workspace is too small for the 
monitor size you want to adjust. The workspace maximizes automatically.

7. Release the left mouse key when a green frame is displayed.

8. Click on Save.

IMPORTANT: Exact operation is only possible if the monitors shown in the 
web application are placed in the same order as on the workplace.
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(De)Activating access to exclusive signals

There are signals that cannot be connected to several DWCs at the same time 
(e.g. Generic-HID, RS232). In the default setting, the DWC that connects to 
computer module first is given access to these exclusive signals.

It may be that the exclusive signals are not needed at this DWC or that certain users 
should not have access to them. Therefore, access to the exclusive signals can be 
deactivated for DWCs as well as users and user groups.

How to (de)activate access to exclusive signals for a DWC:

1. In the menu, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the DWC you want to configure and then click on Configuration.

3. Click on the tab General.

4. Select one of the options of the Access to exclusive signals field under the paragraph 
Configuration.  

5. Click on Save.

Enabled: Basically access to the exclusive signals (default)

Disabled: No access to the exclusive signals

IMPORTANT: The user only has access to the exclusive signals if the access is 
enabled at the corresponding DWC and the user has the corresponding right 
(default).
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Rights for access to exclusive signals

You can either change the global settings to allow access to exclusive signals 
(for all computer modules to which a user or a user group has access) or you can 
change the rights for particular computer modules or computer module groups only.

How to change the rights to access exclusive signals for all computer modules:

1. In the menu, click on User or on User groups.

2. Click on the user account or the user group you want to configure  
and then click on Configuration.

3. Click on the tab KVM matrix systems and click on Global device rights in the selection 
area on the right-hand side.

4. Select one of the options given under Access to exclusive signals:

5. Click on Save.

NOTE: The right for access to exclusive signals depends on the user´s effective right 
(see page 64). The effective right is the highest right and results from the individual 
right of a user account and the rights of the assigned group(s).

Enabled: Basically access to the exclusive signals (default)

Disabled: No access to the exclusive signals

IMPORTANT: The user only has access to the exclusive signals if the user has 
the corresponding right and the access is enabled at the corresponding DWC 
(Standard).
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How to change the rights to access exclusive signals for a particular computer 
module:

1. In the menu, click on Users or on User groups.

2. Click on the user account or the user group you want to configure  
and then click on Configuration.

3. Click on the tab KVM matrix systems and click on Individual rights in the selection on 
the right-hand-side.

4. In the Individual computer module rights field, you can select the desired computer 
module on the left-hand side.

5. Select one of the options given in the Access to exclusive signals field:

6. Click on Save.

ADVICE: If necessary, use the Search field to limit the number of computer modules 
to be displayed in the selection window.

Enabled: Basically access to the exclusive signals (default)

Disabled: No access to the exclusive signals

IMPORTANT: The user only has access to the exclusive signals if the user has 
the corresponding right and the access is enabled at the DWC (Standard).
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How to change the rights to access exclusive signals for a particular computer 
module group:

1. In the menu, click on Users or on User groups.

2. Click on the user account or the user group you want to configure  
and then click on Configuration.

3. Click on the tab KVM matrix systems and click on Device group rights in the selection 
on the right-hand-side.

4. In the Device group rights field, you can select the desired computer module group on 
the left-hand side.

5. Select one of the options given in the Access to exclusive signals field:

6. Click on Save.

ADVICE: If necessary, use the Search field to limit the number of computer module 
groups to be displayed in the selection window.

Enabled: Basically access to the exclusive signals (default)

Disabled: No access to the exclusive signals

IMPORTANT: The user only has access to the exclusive signals if the user has 
the corresponding right and the access is enabled at the corresponding DWC 
(Standard).
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Settings for special hardware

Support of any USB devices

In Generic USB mode, the data from the USB devices connected to the interface of the 
DWC is transmitted to the active computer module.

In Generic USB mode, you can connect USB hubs or USB composite devices to the 
Generic interface of the DWC.

How to enable/disable the Generic USB mode of a DWC:

1. In the menu, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the DWC you want to configure and then click on Configuration.

3. Click on the General tab.

4. In the Generic USB field, you can select between the following options:

5. Click on Save.

NOTE: When the Generic USB mode is enabled, it is not possible to operate the 
WindowManager with a keyboard connected to the Generic interface.

IMPORTANT: The Generic USB mode supports many available devices. However, 
the operation of a particular device in Generic USB mode can not be guaranteed.

NOTE: In multiuser mode, the generic USB device is available on the first active 
console module/the first active DWC. Once this console module/DWC logs off 
and another console module/another DWC logs in, the generic USB device of the 
other console module/the other DWC is available.

Disabled: You can connect either a USB keyboard or a USB mouse 
to the Generic interface of the DWC.

Enabled: Data from any USB device connected to the Generic
interface is transmitted to the active computer module.

IMPORTANT: To use a generic USB device, enable the USB HID mode 
Generic USB of the computer modules you want to access (see page 103).
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Reinitialising USB input devices

After connecting a USB keyboard or mouse to the DWC, the input devices are 
initialised and can be used immediately.

Some USB input devices require a reinitialisation of the USB connection. Enable 
the automatic reinitialisation of USB devices if a USB keyboard or mouse does not 
respond to your inputs during operation.

How to enable/disable the reinitialisation of USB devices:

1. In the menu, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the DWC you want to configure and then click on Configuration.

3. Click on the General tab.

4. Under USB Auto Refresh, you can choose between the following options:

5. Click on Save.

Off: The status of the USB devices is not monitored. 
If communication to a USB device is interrupted, the 
device is not reinitialised.

All devices: The status of the USB devices is monitored. 
If communication to one USB device is interrupted, 
all devices are reinitialised.

Only faulty devices: The status of USB devices is monitored. 
If the communication with a USB devices is interrupted, 
this device is reinitialised (recommended setting).
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Advanced functions

Automatic user logout

A DWC can be configured in a way that the accesses to the computer modules are 
automatically disconnected after a user has been inactive for a certain amount of time. 
This way, the inactive user is automatically logged out of the KVM matrix system.

How to set the automatic user logout:

1. In the menu, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the DWC you want to configure and then click on Configuration.

3. Click on the General tab.

4. In the Auto logout (minutes) field, you can set the time (between 1 to 999 minutes) for 
the automatic logout.

5. Click on Save.

NOTE: Entering the value »0« disables the automatic user logout.
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Remembering a username in the login box

If the same users often works at a certain DWC, their login can be used as default in 
the login box of the KVM matrix system.

After a user has logged out of the system, the login mask automatically remembers 
the username of the last active user.

How to remember the username in the login mask:

1. In the menu, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the DWC you want to configure and then click on Configuration.

3. Click on the General tab.

4. In the Remember last user field, you can select between the following options:

5. Click on Save.

Yes: The system remembers the last user.

No: The system does not remember the last user.
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Adjusting the operating mode of the RS232 interface

In the default setting of the DWC, you can connect any RS232-compatible device to 
the RS232 interface of the DWC. The RS232 data stream is transmitted unchanged 
to the computer module.

Fro transmitting RS422 signals, you can use two G&D RS232-422 adapters. Each of the 
adapters converts the RS232 interface of the console module and the computer module 
into RS422 interfaces.

How to set the operating mode of the RS232 interface:

1. In the menu, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the DWC you want to configure and then click on Configuration.

3. Click on the General tab.

4. Select one of the options of the Serial communication field under the paragraph  
Configuration:

5. Click on Save.

IMPORTANT: If you want to transmit RS422 signals, in addition to using adapters, 
you also need to change the operating mode of the RS232 interfaces of both the 
DWC and the computer module.

RS232: The data stream of an RS232 device is transmitted 
from the console module to the computer module 
(default).

RS422: The data stream of an RS422 device is transmitted 
from the console module to the computer module 
via separately available G&D RS232-422 adapters.
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Defining a default view filter

After the user login, the default setting of the Comp. modules menu and the Select
menu displays all computer modules. By applying a view filter, you can filter the 
computer modules to be displayed.

If you want to activate a certain view filter directly after accessing the Comp. 
modules menu and after accessing the Select menu, you can configure the user 
account accordingly. 

Defining the primary mouse button

The DWC WindowManager is optimized for mouse operation. 

How to change the primary mouse button for a user account:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the tab KVM matrix systems and click on Personal profile in the selection area 
on the right-hand side.

4. Go to the DynamicWorkplace-CONs section.

5. Under Primary mouse button, select between the following options:

6. Click on Save.

NOTE: Information on defining a default view filter can be found in the chapter 
Defining a default view filter on page 218 ff..

ADVICE: Mouse operation can be optimized for right-handed or left-handed users. 
For right-handed operation, the primary mouse button is placed on the left-hand 
side of the mouse (default). For left-handed operation, the primary mouse button 
can be placed on the right-hand side of the mouse.

Left mouse 
button

Primary mouse button on the left side of the mouse (default)

Right mouse 
button

Primary mouse button on the right side of the mouse
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Defining the delay before focusing by mouseover

In the DWC WindowManager, it is possible to operate a window via mouseover, 
even if this window is not in the foreground. Depending on the configuration, it 
may also be necessary to click on the window to bring it to the foreground.

How to change the delay before focusing by mouseover for a user account:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the tab KVM matrix systems and click on Personal profile in the selection area 
on the right-hand side.

4. Go to the DynamicWorkplace-CONs section.

5. In the Delay before focusing by mouseover (0-5 seconds) field, enter the desired delay in 
seconds (default: 0 = no delay).

6. Click on Save.

IMPORTANT: If a computer module is activated in a Transmission window or a 
FocusArea, which is operated via relative mouse coordinates (see Enabling Cross-
Display-Switching for the entire system on page 291 ff.), the window cannot be 
operated when moving the mouse over it.
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Defining a DWC default execution

A standard preset or a standard script/script group can be assigned to a user profile. 
The default execution takes place when the corresponding user logs on to the DWC.

How to select a default preset that is automatically executed after a user logon:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the tab KVM matrix systems and click on Personal profile in the selection area 
on the right-hand side.

4. Go to the DynamicWorkplace-CONs section.

5. In the DWC default exec. field, select the option Default preset.

6. Scroll down to the DWC default preset area.

7. Click on the slider of the desired default preset in the column DWC default preset 
(enabled).

8. Click on Save.

IMPORTANT: If the Return to last computer module function (see page 130 f.) or the 
Restore last FreeSeating session function (see page 131 f.) is activated, the user‘s 
configured DWC default execution is ignored.

ADVICE: If necessary, use the Search field to limit the number of presets to be 
displayed in the selection window.
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How to select a default script or a script group that is automatically executed 
after a user logon on a DWC:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the tab KVM matrix systems and click on Personal profile in the selection area 
on the right-hand side.

4. Go to the DynamicWorkplace-CONs section.

5. In the DWC default exec field, select the option Default script/script group.

6. Scroll down to Default script/script group.

7. Click on the slider of the desired default script/script group in the  
column Default script/script group.

8. Click on Save.

How to disable the configured DWC default execution:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the tab KVM matrix systems and click on Personal profile in the selection area 
on the right-hand side.

4. Go to the DynamicWorkplace-CONs section.

5. In the DWC default exec field, select the option None.

6. Click on Save.

ADVICE: If necessary, use the Search field to limit the number of scripts and 
groups to be displayed in the selection window.
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Return to the last computer modules

Enable the Return to last computer module function in your personal profile to remember 
the computer modules you accessed before logging out of the system. After the next 
login, you will automatically be switched to this computer modules.

How to enable automatic access to the last accessed computer modules:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the tab KVM matrix systems and click on Personal profile in the selection area 
on the right-hand side.

4. Select the option Return to last computer module under Restore last session.

5. Click on Save.

NOTE: Turning off the DWC on which the user is logged in is treated like a logout.

IMPORTANT: If the Return to last computer module function is activated, the user‘s 
configured default execution (see page 128 f.) and DWC default execution 
(see page 165 f.) are ignored.
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Restore the last FreeSeating session

Enable the Restore last FreeSeating session function in the personal profile to save the 
connection status of FreeSeating members. With this function, the last connection 
state can be restored when logging in again at the same workplace or another 
workplace that is set up and configured accordingly. By logging in or logging out to 
the Tradeswitch leader, all other FreeSeating members are automatically logged in 
with the same user (if no other user is logged in yet) or logged out (if the same user is 
logged in).

How to enable the restore last FreeSeating session function:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the tab KVM matrix systems and click on Personal profile in the selection area 
on the right-hand side.

4. Select the option Restore last FreeSeating session under Restore last session.

5. Click on Save.

Deactivation of the Restore last session function

How to disable the Restore last session function:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the tab KVM matrix systems and click on Personal profile in the selection area 
on the right-hand side.

4. Select the option Off under Restore last session.

5. Click on Save.

IMPORTANT: The prerequisite for this is the activation and configuration of the 
premium Tradeswitch function (see page 276 ff.).

NOTE: Turning off the console module or DWC on which the user is logged in is 
treated like a logout.

IMPORTANT: If the Restore last FreeSeating session function is activated, the user‘s 
configured default execution (see page 128 f.) and DWC default execution 
(see page 165 f.) are ignored.
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Show window frames

By default, windows in the WindowManager of a DWC do not have a frame. You 
can activate a frame for all windows in a user profile.

How to change the window frame display for a user account:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the tab KVM matrix systems and click on Personal profile in the selection area 
on the right-hand side.

4. Go to the DynamicWorkplace-CONs section.

5. Scroll down to the Show window frames line.

6. Move the slider to the right (activated) or left (default: deactivated).

7. Click on Save.
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Selecting a keyboard layout for WindowManager entries

If the characters entered on the DWC keyboard deviate from the characters 
displayed on the WindowManager, the selected keyboard layout does not fit the 
keyboard.

In this case, please ascertain which keyboard layout does apply to the connected 
keyboard and select the layout in the DWC settings.

How to select the keyboard layout for the DWC keyboard:

1. In the menu, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the DWC you want to configure and then click on Configuration.

3. Click on the General tab.

4. In the Keyboard layout field, you can select one of the following options:

5. Click on Save.

 German

 English (US)

 English (UK)

 French

 Spanish

 Latin American

 Portuguese

 Swedish

 Swiss-French

 Danish
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Changing the DWC MainNav hotkey to open the DWC main 
navigation

The DWC MainNav hotkey to open the DWC main navigation is used on the 
DWCs connected to the KVM matrix system. This DWC MainNav hotkey enables 
you to open the main navigation in order to operate the system.

The DWC MainNav hotkey consists of at least one DWC MainNav hotkey 
modifier key and an additional DWC MainNav hotkey, which you can freely select.

Both the DWC MainNav hotkey modifier key and the Num DWC MainNav hotkey 
can be configured by the user.

How to change the DWC MainNav hotkey to open the main navigation:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the matrix switch and then click on Configuration.

3. Select at least one of the modifiers listed under DWC MainNav hotkey modifier:

4. In the DWC MainNav hotkey field, select one of the following options:

5. Click on Save.

NOTE: The DWC MainNav hotkey Num is the default DWC MainNav hotkey. By 
default there is no DWC MainNav hotkey modifier.

 Ctrl

 Alt

 Alt Gr

 Win

 Shift

Pause Pause key

Insert Insert key

Delete Delete keye

Home Home key

PgUp Page up key

PgDown Page down key

Num Num key

End End key

Space Space key
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Calling presets via DWC preset keys

After you have configured DWC preset key modifier key(s) and a DWC preset key set, 
and enabled a DWC preset key set in the user account, you can call a preset using key 
combinations on the keyboard of the DWC.

Changing DWC preset key modifier or valid key type

DWC preset keys enable you to quickly call a previously saved status with a key 
combination. For this, you can create DWC preset key sets in the KVM matrix system.

In combination with a DWC preset key modifier, a DWC preset key set defines the 
key combination to be pressed to access a particular preset.

In addition to the DWC preset key modifier, you are also enabled to define valid 
keys for the DWC preset keys.

How to change the DWC preset key modifier or the valid keys:

1. In the menu, click on Matrix systems > [Name] > Matrix switches.

2. Click on the matrix switch and then click on Configuration.

3. Select at least one of the listed modifiers under DWC preset key modifier in the 
Configuration paragraph by marking the respective entry:

 Ctrl  Win

 Alt  Shift

 Alt Gr
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4. In the Valid DWC preset keys field, you can select one of the following options:

5. Click on Save.

Administrating DWC preset key sets

The KVM matrix system allows you to create 20 global DWC preset key sets or ten 
individual DWC preset key sets for each user.

Within a DWC preset key set, you can define DWC preset keys for presets you want 
to call.

You can administrate DWC preset key sets comfortably with a wizard. Click on the 
menu Advanced features and select the entry DWC preset keys. Click on Configuration to start 
the wizard.

The following paragraphs briefly summarise the wizard's configuration options.

Step 1: Select a matrix switch

 Select the matrix switch on which you want to store the configuration of the 
DWC preset key set.

Only numbers: Only numerical keys are interpreted as DWC preset keys 
when pressed in combination with the DWC preset key 
modifier

Only characters: Only alphabetic keys are interpreted as DWC preset keys 
when pressed in combination with the DWC preset key 
modifier

Numbers and 
characters:

Alphabetical and numerical keys are interpreted as DWC 
preset keys when pressed in combination with the 
DWC preset key modifier

IMPORTANT: The selected valid DWC preset keys and the DWC preset key 
modifier are no longer provided as key combinations to the operating system 
and the applications on the desired computer.

NOTE: Global DWC preset key sets are available for all users of the KVM matrix 
system.

NOTE: After you selected a matrix switch, you will see the current configuration of 
the DWC preset key modifier and the valid DWC preset keys (see above). If required, you 
can change these settings directly in this menu.
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Step 2: Select a user

 Select a user account for which the configured DWC preset keys will be available.
When selecting the entry Available for all (global), you create a global DWC preset 
key set that will be available for all users.

Step 3: Add or select DWC preset key sets

 Select the DWC preset key set you want to configure.
Click on the buttons Add, Edit or Delete to add a new DWC preset key set or to edit 
or delete an existing set.

 Click on the slider Activate DWC preset key set for current user if you want to activate 
the set for the user selected in step 2.

Step 4: Assign presets and edit DWC preset key sets

 Enter the desired key combinations for the preset.

IMPORTANT: If you have selected the table entry Available for all (global) in step 2, 
clicking on the slider activates the set for all users.

NOTE: Only by assigning a DWC preset key set to a user account, the DWC preset 
keys defined in the set are accepted as inputs on the DWC and accessing the 
corresponding preset takes place.
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Changing the hotkey to open the Window Menu

The hotkey to open the OSD is used on the console modules connected to the 
KVM matrix system. On a DWC, this hotkey can be used to open the 
Window Menu.

Opening the Window Menu via double keypress

Instead of opening the Window Menu with a hotkey, you can define a key to press 
twice to open the Window Menu.

Viewing the active connections of a DWC 
transmission channel

How to view the active connections of a DWC transmission channel:

1. In the menu, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the desired DWC and then click on Configuration.

3. Click on the Transmission tab.

4. Click on the desired DWC transmission channel and  
then click on Service tools > Active connections.

A table informs you about all components (such as console module,  
matrix switch and computer module) included in the active connection.

You can also view the medium (CAT/fibre) and the connected user.

5. Click on Close.

NOTE: Information on changing the hotkey can be found in the chapter 
Changing the hotkey to open the OSD on page 211 ff..

NOTE: Information on changing this key can be found in the chapter 
Opening the OSD via double keypress on page 213 ff..
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Restarting a DWC

This function enables you to restart the DWC. Before restarting the device you are 
requested to confirm your action to prevent accidental restarts.

How to restart a DWC via web application:

1. In the menu, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the DWC you want to restart.

3. Click on Service tools and then click on Restart.

4. Confirm the security prompt with Restart.
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Updating the firmware of a DWC
You can use the web application to update the firmware of a DWC.

How to update the firmware of a DWC:

1. In the menu, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the DWC you want to update.

3. Click on Service tools and then click on Firmware update.

4. Click on Supply firmware image files.

Select the firmware file on your local data carrier and click on Open.

The firmware file is transferred to the internal device memory and can then be 
selected for the update.

5. Select the firmware files to be used from the internal device memory  
and click on Continue.

6. If required, select the Target version of the devices if you have  
selected several firmware files for one device in step 5.

7. Click on the Update slider of all devices you want to update.

8. Click on Run update.

ADVICE: If the firmware file is already stored in the internal device memory, 
you can skip this step.

ADVICE: Press the Shift key to select multiple firmware files using the left mouse 
key.

IMPORTANT: Do not close the browser session while devices are being updated. 
Do not turn off the devices or disconnect them from the power supply during 
the update.
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Viewing status information of a DWC

How to view the status information of a DWC:

1. In the menu, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the DWC you want to configure and then click on Configuration.

3. Click on the Information tab.

4. Now you are provided with the following information:

5. Click on Close.

Name: Name of the DWC

Device ID: Physical ID of the DWC

Status: Current status (Online or Offline) of the DWC

Klasse: Device class

Firmware name: Firmware name

Firmware rev: Firmware version

Hardware rev.: Hardware version

IP address A: IP address of the network interface A

IP address B: IP address of the network interface B

MAC A: MAC address of the network interface A

MAC B: MAC address of the network interface B

Serial number: Serial number of module

SFP type: Name of the SFP module (fibre variant only)

DWC transmission 
channel - Matrix 
switch:

Name of matrix switch to which the desired DWC 
transmission channel is connected.

DWC transmission 
channel - Port:

Matrix switch port to which the desired DWC 
transmmission channel is connected.

NOTE: In addition, Active features and the Monitoring information of the device 
are displayed.
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Remote gateways and remote targets
The computer modules of the RemoteAccess-CPU series let you integrate virtual 
machines into a digital matrix switch. You can access these virtual machines via 
network.

Like other computer modules, the virtual machines connected via these computer 
modules are integrated into the OSD and the operating concept of the matrix 
switch:

As usual, you connect to a virtual machine (remote target) via the Select menu in the 
OSD and can also use functions such as push-get, multi-user access or CrossDisplay-
Switching with these virtual machines.

The instructions and functions provided in the chapter Computer modules on 
page 91 ff. also apply for remote targets (apart from marked exceptions). 

To connect a remote target, you need to configure the remote gateway, the different 
remote targets and the remote pools.

NOTE: To establish a network connection to virtual machines, you can use the 
SSH, VNC or RDP protocol.

With the fee-based RemoteAccess Streaming Feature, streams can also be received via 
RTP/TCP, RTSP/TCP and MMSH transport protocols. The H.265, H.264, VP8 and VP9
codecs for decoding video data and MPGA, MP3 and AC3 for decoding audio data are 
supported.

NOTE: The following terms are important to distinguish in connection with remote 
targets:

 Remote gateway: Each connected computer module of the RemoteAccess-CPU
series is listed under Remote Gateways in the web application.

Remote gateways establish a connection between a KVM matrix system and virtual 
machines

 Remote targets: Configured virtual machines are called remote targets within a 
KVM matrix system. They are listed under Remote targets in the web application

 Remote pools: A remote pool groups all remote targets that are accessible via the 
remote gateways included in the pool.

NOTE: You can adjust the mouse speed of a remote target. Further information on this 
topic are provided on page 297 of this manual and in the separate OSD manual.
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Configuring remote gateways

Changing the name of a remote gateway

How to change the name of a remote gateway:

1. In the menu, click on Matrix systems > [Name] > RemoteGateways.

2. Click on the remote gateway/computer module you want to configure and  
then click on Configuration.

3. Enter the name in the Name field of the Device section.

4. Click on Save.

Changing the comment of a remote gateway

The list field of the web application displays the name of a remote gateway as well 
as the comment entered.

How to change the comment of a remote gateway:

1. In the menu, click on Matrix systems > [Name] > RemoteGateways.

2. Click on the remote gateway/computer module you want to configure and  
then click on Configuration.

3. Enter any comment in the Comment field of the Device section.

4. Click on Save.
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Configuring the network interface

The device provides a network interface. This interface is used to connect to one of 
the virtual machines and allows direct access to the web application.

By default, the following settings of the Network interface are preselected:

How to configure the settings of a network interface:

1. In the menu, click on Matrix systems > [Name] > RemoteGateways.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Network.

 IP address of the Network interface: 
Obtain address via DHCPv4 (Fallback: IP address:192.168.0.1)

 Global network settings: 
Obtain settings dynamically

NOTE: The Link Local address space 169.254.0.0.0/16 is reserved for internal 
communication between devices according to RFC 3330. It is not possible to 
assign an IP address of this address space!
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4. Enter the following values under Network:

5. Click on Save.

NOTE: Each network interface is assigned a unique zone ID in addition to its 
name, which specifies the interface number. This is required to uniquely 
identify the corresponding interface when using IPv6 link-local addresses.

Operating mode: Select the operating mode of the Network interface:

 Off: Disable network interface.
 Static IPv4: A static IPv4 address is assigned.
 DHCPv4: Obtain IPv4 address from a DHCP server.

IPv4 address: Enter the IPv4 address of the interface (only when operating 
mode Static IPv4 is selected).

Netmask: Enter the netmask of the network (only when operating 
mode Static IPv4 is selected).

IPv6: Click the toggle switch to enable IPv6 (green/right = enabled).

Click the toggle switch to disable IPv6 (grey/left = disabled 
(default)).

IPv6 address: Enter the static IPv6 address of the interface.

Subnet prefix 
length:

Specify the prefix length (default: 64) for the interface 
according to the notation rules defined in RFC 5952.

NOTE: When IPv6 is enabled, a link-local IPv6 address is automatically 
generated based on the MAC address of the interface by default, in 
accordance with RFC 4921. This link-local IPv6 address cannot be 
modified by the user.
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Configuring global network settings

Global network settings ensure that the web application is accessible from all 
subnetworks, even in complex networks.

How to configure global network settings:

1. In the menu, click on Matrix systems > [Name] > RemoteGateways.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Network.

4. Select the section Global settings.

5. Enter the following values:

Operating mode: Enter the desired operating mode:

 Static: Use of static settings.
 Dynamic: Partial automatic retrieval of the settings 

described below from a DHCP server (IPv4) or via 
SLAAC (IPv6).

Hostname: Enter the hostname of the device.

Domain: Enter the domain to which the device should belong.

Gateway IPv4: Enter the IPv4 address of the gateway.

Gateway IPv6: Enter the IPv6 address of the gateway.

DNS server 1: Enter the IP address of the DNS server.. 

DNS server 2: Optionally, enter the IP address of another DNS server.. 

Prioritization of 
IPv6:

Click the toggle switch if IPv6 should be preferred when a 
destination has both an IPv6 and an IPv4 address 
(green/right = IPv6 is preferred).

Click the toggle switch if IPv6 should not be preferred 
(grey/left = IPv6 is not preferred, default).

Use IPv6 
Stateless 
Address Auto-
configuration 
(SLAAC):

Click the toggle switch if SLAAC should be used 
(green/right = SLAAC is used, default). 

Click the toggle switch if SLAAC should not be used 
(grey/left = SLAAC is not used).

NOTE: If a link-local IPv6 address is entered, the zone ID of the interface 
must be specified. The zone ID is appended to the link-local IPv6 address, 
separated by the percent sign %.

NOTE: If a link-local IPv6 address is entered, the zone ID of the interface 
must be specified. The zone ID is appended to the link-local IPv6 address, 
separated by the percent sign %.
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6. Click on Save.

Send ICMP Echo 
Reply to Echo 
Request from a 
Multicast/anycast 
address (IPv6):

Click the toggle switch if ICMPv6 Echo Requests should be 
answered (green/right = Echo Requests are answered, 
default). 

Click the toggle switch if ICMPv6 Echo Requests should not 
be answered (grey/left = Echo Requests are not answered).

Send ICMP 
destination 
unreachable 
messages (IPv6):

Click the toggle switch if an ICMPv6 error message should 
be sent to the sender when a packet cannot be delivered 
(green/right = error message is sent, default).

Click the toggle switch if no ICMPv6 error messages should 
be sent (grey/left = error message is not sent).

Process redirect 
messages (IPv6):

Click the toggle switch if redirect messages should be 
accepted and processed (green/right = redirect messages are 
processed, default). 

Click the toggle switch if redirect messages should not be 
processed (grey/left = redirect messages are not processed).

Duplicate 
Address 
Detection (IPv6):

Click the toggle switch if a check for duplicate IPv6 
addresses should be performed before an address is used 
(green/right = duplicate address check is performed, default). 

Click the toggle switch if no check for duplicate IPv6 
addresses should be performed (grey/left = no duplicate 
address check is performed).
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Assigning a remote pool

A remote pool groups all remote targets that are accessible via the existing remote 
gateways included in the pool.

All remote targets and remote gateways are automatically assigned to the default pool. If 
you want to limit the accessibility, you can do so at any time by assigning a pool 
that you have defined.

How to change the pool assignment of a remote gateway:

1. In the menu, click on Matrix systems > [Name] > RemoteGateways.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Remote pool.

4. In the Assigned column, click on the slider of the pool (enabled) to which you 

want to assign the remote gateway.

5. Click on Save.

NOTE: Each remote gateway belongs to exactly one remote pool.

If you don’t select a specific pool, the remote gateway automatically belongs to 
the default pool.
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Viewing monitoring values

You can see the list of all monitoring values under Remote gateways.

How to open the list containing all monitoring values:

1. In the menu, click on Matrix systems > [Name] > RemoteGateways.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Monitoring.

The displayed table contains a list of all available monitoring values.

4. Click on Save.

NOTE: Chapter Monitoring functions on page 55 ff. provides more information on 
how to configure monitoring values.
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Viewing status information of a remote gateway

How to view the status information of a remote gateway:

1. In the menu, click on Matrix systems > [Name] > RemoteGateways.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Information.

4. The following information is displayed in the dialog box that opens now:

5. Click on Close.

Name: Name of the remote gateway

Device ID: Unique ID of the remote gateway

Status: Current status (online or offline) of the  
remote gateway

Class: Device class

Firmware name: Firmware name

Firmware rev.: Firmware version

Hardware rev.: Hardware version

IP address A: IP addresses of the network interface

IP address Transmission: IP addresses of the transmission interface

MAC A: MAC address of the network interface

MAC Transmission: MAC address of the transmission interface

Serial number: Serial number of the module

Matrix switch: Name of the matrix switch to which the module is 
connected

Port: Port of the matrix switch to which the module is 
connected

NOTE: In addition, Active features and the Monitoring information of the device 
are displayed.
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Configuring remote targets

Changing the name of a remote target

How to change the name of a remote target:

1. In the menu, click on Matrix systems > RemoteTargets.

2. Click on the remote target you want to configure and then  
click on Configuration.

3. Enter the name of the remote target in the Name field of the Device section.

4. Click on Save.

Changing the comment of a remote target

The list field of the web application displays the name of a remote target as well as 
the comment entered.

How to change the comment of a remote target:

1. In the menu, click on Matrix systems > RemoteTargets.

2. Click on the remote target you want to configure and then  
click on Configuration.

3. Enter any comment in the Comment field of the Device section.

4. Click on Save.
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Saving the resolution of a virtual machine

To make sure the video signal from the virtual machine is displayed correctly on the 
console modules, you need to provide information about the resolution set in the 
virtual machine.

How to save the resolution set in a virtual machine in the KVM matrix system:

1. In the menu, click on Matrix systems > RemoteTargets.

2. Click on the remote target you want to configure and then  
click on Configuration.

3. Select the resolution set in the virtual machine in the Resolution field  
on the General tab:

4. Click on Save.

1024x768/60Hz/VESA DMT

1280x1024/60Hz/VESA DMT

1680x1050/60Hz/VESA CVT

1600x1200/60Hz/VESA DMT

1920x1080/60Hz/CTA-861-D

2560x1440/60Hz/VESA CVT-RB

2560x1600/60Hz/VESA CVT-RB

3840x2160/30Hz/VESA CVT-RB
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Reducing the colour depth of the image data to be transmitted

By default, a remote target transmits image information with a maximum colour 
depth of 24 bit to the console module.

When using a high image resolution and displaying moving images, it may happen in 
exceptional cases that some images are "skipped" on the console module.

In this case, reduce the colour depth of the image data to be transmitted to 18 bit. This 
can reduce the data volume to be transmitted.

How to reduce the colour depth of image data to be transmitted:

1. In the menu, click on Matrix systems > RemoteTargets.

2. Click on the remote target you want to configure and then  
click on Configuration.

3. In the Colour depth field of the Configuration section, select one of the  
following options:

4. Click on Save.

Holding a connection

In the default setting of the matrix switch, the existing connection is disconnected 
when switching from a remote target to a “classic” computer module or to a remote target 
of another pool. The connection to the “classic” computer module is then established.

You can also hold the connection to the remote target for a specified period of time 
(1 to 10 minutes) or permanently. Within this time span, you can quickly continue the 
existing connection by reconnecting to the console module or to the DWC.

NOTE: Depending on the content of the image, slight colour gradations may occur 
when reducing the colour depth.

24 Bit: Transmit image data with a maximum colour depth of 24 bits.

18 Bit: Reduce colour depth of image data to 18 bits.

IMPORTANT: Activating this option may pose a security risk, since reconnecting to 
the remote target within the holding period does not require a new login!

NOTE: When connecting to another remote target of the same pool, the existing 
connection cannot be maintained, since only one connection via a remote 
gateway is possible at any time.
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How to set the hold period of a connection:

1. In the menu, click on Matrix systems > RemoteTargets.

2. Click on the remote target you want to configure and then  
click on Configuration.

3. Set the holding period in the Hold connection field of the Configuration paragraph 
between 1 and 10 minutes or permanently.

You can also disable the hold function (No).

4. Click on Save.

Connection repeats

If the connection to a remote target is interrupted or not possible, you can configure 
a number and interval of connection repeats.

How to set the number and the interval of connection repeats:

1. In the menu, click on Matrix systems > RemoteTargets.

2. Click on the remote target you want to configure and then  
click on Configuration.

3. In the Number of connection repeats field under Configuration, you can define the 
number of connection repeats (between 0 and 999).

4. In the Interval of connection repeats (seconds) field, you can define an interval 
between 1 and 999 seconds at which several connection repeats are executed.

5. Click on Save.

NOTE: Connection repeats are disabled in the default settings.
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Defining the connection parameters for a remote target

How to configure the basic connection parameters for a remote target:

1. In the menu, click on Matrix systems > RemoteTargets.

2. Click on the remote target you want to configure and then  
click on Configuration.

3. Click on the tab Connection.

4. Enter the following values:

5. When selecting the RDP protocol, additionally enter the following information:

IP address/DNS 
name:

Enter the IP address or name of the virtual machine.

Protocol: Select the protocol used to connect the virtual machine:

 SSH
 VNC
 RDP
 Streaming

Port: Enter the port to be used to connect to the terminal 
server.

Remote FX 
optimisation:

Enable Remote FX optimisation if supported by the 
RDP server.

You can enable RemoteFX optimisation specifically for 
static images (Image) of a common desktop environment 
or for moving images (Video).
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6. When selecting the VNC protocol, additionally enter the following information:

7. When selecting the Streaming protocol, additionally enter the following information:

8. Click on Save.

Quality: Select a quality level between 0 (low) and 9 (high).

Compression: Select a compression level between 0 (fast) and 9 (best).

Cursor highlighting: After enabling the function, the local cursor (circle) of the 
RemoteAccess-CPU is displayed in addition to the cursor of 
the virtual machine.

Audio delay: Set the delay in the range from -2500 to 2500 ms.
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Saving login data or use the matrix credentials for login

To automatically log on a user after connecting to the virtual machine, you can save 
the login data in the web application.

Alternatively you have the option to use the login data of the matrix for the login of 
the remote targets, as well.

How to capture the credentials for login of the remote target:

1. In the menu, click on Matrix systems > RemoteTargets.

2. Click on the remote target you want to configure and then  
click on Configuration.

3. Click on the tab Connection.

4. Enter the following values:

5. Click on Save.

Use matrix  
credentials:

Enable or disable this function.

Default: function is disabled.

If you enable this function, any remote target credentials 
(username and password) that may have been entered 
are ignored.

Username Enter the username of the user to log on.

Password Enter the password of the user to log on.

NOTE: Depending on the configuration of the virtual machine, it is sometimes 
necessary to enter both username and password; sometimes you only need to 
enter the password!
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Assigning a remote pool

A remote pool groups all remote targets that are accessible via the existing remote 
gateways included in the pool.

All remote targets and remote gateways are automatically assigned to the default pool. If 
you want to limit the accessibility, you can do so at any time by assigning a pool 
that you have defined.

How to change the pool assignment of a remote target:

1. In the menu, click on Matrix systems > RemoteTargets.

2. Click on the remote target you want to configure and then  
click on Configuration.

3. Click on the tab Remote pool.

4. In the Assigned column, click on the slider of the pool (enabled) to which you 

want to assign the remote target.

5. Click on Save.

Viewing monitoring values

You can see the list of all monitoring values under RemoteTargets.

How to open the list containing all monitoring values:

1. In the menu, click on Matrix systems > RemoteTargets.

2. Click on the remote target you want to configure and then  
click on Configuration.

3. Click on the tab Monitoring.

The displayed table contains a list of all available monitoring values.

4. Click on Save.

NOTE: Each remote target belongs to exactly one remote pool.

If you don’t select a specific pool, the remote target automatically belongs to the 
default pool.

NOTE: The chapter Monitoring functions on page 55 ff. provides more information 
on how to configure monitoring values.
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Viewing status information of a remote target

How to view the status information of a remote target

1. In the menu, click on Matrix systems > RemoteTargets.

2. Click on the remote target you want to configure and then  
click on Configuration.

3. Click on the tab Information.

4. The following information is displayed in the dialog box that opens now:

5. Click on Close.

Name: Name of the remote target

Device ID: Physical ID of the remote target

Status: Current status (online or offline) of the remote target

Class: Device class

NOTE: In addition, the Monitoring information of the remote target are displayed.
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Computer module groups and view 
filters
Computer modules of the KVM matrix system can be arranged in computer module 
groups and view filters.

Intended use of computer module groups
Creating computer module groups enables administrators to quickly assign the 
rights of a user or a user group to all computer modules within a group.

Intended use of view filters
View filters enable users of a KVM matrix system to organise the different computer 
modules into OSD views and WindowManager views (at a DWC). Especially in 
large KVM matrix systems, creating view filters provides better orientation in the 
OSD and WindowManager.

You can group computer modules according to their location (e.g. the server room) 
or other features (e.g. to the operating system of the connected computer).

Administrating computer module groups

The »New digital targets« and »New analog targets« computer 
module groups

By default, the New digital targets and New analog targets computer module groups are
created in the KVM matrix system. This groups automatically contain all computer 
modules as soon as they are first connected to the KVM matrix system. For this, the 
computer connected to the module has to be switched on.

If you want to provide a user or a user group with particular rights to all recently 
connected computer modules, change the device group rights (see page 91) of either 
the user account or the user group.

NOTE: The different computer modules can be members of multiple computer 
module groups.
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Creating a new computer module group

How to create a new computer module group:

1. In the menu, click on Computer module groups.

2. Click on Add computer module group and  
select the type of group you want to add.

3. In the Name field, you can enter the name  
of the computer module group.

4. In the Comment field, you can enter a comment  
about the computer module group.

5. Click on Save.

Changing the name or comment of a computer module group

How to change the name or comment of a computer module group:

1. In the menu, click on Computer module groups.

2. Click on the computer module group you want to  
configure and then click on Configuration.

3. In the Name field, you can change the name of the  
computer module group.

4. In the Comment field, you can enter or change a comment  
about the computer module group.

5. Click on Save.

NOTE: You can assign the rights for this computer module group by changing the 
device group rights (see page 93) of either the user account or the user group.
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Administrating computer module group members

How to administrate the members of a computer module group:

1. In the menu, click on Computer module groups.

2. Click on the computer module group you want to  
configure and then click on Configuration.

3. Click on the Members tab.

4. In the Members column, click on the slider of the  
computer modules you want to add to the group (enabled).

5. In the Members column, click on the slider of the  
computer modules you want to delete from the group (disabled).

6. Click on Save.

Deleting a computer module group

How to delete a computer module group:

1. In the menu, click on Computer module groups.

2. Click on the computer module group you want to  
delete and then click on Delete.

3. Confirm the confirmation prompt by clicking on Yes or  
cancel the process by clicking on No.

NOTE: You can assign up to 20 computer modules to each computer module 
group of the KVM matrix system.

ADVICE: If necessary, use the Search field to limit the number of computer modules
to be displayed in the selection window.

ADVICE: If necessary, use the Search field to limit the number of computer modules
to be displayed in the selection window.
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Administrating view filters
To administrate view filters, you can use the View filter wizard provided in the menu 
Advanced features.

The wizard shows you how to set up, configure and assign a view filter to one or 
more user accounts.

How to start the »View filter« wizard:

1. In the menu, click on Advanced features.

2. Click on View filter and then click on Configuration.

3. Follow the instructions of the wizard.

Creating a new view filter

How to create a new view filter:

1. Start the View filter wizard (see page 200 f.).

2. In Step 1 of the wizard, click on Add.

3. In the Name field, you can enter a name.

4. In the Comment field, you can enter a comment.

5. Click on Save.

Changing the name of a view filter

How to change the name of a view filter:

1. Start the View filter wizard (see page 200 f.).

2. In Step 1 of the wizard, click on the view filter you want to edit and  
then click on Edit.

3. Edit the name of and/or the comment about the view filter.

4. Click on Save.

Deleting a view filter

How to delete a view filter:

1. Start the View filter wizard (see page 200 f.).

2. In Step 1 of the wizard, click on the view filter you want to delete and  
then click on Delete

3. Confirm the confirmation prompt by clicking on Yes or  
cancel the process by clicking on No.
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Adding a computer module to a view filter

How to add a computer module to a view filter:

1. Start the View filter wizard (see page 200 f.).

2. In Step 1 of the wizard, click on the view filter you want to edit and  
then click on Edit.

3. In Step 2, click on the slider (in the Show devices column) of the computer modules 
you want to add to the view filter.

Deleting a computer module from a view filter

How to delete a computer module from the view filter:

1. Start the View filter wizard (see page 200 f.).

2. In Step 1 of the wizard, click on the view filter you want to edit and  
then click on Edit.

3. In Step 2, click on the slider (in the Show devices column) of the computer modules 
you want to delete from the view filter.

ADVICE: If necessary, use the Search field to limit the number of computer modules
to be displayed selection window.

NOTE:  To simultaneously assign all computer modules to a view filter, mark the 
check box in the header of the Show devices column.

ADVICE: If necessary, use the Search field to limit the number of computer modules
to be displayed selection window.

NOTE:  To simultaneously delete all displayed computer modules from the view 
filter, mark the check box in the header of the Show devices column.
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Assigning a view filter as default in the OSD

How to set a default filter:

1. Start the View filter wizard (see page 200 f.).

2. In Step 1 of the wizard, click on the view filter you want to edit and  
then click on Edit.

3. In Step 2,assign one or multiple computer module(s) to the view filter.

4. In Step 3, click on the slider (in the Use as default in OSD column) of the user 
accounts that will use the view filter as default in the OSD (enabled).    

ADVICE: If necessary, use the Search field to limit the number of user accounts 
to be displayed selection window.

NOTE: To simultaneously set a view filter as default for all displayed user 
accounts, mark the check box in the header of the Use as default in OSD column.

NOTE: The view filters are also available in the WindowManager of a DWC.
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Accessing computer modules via 
select keys
After you have defined Select-Key modifier key(s) and a Select-Key Set and activate a 
Select-Key Set in the user account, you can connect to a computer module by pressing 
key combinations on the console module keyboard and DWC keyboard.

Changing select key modifier or valid key type
Select keys enable you to quickly access a particular computer module with a key 
combination. For this, you can create select key sets in the KVM matrix system.

In combination with a select key modifier, a select key set defines the key 
combination to be pressed to access a particular computer module.

In addition to the select key modifier, you are also enabled to define valid keys for 
the select keys.

How to change the select key modifier or the valid keys:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the matrix switch and then click on Configuration.

3. Select at least one of the listed modifiers under Select key modifier in the Configuration 
paragraph by marking the respective entry:

 Ctrl  Win

 Alt  Shift

 Alt Gr
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4. In the Valid select keys field, you can select one of the following options:

5. Click on Save.

Administrating select key sets
The KVM matrix system allows you to create 20 global select key sets or ten individual 
select key sets for each user.

Within a select key set, you can define select keys for computer modules you want 
to access.

You can administrate select key sets comfortably with a wizard. Click on the menu 
Advanced features and select the entry Select keys. Click on Configuration to start the 
wizard.

The following paragraphs briefly summarise the wizard's configuration options.

Step 1: Select a matrix switch

 Select the matrix switch on which you want to store the configuration of the select 
key set.

Only numbers: Only numerical keys are interpreted as select keys when 
pressed in combination with the select key modifier

Only characters: Only alphabetic keys are interpreted as select keys when 
pressed in combination with the select key modifier

Numbers and 
characters:

Alphabetical and numerical keys are interpreted as select 
keys when pressed in combination with the select key 
modifier

IMPORTANT: The selected valid keys and the select key modifier are no longer
provided as key combinations to the operating system and the applications on 
the desired computer.

NOTE: Global select key sets are available for all users of the KVM matrix system.

NOTE: After you selected a matrix switch, you will see the current configuration of 
the select key modifier and the valid select keys (see above). If required, you can 
change these settings directly in this menu.
204 · G&D ControlCenter-Compact



Accessing computer modules via select keys
Step 2: Select a user

 Select a user account for which the configured select keys will be available.
When selecting the entry Available for all (global), you create a global select key set 
that will be available for all users.

Step 3: Select key sets

 Select the select key set you want to configure.
Click on the buttons Add, Edit or Delete to add a new select key set or to edit or 
delete an existing set.

 Click on the slider Activate select key set for current user if you want to activate the set 
for the user selected in step 2.

Step 4: Configure a select key set

 Enter the desired key combinations for the computer modules.

IMPORTANT: If you have selected the table entry Available for all (global) in step 2, 
clicking on the slider activates the set for all users.

NOTE: Only by assigning a select key set to a user account, the select keys defined 
in the set are accepted as inputs on the console module and DWC and switching 
to the corresponding computer module takes place.

ADVICE: In the line Return to last computer module you can define a key combination for 
switching to the computer module that was switched on last.
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Automatic or manual switching between computer modules
Automatic or manual switching 
between computer modules

Auto scanning all computer modules (Autoscan)
The Autoscan function successively accesses all computer modules that are included 
in the active scan mode set and available to users.

The Scantime setting (see page 207) enables you to define how long you want to 
switch to a computer module.

When switching to a computer module, the console module name, the name of the 
currently accessed computer module, and a note regarding the Autoscan function are 
displayed.

IMPORTANT: Functions of automatic and manual switching between computer 
modules are not available on a DynamicWorkplace-CON (DWC).

NOTE: If the Autoscan function is active, keyboard and mouse inputs are 
transmitted to the currently accessed computer module.

During inputs, the Autoscan function stops and continues after the inputs are finished.
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Automatic or manual switching between computer modules
Applying the Autoscan function

Configuring the scantime of the Autoscan function

By default, a computer module is accessed for 10 seconds before the connection is 
disconnected and the next computer module is accessed.

Select a time span between 1 and 99 seconds to define how long you want to switch 
to a computer module.

How to change the scantime:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the tab Matrix systems and then go to Personal Profile.

4. In the Scantime (1-99 seconds) field, enter a time span between 1 and 99 seconds.

5. Click on Save.

Requirements for using this function:

 Creating a scanmode set (see page 210 ff.)
 Assigning a scanmode set to a user account (see page 210 ff.)
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Automatic or manual switching between computer modules
Auto scanning all active computer modules (Autoskip)
The Autoskip function successively switches to computer modules that are included 
in the active scancode set and available to users.

The connected computer must be active to carry out this function.

The Scantime setting (see page 207) enables you to define how long each computer 
module is to be accessed.

When accessing the computer modules, the console module name, the name of the 
currently accessed computer module, and a note regarding the Autoscan function are 
displayed.

Applying the Autoskip function 

Configuring the scantime of the Autoskip function

By default, a computer module is accessed for 10 seconds before the connection is 
disconnected and the next computer module is accessed.

Select a time span between 1 and 99 seconds to define how long you want to switch 
to a computer module.

How to change the scantime:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the Matrix systems tab and then go to Personal Profile.

4. In the Scantime (1-99 seconds) field, enter a time span between 1 and 99 seconds.

5. Click on Save.

NOTE: If the Autoskip function is activated, all keyboard and mouse inputs are 
transmitted to the currently accessed computer module.

The Autoskip function stops during the user’s inputs and continues after all inputs 
are finished.

Requirements for using this function:

 Creating a scanmode set (see page 210 ff.)
 Assigning a scanmode set to a user account (see page 210 ff.)
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Automatic or manual switching between computer modules
Scanning computer modules manually (Stepscan)
By pressing a key, the Stepscan function successively switches to all computer modules 
that are included in the scan mode set and available to users.

When accessing the computer modules, the console module name, the name of the 
currently accessed computer module and a note regarding the Stepscan function are 
displayed.

Starting and stopping the Stepscan function

Configuring keys for manually scan

By pressing a key, the Stepscan function successively switches to all computer modules 
that are available to users.

You can select different keys to access the next (default: Up) or the previous 
(default: Down) computer module.

How to select keys for using the Stepscan function:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the KVM matrix systems tab and then go to Personal Profile.

4. In the Step keys field, you can select between the following options:

5. Click on Save.

Requirements for using this function:
 Creating a scanmode set (see page 210 ff.)
 Assigning a scanmode set to a user account (see page 210 ff.)
 Configuring keys to scan the computer modules manually (see page 210 ff.)

Up/Down: Arrow keys Up and Down

PgUp/PgDn: Page and page keys

Num Up/Down: Arrow keys Up and Down of the numeric keypad

Num PgUp/PgDn: Page and page keys of the numeric keypad

Num +/- Plus and minus keys of the numeric keypad
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Automatic or manual switching between computer modules
Administrating scan mode sets
The matrix system enables you to create 20 global select key sets or ten individual 
scan mode sets for each user.

Scan mode sets allow you to define the computer modules to be accessed when 
executing the Autoscan, Autoskip or Stepscan function.

You can administrate scan mode sets comfortably with a wizard. Click on the menu 
Advanced features and select the entry Scan mode sets. Click on Configuration to start the 
wizard.

The following paragraphs briefly summarise the wizard's configuration options.

Step 1: Select a user

 Select a user account for which the configured scan mode keys will be available.
When selecting the entry Available for all (global), you create a global scan mode set 
that will be available for all users.

Step 2: Scan mode sets

 Select the scan mode set you want to configure.
Click on the buttons Add, Edit or Delete to add a new scan mode set or to edit or 
delete an existing set.

 Click on the slider Activate scan mode set for current user  if you want to activate the 
set for the user selected in step 2.

Step 3: Configure scan mode set

 Click on the slider Add device of all computer modules you want to include in the 
automatic switching process.

NOTE: Global scan mode sets are available for all users of the KVM matrix system.

IMPORTANT: If you have selected the table entry Available for all (global) in step 2, 
clicking on the slider activates the set for all users.

NOTE: Only by assigning a scan mode set to a user account, the computer modules 
defined in the set are considered when executing the Autoscan, Autoskip or Stepscan
function.

NOTE: Enable the option Add device in the column header to add all computer modules 
to a set.
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Configuring the on-screen display
Configuring the on-screen display
The on-screen display (OSD) of the KVM matrix system enables the user to operate and 
configure the system. By default, the OSD is provided on all console modules.  

Configuration
Most basic functions and features of the OSD can be adjusted to your demands.

You can define a hotkey to open the OSD as well as the position and font size of the 
OSD.

Any adjustable settings are described on the following pages.

Changing the hotkey to open the OSD

The hotkey to open the OSD is used on the console modules connected to the 
KVM matrix system. This hotkey enables you to open the OSD in order to operate 
and configure the system. 

The hotkey consists of at least one hotkey modifier key and an additional hotkey, 
which you can freely select.

Both the Ctrl hotkey modifier key and the Num hotkey can be configured by the user.

IMPORTANT: The OSD described here is not available on a DynamicWorkplace-CON
(DWC). A DWC is operated via the WindowManager of the respective DWC. 
Further information on operation can be found in the DWC manuals. 
Information on the corresponding configuration options can be found in the 
separate manual for the web application. Alternatively, you can also use the OSD 
of an additional console module.

NOTE: The hotkey modifier Ctrl and the hotkey Num are the default settings.

ADVICE: On a DWC, the WindowMenu can be opened by using the hotkey.
G&D ControlCenter-Compact · 211



Configuring the on-screen display
How to change the hotkey to open the OSD:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the matrix switch and then click on Configuration.

3. Select at least one of the modifiers listed under Hotkey modifier:

4. In the Hotkey field, select one of the following options:

5. Click on Save.

 Ctrl

 Alt

 Alt Gr

 Win

 Shift

Pause Pause key

Insert Insert key

Delete Delete keye

Home Home key

PgUp Page up key

PgDown Page down key

Num Num key

End End key

Space Space key
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Configuring the on-screen display
Opening the OSD via double keypress

Instead of opening the OSD with a hotkey, you can define a key to press twice to 
open the OSD.

How to define the key to open the OSD via double keypress:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the matrix switch and then click on Configuration.

3. Select one of the following options under OSD via double keypress:

4. Click on Save.

ADVICE: On a DWC, the WindowMenu can be opened by using this key.

Off: Open OSD via double keypress disabled (default)

Ctrl: Open OSD via double keypress of Ctrl key

Alt: Open OSD via double keypress of Alt key

Alt Gr: Open OSD via double keypress of Alt Gr key

Win: Open OSD via double keypress of Win key

Shift: Open OSD via double keypress of Shift key

Print: Open OSD via double keypress of Print key

Cursor-Left: Open OSD via double keypress of Cursor-Left key

Cursor-Right: Open OSD via double keypress of Cursor-Right key

Cursor-Up: Open OSD via double keypress of Cursor-Up key

Cursor-Down: Open OSD via double keypress of Cursor-Down key
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Configuring the on-screen display
Automatic closing of the OSD after inactivity

If desired, you can set the OSD to close automatically after a period of inactivity.

Define this period by entering a value between 5 and 99 seconds.

How to change a period of inactivity after which the OSD closes:

1. In the menu, click on User.

2. Click on the user account you want to edit and then click on Configuration.

3. Click on the tab KVM matrix systems and then go to Personal Profile.

4. In the Timeout of OSD sessions (5-99 seconds) field, you can define a time span  
between 5 and 99 seconds.

5. Click on Save.

NOTE: To disable the function, enter the value 0.
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Configuring the on-screen display
Adjusting the OSD transparency

In the default settings, the screen content under the OSD is semi-visible. The screen 
content shines through the part that is covered by the OSD.

You can either adjust or turn off the OSD transparency in the personal profile of a user.

How to adjust the OSD transperency:

1. In the menu, click on User.

2. Click on the user account you want to edit and then click on Configuration.

3. Click on the tab KVM matrix systems and then go to Personal Profile.

4. In the OSD transparency field,you can select between the following options:

5. Click on Save.

High: Screen content almost completely visible

Average: Screen content semi-visible (default)

Low: Screen content slightly visible

Off: Screen content is covered
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Configuring the on-screen display
Adjusting the information display

When switching to a computer module, a temporary information display (5 seconds) 
opens. The display informs you about the console name, the name of the currently 
accessed computer module and provides further information.

The information display can also be permanently displayed or deactivated. The selected 
setting is assigned to your user account and stored in your Personal Profile.

How to change the general settings of the information display:

1. In the menu, click on User.

2. Click on the user account you want to edit and then click on Configuration.

3. Click on the tab KVM matrix systems and then go to Personal Profile.

4. In the Show OSD info field, you can select between the following options: 

5. Click on Save.

NOTE: You can set the information display separately for computer modules with 
view rights and all other computer modules.

ADVICE: When active, the temporary information can be recalled by pressing 
Ctrl+Caps Lock.

5 seconds: Temporary information display

Perm: Permanent information display

Off: Deactivate information display
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Configuring the on-screen display
How to change the general settings of the information display for computer 
modules with view right:

1. In the menu, click on User.

2. Click on the user account you want to edit and then click on Configuration.

3. Click on the tab KVM matrix systems and then go to Personal Profile.

4. In the Show OSD info for computer modules with view rights field, you can select  
between the following options: 

5. Click on Save.

Changing the colour of the information display

By default, information displays (like when accessing a computer module) are shown 
in light green. In their personal profiles, users can change the colour of the information 
display.

The following colours are supported:

How to change the colour of the information display:

1. In the menu, click on User.

2. Click on the user account you want to edit and then click on Configuration.

3. Click on the tab KVM matrix systems and then go to Personal Profile.

4. In the Colour of OSD info field, you can select the desired colour.

5. Click on Save.

Use regular 
OSD info:

Using the general setting of the information display (see above)

5 seconds: Temporary information display

Perm: Permanent information display

Off: Deactivate information display

black dark red

green dark yellow

dark blue purple

dark turquoise silver

light green yellow

blue fuchsia

light turquoise white
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Configuring the on-screen display
Defining a default view filter

After the user login, the Select menu is displayed. The default setting of the Select
menu displays all computer modules. By applying a view filter, you can filter the 
computer modules to be displayed.

If you want to activate a certain view filter directly after accessing the Select menu, 
you can configure the user account accordingly.

How to select a default view filter for the Select menu:

1. In the menu, click on Advanced features.

2. Click on a view filter and then click on Configuration.

3. In step 1, select the desired view filter and click on Save and continue.

4. In step 2, select the computer modules you want to include in the view filter and 
click on Save and continue.

5. In step 3, select the users who should use this view filter as default and  
click on Save and continue.

NOTE: The default view filter is applied directly after you log in on the matrix system.

By applying this view filter, you can change the default and therefore activate 
another filter.

ADVICE: On a DWC, the standard view filter can be used as well.
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Configuring the on-screen display
Selecting a keyboard layout for OSD entries

If the characters entered on the console keyboard deviate from the characters 
displayed on the on-screen display, the selected keyboard layout does not fit the 
keyboard.

In this case, please ascertain which keyboard layout does apply to the connected 
keyboard and select the layout in the console settings.

How to select the keyboard layout for the console keyboard:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to configure and then click on Configuration

3. Click on the General tab.

4. In the Keyboard layout field, you can select one of the following options:

5. Click on Save.

 German

 English (US)

 English (UK)

 French

 Spanish

 Latin American

 Portuguese

 Swedish

 Swiss-French

 Danish
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Configuring the on-screen display
Operating the OSD by mouse

In the default settings of the KVM matrix system, the OSD can only be opened with 
a configured key combination.

If a Microsoft »IntelliMouse Explorer« or another compatible mouse with five keys is 
connected to the console module, you can open the OSD with mouse keys four and 
five on the side of the mouse.

How to enable/disable mouse support to operate the OSD:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to configure and then click on Configuration.

3. In the OSD by Mouse field in the paragraph OSD configuration, select one of the  
following options:

4. Click on Save.

Enabling/disabling the OSD

This function defines if users of a console module can activate the OSD or if they 
can use only select keys to switch between channels.

How to (de)activate the OSD:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to configure and then click on Configuration.

3. Under OSD blocked in the paragraph OSD configuration, select one of the  
following options:

4. Click on Save.

On: Open OSD with mouse key 4 and 5 of a compatible mouse.

Off: Disable the possibility to open the OSD by mouse.

No: OSD and displaying of info messages available

OSD menu: OSD blocked; displaying of info messages available

OSD menu 
+ OSD info:

OSD and displaying of info messages blocked.
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Configuring the on-screen display
Adjusting the OSD resolution

In the defaults of the matrix switch the OSD is displayed on the console monitor in 
a resolution of 1024  × 768 pixels if the monitor does support this resolution. If the 
monitor does not support this resolution, a resolution of 640 × 480 pixels is used.

You can also set the OSD resolution for the entire system (see table below). 
Adjusting the resolution for the entire system includes all console modules. 
However, you can also individually set the OSD resolution for each console 
module.

How to adjust the OSD resolution of the entire system:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the matrix you want to configure and then click on Configuration.

3. In the OSD resolution field, select one of the following options:

4. Click on Save.

Auto: If supported by the monitor, the OSD is displayed in a resolution
of 1024 × 768 pixels.

If the monitor does not support this resolution, a resolution of 
640 × 480 pixels is used. (default).

640×480: OSD is displayed in a resolution of 640 × 480 pixels

720×400: OSD is displayed in a resolution of 720 × 400 pixels

1024×768: OSD is displayed in a resolution of 1024 × 768 pixels
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Configuring the on-screen display
How to adjust the OSD resolution of a particular console module:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to configure and then click on Configuration.

3. In the OSD resolution field of the paragraph OSD configuration, select one of the  
following options:

4. Click on Save.

System: Use system-wide (see above) setting (default).

Auto: If supported by the monitor, the OSD is displayed in a resolution
of 1024 × 768 pixels.

If the monitor does not support this resolution, a resolution of 
640 × 480 pixels is used. (default).

640×480: OSD is displayed in a resolution of 640 × 480 pixels

720×400: OSD is displayed in a resolution of 720 × 400 pixels

1024×768: OSD is displayed in a resolution of 1024 × 768 pixels
222 · G&D ControlCenter-Compact



Special functions for cascaded KVM matrix systems
Special functions for cascaded 
KVM matrix systems
Cascading increases the number of computers that can be connected to the 
KVM matrix system. For this, several matrix switches are integrated into the system.

The configuration settings for a cascaded KVM matrix system are described in this 
chapter.

Basic functions

Changing names or comments of matrix switches

How to change names or comments of matrix switches:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the matrix switch you want to configure and then click on Configuration.

3. In the Name field, you can change the name of the matrix switch.

4. Optional: In the Comment field, you can change or enter a comment regarding the 
matrix switch.

5. Click on Save.

Deleting follower matrix switches from the system

If the KVM matrix system is not able to detect a matrix switch, which was already 
connected to the system, the device is considered inactive.

Delete the list entry of matrix switches you want to permanently remove from the 
system.

How to delete inactive or disconnected matrix switches:

1. In the directory tree, click on Matrix systems > [Name] > Matrix.

2. Click on the matrix switch you want to delete and click on Delete 

3. Confirm the security prompt by pressing Yes or cancel the process by pressing No.

NOTE: The optional KVM Matrix-Grid™ offers you further options (see Difference 
between cascade and Matrix-Grid on page 314),

NOTE: Only administrators and users with the Superuser right can delete inactive 
matrix switches.
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Special functions for cascaded KVM matrix systems
Configuration settings

Defining the cascade mode of a matrix switch

In a cascaded KVM matrix system, the single matrix switches auto detect if they 
have been installed as leader or as follower device within the cascaded system.

How to change the cascade mode of matrix switches:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the leader matrix switch and then click on Configuration.

3. Click on the tab General.

4.  Under Cascade mode, you can select between the following options:

5. Click on Save.

NOTE: Applying the Auto setting in the cascade mode may change the matrix switch’s 
operating mode if the devices’ cabling has been accidentally changed.

To avoid this, the operating mode of each matrix switch can be separately 
adjusted.

IMPORTANT: The settings regarding the cascade mode are to be carried out in the 
web application of the matrix switch whose setting you want to change.

Auto: The matrix switch decides whether it is operating in the leader or 
follower mode.

Leader: In this operating mode, only console modules and DWCs can be 
connected to the Console ports. The names of the connected 
computer modules can be edited. The edited names are 
automatically updated at the follower devices within the cascade.

Follower: In this operating mode, the connected computer modules cannot 
be renamed. The computer modules are automatically named by 
the leader device.
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Special functions for cascaded KVM matrix systems
Forwarding computer modules names to the follower matrix 
switches

Within a cascaded KVM matrix system, the computer module names from the 
superior matrix switch are forwarded to the connected matrix switch(es). This way, 
the computer modules are named identically across the entire system.

If you want to define different computer module names within the different matrix 
switches of the cascaded system, deactivate the Forward computer module names function.

How to (de)activate the forwarding of computer module names to the follower 
matrix switches:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the leader matrix switch and then click on Configuration.

3. Click on the tab General.

4. Under Forward computer module names, you can select between the  
following options:

5.  Click on Save.

IMPORTANT: Deactivating the function for forwarding the computer module names 
in the  first level of the matrix switch only affects the directly connected matrix switches 
of the second level. 

If the third level also includes follower matrix switches, this function has to be 
deactivated in the matrix switches of the second level!

On: The computer module names are forwarded from the superior 
matrix switch to the connected matrix switch(es).

Off: The computer module names are not forwarded from the superior 
matrix switch to the connected matrix switch(es).
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Expanding switchable signals
Expanding switchable signals
You can expand the switchable signals of a computer or a console through channel 
grouping

With the ControlCenter-Compact, you can switch various computer modules of one
computer or various console modules of one console at the same time.  

EXAMPLE: To transmit a second video signal and a USB 2.0 signal of the same 
computer, in addition to a first computer module, connect a second computer 
module (second video channel) and a U2+R-CPU module (USB2.0/RS232) to the 
computer.

In addition to the first console module, connect a second console module (second 
video channel) and a U2+R-CON module (USB2.0/RS232) to the console the 
aforementioned computer is accessing.

IMPORTANT: A DWC and its channels cannot be part of a channel grouping.

NOTE: Only in this mode, you can hold the USB signal using the OSD Operation
menu at the currently active computer. If you switch to another computer after 
executing the hold function, the USB signal remains on the computer that you 
accessed first.

After disabling the hold function on the Operation menu, the USB signal switches to 
the currently active computer.
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Expanding switchable signals
Expanding the system through channel grouping
The web application lets you assign up to seven additional video channels, one 
USB 2.0 or RS 232 channel and four multi channels to the KVM channel of the 
console.

You can also assign up to seven additional video channels to the KVM channel of the 
computer. In addition, you can create pools of four devices for the USB 2.0/RS 232 
channel and for each of the four multi-channels.

By using pools, you can grant up to four users the right to access the
USB 2.0/RS 232 channel and the four multi-channels at the same time. For this, the 
matrix switch selects an available device from the pool after switching.

Assigning multiple channels to a console or computer creates a channel group.

NOTE: Within the channel groups of the console a USB 2.0/RS 232 channel or a 
multi-channel represents one single device. For computers such a channel repre-
sents a group of up to four devices.

NOTE: The OSD does not show any console or computer modules that you added 
as additional channels to the channel group.
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Expanding switchable signals
Creating a new channel group

How to create a new channel group:

1. In the menu, click on Matrix systems > [Name] > Console modules or Computer modules.

2. Click on a console or a computer module that is not assigned to a channel group.

3. Click on Channel grouping.

The selected module is assigned to the first KVM channel and is shown in the 
Device group column. The right column (Unassigned) lists the matrix switch 
modules you can add to the new channel group.

4. In the right column (Unassigned), click on the module you want to add. In the left 
column (Device group), click on the channel you want to add the module to.

5. Click on  (arrow left) to assign the module to the chosen channel.

6. Repeat steps 4 and 5 to add another module to the channel group.

7. Click on Save.

NOTE: You can assign up to seven additional video channels, one USB or 
RS232 channel and four multi channels to a console’s KVM channel.

You can assign up to seven additional video channels to the KVM channel of the 
computer, too. In addition, you can create pools of four devices for the 
USB 2.0/RS 232 channel and for each of the four multi-channels.

NOTE: All channels of a channel group are switched at the same time.

NOTE: To change the order of already added channels, mark a channel and 
click on  (arrow down) or  (arrow up). The chosen channel is moved up or 
down.
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Expanding switchable signals
Adding or deleting modules from a channel group

How to add modules to or delete them from a channel group:

1. In the menu, click on Matrix systems > [Name] > Console modules or Computer modules.

2. Click on a console module or a computer module that is already assigned to the 
channel group to which you want to add another module or from which you want 
to delete a module.

3. Click on Channel grouping.

Now you can see the current configuration. The right column (Not assigned) lists 
the matrix switch modules you can add to the channel group.

4. Add more modules to or delete them from the channel group:

5. Click on Save.

NOTE: You can assign up to seven additional video channels, one USB or 
RS232 channel and four multi channels to a console’s KVM channel.

You can assign up to seven additional video channels to the KVM channel of the 
computer, too. In addition, you can create pools of four devices for the 
USB 2.0/RS 232 channel and for each of the four multi-channels.

Adding modules:  In the right column (Unassigned), click on the 
module you want to add. In the left column  
(Device group), click on the channel to which you 
want to add the module.

 Click on  (arrow left) to assign the module to the 
selected channel.

Deleting modules:  In the right column (Assigned), click on the module 
you want to delete from the channel group.

 Click on  (arrow right) to delete the module’s 
assignment.
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Expanding switchable signals
Deleting a channel group

How to delete a multichannel configuration:

1. In the menu, click on Matrix systems > [Name] > Console modules  
or Computer modules.

2. Click on a console module or a computer module already assigned  
to the channel group you want to delete.

3. Click on Channel group to see the current configuration.

4. In the left column (Device group), click on a module that is assigned  
to one of the 2 to 8 channels or to the USB/RS232 channel.

Click on  (arrow right) to delete the module’s assignment.

5. Repeat step 4 to delete the assignment of other modules.

6. As soon as only one module is assigned to KVM channel 1, click on Save.

The channel group is deleted.

NOTE: The web application deletes a channel group if it does not contain any 
other channels than KVM channel 1.
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Powerswitches
By integrating a compatible IP powerswitch or an RS232 powerswitch 
G&D Hardboot CCX (no longer available) into the KVM matrix system, you can enable or 
disable the power supply of devices.

For this, one or several power outlets are assigned to a computer module. 
Afterwards, the outlets can be switched via the Operation menu of the console 
module OSD.

Basic configuration of IP power switches

Adding an IP power switch to a KVM system

How to add a KVM power switch to a KVM system:

1. In the menu, click on IP-Powerswitches.

2. Click on Add IP power switch.

3. In the Name field, enter the name of the IP powerswitch.

4. In the Comment field, enter any comment about the IP powerswitch.

5. Click on Save.

Changing name and comment of an IP powerswitch

How to change name and comment of an IP powerswitch:

1. In the menu, click on IP-Powerswitches.

2. Click on the IP powerswitch you want to configure and then click on Configuration.

3. In the Name field, you can change the name of the IP powerswitch.

4. In the Comment field, change or enter any comment about the IP powerswitch.

5. Click on Save.
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Configuring an IP powerswitch

Controlling an IP powerswitch via matrix switch requires you to enter the 
IP address and the access data of the hidden page account (see installation guide of the 
power switch) of the IP powerswitch.

How to configure an IP powerswitch:

1. In the menu, click on IP-Powerswitches.

2. Click on the IP powerswitch you want to configure and then click on Configuration.

3. Fill in all fields in the Configuration paragraph.

4. Click on Save.

Deleting an IP powerswitch

If a KVM system is not able to detect an IP powerswitch that has already been 
connected to the system, the system assumes that the device is switched off.

If you want to permanently delete an IP powerswitch from the system, delete the 
device manually from the list of IP power switches.

How to delete a switched off IP powerswitch:

1. In the menu, click on IP-Powerswitches.

2. Click on the IP powerswitch you want to delete and click on Delete.

3. Confirm the confirmation prompt by clicking on Yes or cancel the process by 
clicking on No.

NOTE: Only switched off IP powerswitches can be deleted.
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Viewing the status information of an IP powerswitch

The context menu of an IP powerswitch lets you open a window showing various 
status information.

How to view the status information of an IP powerswitch:

1. In the menu, click on IP-Powerswitches.

2. Click on the IP powerswitch you want to configure and then click on Configuration.

3. Click on the tab Information.

4. On the tab you will find the following information:

Name: Name of the IP powerswitch

Status: Current status (online or offline) of the IP powerswitch

NOTE: The paragraph Outlets shows a list of all channels of the IP powerswitch. 
Among other things, the table also shows which computer module is assigned 
to a channel.
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Basic configuration of RS232 powerswitches
After installing the RS232 powerswitch G&D Hardboot CCX (no longer available) as 
described in the separate manual, the KVM matrix system auto-detects the latest 
connected RS232 powerswitch.

Changing name and comment of an RS232 powerswitch

How to change name and comment of an RS232 powerswitch:

1. In the menu, click on Matrix systems > [Name] > RS232-Powerswitches.

2. Click on the RS232 powerswitch you want to configure and then  
click on Configuration.

3. Click on the tab General.

4. If desired, change the name of the RS232 powerswitch in the Name field.

5. Change or enter any comment about the powerswitch in the Comment field.

6. Click on Save.

Deleting an RS232 powerswitch from a KVM matrix system

If a KVM matrix system is not able to detect an RS232 powerswitch that has already 
been connected to the system, the system assumes that the device is switched off.

If you want to permanently delete an RS232 powerswitch from a system, delete the 
device manually from the list of RS232 powerswitches.

How to delete a switched off RS232 powerswitch:

1. In the menu, click on Matrix systems > [Name] > RS232-Powerswitches.

2. Click on the RS232 powerswitch you want to delete and then click on Delete.

3. Confirm the confirmation prompt by clicking on Yes or cancel the process by 
clicking on No.

NOTE: Only switched off RS232 powerswitches can be deleted.
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Viewing the status information of RS232 powerswitches

The context menu of an RS232 powerswitch lets you open a window showing 
various status information.

How to view the status information of RS232 powerswitches:

1. In the menu, click on Matrix systems > [Name] > RS232-Powerswitches.

2. Click on the desired RS232 powerswitch and then click on Information.

3. Now you can see the following information:

4. Click on Close.

Name: Name of the RS232 powerswitch

Status: Current status (online or offline) of the RS232 powerswitch

Comment: User comment about the RS232 powerswitch

Name: Name of the matrix switch to which the RS232 powerswitch 
is connected

Device ID: Device ID of the matrix switch to which the  
RS232 powerswitch is connected

Class: Device class of the matrix switch to which the  
RS232 powerswitch is connected

NOTE: The paragraph Outlets shows a list of all channels of the RS232 
powerswitch. The table also shows, among other things, which computer 
module is assigned to a channel.
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Assigning a powerswitch power outlet to a computer 
module
If the system is equipped with at least one powerswitch, you can assign one or several 
power outlets to a computer module.

The assigned power outlets can be switched via the Operation menu of the console 
module OSD.

How to change the assignment of powerswitch outlets of computer modules:

1. In the menu, click on Matrix systems > [Name] > RS232-Powerswitches or  
IP-Powerswitches.

2. Click on the powerswitch you want to configure and then click on Configuration.

3. Click on the tab Outlets.

On the tab, all available powerswitch outlets are displayed in the left table  
(Outlet index). The table on the right shows all computer modules.

4. In the left table, mark the outlet you want to assign to a computer module or 
whose assignment you want to delete.

5. (De)activate the assignment of a power outlet to a specific computer module in 
the right table by moving the Assigned slider of the computer module to the right 
(assigned) or to the left (not assigned).

6. Click on Save.

Rights administration

Rights to switch the power outlets of a computer module

How to change the rights to switch the power outlets assigned to a computer 
module:

1. In the menu, click on Users or User groups.

2. Click on the user account or the user group you want to configure and then click 
on Configuration.

3. Click on the tab KVM matrix systems and go to Individual device rights.

NOTE: The Assigned marker in the left table marks all powerswitch outlets to 
which a computer module is assigned.
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4. Select the desired computer module in the Individual computer module rights list field 
on the left-hand side.

5. In the Device power field, you can select between the following options:

6. Click on Save.

Rights to switch the power outlets of a computer module group

How to change the right to switch the power outlet(s) assigned to the computer 
modules of the group:

1. In the menu, click on Users or User groups.

2. Click on the user account or the user group you want to configure and then click 
on Configuration.

3. Click on the tab KVM matrix systems and go to Device group rights.

4. In the list field of the Device group rights paragraph, select the desired computer  
module group on the left-hand side.

5. In the Device power field, you can select between the following options:

6. Click on Save.

ADVICE: If necessary, use the Search field to limit the number of computer 
modules to be displayed in the selection window.

Yes: Allow switching of power outlets assigned to the selected computer 
module.

No: Deny switching of power outlets assigned to the selected computer 
module.

ADVICE: If necessary, use the Search field to limit the number of computer 
module groups to be displayed in the selection window.

Yes: Allow switching of power outlets assigned to the computer modules 
of the selected group.

No: Deny switching of power outlets assigned to the computer modules of 
the selected group.
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Advanced functions of the 
KVM matrix switch

Copying the config settings of a matrix switch
You can copy the General, Monitoring and/or Tradeswitch/CDS configuration settings of 
one matrix switch to the settings of one or more other matrix switches.

How to copy matrix switch config settings:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the matrix switch whose configuration you want to copy.

3. Open the menu Service tools and select the entry Copy configuration.

4. In the upper area, select which tabs (General, Monitoring and/or 
Tradeswitch/CDS) of the matrix switch should be copied.

5. In the lower area select the matrix switch(es) to which you want to copy the data.

6. Click on Copy configuration.

Setting up a shared database for all devices
All matrix switches are initially configured as database leader. This means that the 
devices store their configuration in their own database.

By changing the database setting of the matrix switch to Forwarder and entering the 
IP address of the matrix switch storing the shared database, this matrix switch no 
longer uses the local database but the shared one to store data.

When the Follower database setting is activated, the connected matrix switch uses the 
database of the database leader. In addition, this database is mirrored to the follower 
matrix switch.

NOTE: The name and the comment of a matrix switch are not copied.

NOTE: The database setting Follower can be activated only if the connected matrix 
switch is at least as powerful as the database leader.

If the connected matrix switch is less powerful than the database leader, the setting 
Follower is automatically changed to Forwarder.
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How to define the database settings of a device:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the matrix switch you want to configure and then click on Configuration.

3. Click on Database mode.

4. Enter the following data to the Edit database mode paragraph:

5. Click on Save.

IMPORTANT: Use the identical Certificate Authority to create certificates for the 
Forwarder, the Follower and the Leader devices.

IMPORTANT: Set the system time of the matrix switches correctly, or use an NTP 
server for automatic time adjustment.

Database 
mode:

Select in which device the database is to be administered:

 Leader: The database of the KVM system is administered in 
this device.

 Follower: The database of the KVM system is stored in a 
database leader and is replicated on this device.

 Forwarder: The database of the KVM system is administered 
in a database leader.

Database port 
(local):

Enter the port (usually 27996) of this device.

Database IP 
(remote):

If you selected the Follower or Forwarder type, enter the IP address 
of the device in which the database is administered.

Database port 
(remote):

If you selected the Follower or Forwarder type, enter the port 
(usually 27996) of the device in which the database is 
administered.
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GPIO function

The GPIO function (general-purpose input/output) provides programmable input and 
output interfaces for general purposes.

After the GPIO function has been activated in the configuration of a console or 
computer module, two lines of the PS/2 mouse and the PS/2 keyboard interface 
can either accept (input) or send out signals (output).

On console modules, the TS LED (if available) can be configured to visualise the 
status of one GPIO line.

Configuring the GPIO function for a console or a computer module

How to configure the GPIO function for a console or a computer module:

1. In the directory tree, click on Matrix systems > [Name] > Console modules  
or Computer modules.

2. Click the module you want to configure and then click on Configuration.

3. Click on the tab GPIO.

4. In the row Select contact, click on the contact you want to configure.

5. In the field Contact pair mode, select the option GPIO.

NOTE: The GPIO function can be used with compatible console modules from 
firmware version 1.6.002 or with compatible computer modules from firmware 
version 1.6.001.

NOTE: The PS/2 interfaces can be operated either in the default mode 
(keyboard/mouse) or in the GPIO mode.

IMPORTANT: Lines K1 and K2 are realised via the PS/2 keyboard connector.

Lines M3 and M4 are realised via the PS/2 mouse connector.

NOTE: By selecting the options Keyboard or Mouse you disable the GPIO function of 
the contact pair.
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6. Enter the following data for the selected contacts:

7. Click on Save.

Operating mode: By selecting the corresponding entry in the pull-down 
menu, you can determine whether the line receives 
signals from outside (Input) or passes signals to the 
outside (output).

Polarity inverted: Select the polarity of the line:

 Negative
 Positive

Display OSD info: Define whether texts (see below) about the status of the 
line should be displayed as information display (Enabled) 
or not (Disabled).

Display OSD info 
when active:

Define the text to be displayed as information display if 
the line is active.

Display OSD info 
when inactive:

Define the text to be displayed as information display if 
the line is inactive.

Display OSD info in 
colour

Define the text colour of the information display if the 
line is active/inactive.
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Configuring the Tradeswitch LED mode

How to configure the mode of a Tradeswitch LED:

1. In the menu, click on Matrix systems > [Name] > Console modules.

2. Click on the console module you want to configure and then click on Configuration.

3. Click on the tab General.

4. In the Tradeswitching LED Mode or Serial communication field, you can select between 
the following options:

5. Click on Save.

Tradeswitch: With the tradeswitch mode you can use optional LED 
sets. This facilitates locating the monitor (computer) to 
which the keyboard/mouse focus is switched to 
(see page 276).

GPIO K1: The LED is controlled via GPIO pin K1.

GPIO K2: The LED is controlled via GPIO pin K2.

GPIO M1: The LED is controlled via GPIO pin M1.

GPIO M2: The LED is controlled via GPIO pin M2.
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Viewing/exporting the port overview of the matrix 
switch
The port overview lists all matrix switch ports. It also lists the connected end devices 
and additional information (for example, device type and target port).

How to open the port overview of a matrix switch:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the desired matrix switch and then click on Service tools > Port overview.

3. Click on Save.

Restarting the matrix switch

This function enables you to restart the matrix switch. Before restarting the device 
you are requested to confirm your action to prevent accidental restarts.

How to restart the matrix switch via web application:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the matrix switch you want to restart.

3. Click on Service tools and select the entry Restart.

4. Confirm the confirmation prompt by clicking on Yes.

ADVICE: Click on Export to export the table contents to a csv file.
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Restoring the connection state after a restart
If you enable the function to Restore connection state, after every restart the matrix 
switch automatically logs in the last active users at the console modules. Then the 
connection to the last accessing computer modules are automatically restored.

How to enable or disable the restore of connection states:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the matrix switch you want to configure and then click on Configuration.

3. Select one of the options given under Restore connection state:

4. Click on Save.

NOTE: The original access order is not considered when restoring the connection 
state. This can result in restrictions when using the multi-user mode.

Off: After you restart the matrix switch, the login box is 
displayed at all console modules (default).

On: After you restart the matrix switch, the last 
connection states are restored.
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Copying config settings to a new matrix switch
If a matrix switch of the KVM matrix system is replaced by another device, the settings 
of the old device can be copied to the new one.

After the config settings have been copied, the new device is immediately ready for 
operation.

How to copy configuration settings of matrix switches:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the new device.

3. Click on Service tools and select the entry Replace device.

4. Select the device whose configuration settings you want to copy.

5. Click on Save.

IMPORTANT: The matrix switch whose settings are copied is afterwards deleted 
from the KVM matrix system.
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Freeze mode
When the cable connection between the computer module and the console module 
or the DWC is lost during operation, the console monitor or the corresponding 
windows of a DWC no longer show an image in the default settings of the 
KVM matrix system.

Enable the freeze mode if you want to display the last image received at the console 
module or in the corresponding windows of a DWC before the loss of connection. 
This image is displayed until the connection is re-established.

You can set the freeze mode for the entire system, too. The setting for the entire system 
applies to all console modules and DWC channels. In addition, you can set the freeze 
mode individually for each console module and each DWC channel.

ADVICE: To emphasize the lost connection, the image last received is either 
highlighted by a coloured frame at a console module or a coloured title bar in the 
corresponding windows at a DWC and/or the note Frozen at a console module or 
an Frozen icon in the title bar of the corresponding windows at a DWC and the 
time past since the loss of connection.
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How to configure the freeze mode for the entire system:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the matrix switch you want to configure and then click on Configuration.

3. Select one of the options given under Freeze mode:

4. Click on Save.

Off: Display no image on disconnection (default).

On | OSD timer + frame: Show a coloured frame at a console module or a 
coloured title bar in the corresponding windows at 
a DWC in case of a disconnection  and the 
message Frozen at a console module or an Frozen 
icon in the title bar of the corresponding windows 
at a DWC and the time past since the loss of 
connection.

On | OSD timer: Show the message Frozen at a console module or a 
Frozen icon in the title bar of the corresponding 
windows at a DWC and the time past since the loss 
of connection.

On | Frame: Show coloured frame at a console module or a 
coloured title bar in the corresponding windows at 
a DWC in case of a disconnection.
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How to configure the freeze mode individually for a console module:

1. In the directory tree, click on Matrix systems > [Name] > Console modules.

2. Select a console module and then click on Configuration.

3. Select one of the options given under Freeze mode:

4. Click on Save.

System: Apply setting (see above) to the entire system 
(default).

Off: Display no image on disconnection.

On | OSD timer + frame: Show a coloured frame in case of a disconnection
and the message Frozen and the time past since the 
loss of connection.

On | OSD timer: Show the message Frozen and the time past since 
the loss of connection.

On | Frame: Show coloured frame in case of a disconnection.
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How to configure the freeze mode individually for a DWC channel:

1. In the directory tree, click on Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the DWC you want to configure and then click on Configuration.

3. Click on the Transmission tab.

4. Select one of the options given under Freeze mode of the desired DWC channel:

5. Click on Save.

System: Apply setting (see above) to the entire system 
(default).

Off: Display no image on disconnection.

On | OSD timer + frame: Show a coloured title bar in the corresponding 
windows in case of a disconnection and an Frozen 
icon and the time past since the loss of connection 
in the title bar of the corresponding windows.

On | OSD timer: Show an Frozen icon and the time past since the 
loss of connection in the title bar of the 
corresponding windows.

On | Frame: Show coloured title bar in the corresponding 
windows in case of a disconnection.
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Changing push event key modifiers and valid 
keymodes

Push event keys let users at console modules and DWCs trigger push events via XML 
control.

The triggered push event contains the following information:

 String entered by a user,
 Console module or DWC name and device ID,
 Name and device ID of the computer module switched to the console module or 

DWC.

You can trigger a push event by pushing and holding the push event key modifier and 
entering a valid string (see entry Valid push event keys).

How to change push event key modifiers or the valid keymode:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Select the matrix switch and then click on Configuration.

3. Under Configuration, go to Push event key modifier and select at least one modifier key 
by ticking the control box:

NOTE: This function is available only after activating the additional IP-Control-API
function.

 Ctrl  Win

 Alt  Shift

 Alt Gr
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4. In the Valid push event keys field, select one of the following options:

5. Click on Save.

Rights administration

Right to change the personal profile

How to change the right to change the personal profile:

1. In the menu, click on User or User groups.

2. Click on the user account or the user group you want to configure and  
then click on Configuration.

3. Click on the tab KVM matrix systems and then go to Global device rights.

4. In the Edit personal profile field, you can select one of the following options:

5. Click on Save.

Only numbers: Only numerical keys are forwarded as part of a push event 
when pressing the push event key modifier

Only characters: Only alphabetic keys are forwarded as part of a push event 
when pressing the push event key modifier

Numbers and 
characters:

Numerical and alphabetical keys are forwarded as part of a 
push event when pressing the push event key modifier

IMPORTANT: The computer’s operating system and its application programs 
are not able to use the selected keymode as hotkey when it is combined with 
the selected push event key modifier(s),.

Yes: Allow users to view and edit own user profile

No: Deny users to view and edit own user profile
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Optional functions
The functional range of the KVM system can be expanded by purchasing additional 
functions. 

Name Function Description

Push-Get  
function

The Push-Get function allows the user to push 
the image on his monitor at a console module 
or the image of a DWC channel at a DWC to 
the display of another workplace or a large-
screen projection or to get it from there.

page 256

IP-Control-API The IP-Control-API enables text-based XML 
control of a KVM matrix system over the net-
work. It offers developers/administrators the 
ability to create custom applications for control, 
send switching commands and retrieve selective 
information on switching states and computer 
status. Thanks to easy integration into existing 
systems, including those from third-party 
manufacturers, the API offers a flexible and 
expandable solution that goes beyond the 
standard functions of the KVM matrix system 
and enables seamless integration into IT 
infrastructures from various providers.

page 260

Scripting  
function

With the scripting function, as part of the IP 
Control API, you can create, manage and 
execute scripts. A script is an XML document 
that contains one or more commands that are 
executed by the matrix switch. This allows you 
to automate scenarios such as changing the 
switching status of individual workplaces, 
several workplaces or the entire system. 

HTTP requests can also be used to control 
external devices.

page 263

EasyControl 
tool

You can use the EasyControl tool integrated in 
the web application to connect a console module 
to a specific computer module or to execute an 
existing script or script group.

Important: It is not possible to connect a DWC or 
DWC channel to a specific computer module with 
the EasyControl tool.

page 340
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Tradeswitch 
function

The TradeSwitch-Function (TS function) 
optimizes the operation of workplaces that, 
through multiple console modules and/or 
DWCs, are responsible for the simultaneous 
monitoring or control of multiple computers. 
Instead of assigning a separate keyboard and 
mouse to each console module and/or DWC, 
the TradeSwitch-Function provides a central 
keyboard and mouse for controlling the entire 
workplace. 

The user can switch these two input devices to 
any console module or display areas of the 
DWCs using a hotkey. 

page 276

CrossDisplay-
Switching 
function

With CrossDisplay-Switching (CDS) as part of 
the TradeSwitch function, user-friendly 
switching via mouse movement is enabled. The 
mouse behaves as if on a “virtual desktop” and 
can be seamlessly moved across the connected 
monitors. When the mouse pointer moves from 
one monitor to another, the keyboard-mouse 
focus is automatically redirected to another 
module, thus switching to a different computer.

page 284

FreeSeating 
function

With the FreeSeating function, as part of the 
TS-Function, the user’s personal work 
environment is automatically restored at any 
workplace within the group – including the last 
connected sources. The simplified login process 
optimizes workflows and increases 
productivity: The login credentials only need to 
be entered once to log into all console modules 
of the group and switch to the most recently 
used sources. Similarly, a single logout is 
sufficient to log out the entire group.

page 131

SyncSwitching Configure up to two matrix switches as Sync-
Follower following the switching states of the 
matrix switch configured as SyncLeader. 

Each switching operation of the SyncLeader 
matrix switch is performed simultaneously on 
the SyncFollower matrix switches.

page 335

Name Function Description
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Matrix-Grid 
function

The Matrix-Grid function allows for the flexible 
use of any matrix switch port within the Matrix-
Grid for console modules, DWCs, computer 
modules, or grid lines. While cascading 
expands only the number of connectable 
computers, the Matrix-Grid allows for the 
universal expansion of the existing KVM 
system.

Additionally, the function removes the 
limitations of the top-down structure within 
cascading and enables bidirectional 
communication between console modules, 
DWCs and computer modules connected to 
different matrix switches. This allows multiple 
digital matrix switches to be combined into a 
large matrix network. Console modules, DWCs 
and computer modules can be connected to any 
matrix switch within the Matrix-Grid.

The matrices grouped in a grid are virtually 
combined into one large matrix system for the 
user. As a result, all sources within the system 
can be accessed from any connected workplace. 
The matrix system automatically handles the 
routing of KVM signals by selecting the optimal 
path through the grid.

page 314

2-factor 
authentication

To provide a greater level of security, optional 
two-factor authentication (2FA) can be used to 
query a second factor based on a device in the 
user’s possession. 

2FA makes use of a time-based one-time 
password (TOTP). Authenticator apps or 
hardware tokens can be used.

page 53

ADVICE: You can display the activated functions in the respective overview table. 
For this, add the Active features column (see Configuring table columns on 
page 8 ff.).

Name Function Description
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Viewing the status information of matrix switches

The context menu of matrix switches enables you to call an interface, which 
provides various status information of the device. Besides technical data, the name, 
the status and the MAC address are displayed.

How to view the status information of matrix switches:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the matrix switch and then click on Configuration.

3. Click on the tab Information.

4. The following information are displayed. Depending on the configuration, you 
see further information here, e.g. the cascade mode.

5. Click on Close.

Name: Matrix switch name

Device ID: Physical ID of the matrix switch

Status: Current status (Online or Offline) of the matrix switch

Class: Device class

FIrmware name: Firmware name

Firmware rev: Firmware version

Hardware rev.: Hardware revision

IP Address A: IP addresses of network interface A

KVM ports: Number of console ports on the matrix switch

MAC A: MAC address of network interface A

Serial number: Serial number of the matrix switch

NOTE: In addition, Active features, the Link status, and the Monitoring information 
of the device are displayed.
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Push-get function (optional)

The optional Push-Get function allows the user to push the switch state of his console 
module or DWC channel to another console module or DWC channel or to get it 
from there.

Changing the right to execute the Push-get function

How to change the right for using the Push-get function:

1. In the menu, click on User or User groups.

2. Click on the user account or the user group you want to configure and then click on 
Configuration.

3. Click on the tab Matrix systems and go to Individual rights.

4. Select the desired console module or the desired DWC channel on the left side of 
the list field of the paragraph Individual console rights.

5. In the Push-Get field on the right side, you can select between the following 
options:

6. Click on Save.

IMPORTANT: Using the Push-get function requires the purchase and activation of 
the premium Push-get Function.

IMPORTANT: This setting is only available if the additional Push-get function has 
been activated.

ADVICE: If necessary, use the Search field to limit the number of console modules 
and DWC channels to be displayed in the selection window.

Yes: Allow use of Push-get function

No: Deny use of Push-get function
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Changing push-get key modifiers and valid keys
Push-get keys let you push orget the switch state from or to a console module or a 
DWC channel by using key combinations. For this, you can create Push-get key sets in 
the matrix system.

In combination with a defined push-get key modifier a push-get key set defines the key 
combination to be pressed for push or get switch states.

In addition to the push-get key modifier you can also define valid keys to be used as 
push-get keys.

How to change push-get key modifiers or valid keys:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the matrix switch and then click on Configuration.

3. Select at least one of the listed modifiers under Push get key modifier by marking the 
respective entry:

4. Under Valid push-get keys, you can select one of the following options:

5. Click on Save.

 Ctrl  Win

 Alt  Shift

 Alt Gr

Only numbers: Only numerical keys are interpreted as push-get keys when 
pressed in combination with the push get key modifier

Only characters: Only alphabetic keys are interpreted as push-get keys when 
pressed in combination with the push get key modifier

Numbers and 
characters:

Aphabetical and numerical keys are interpreted as push-get 
keys when pressed in combination with the push get 
key modifier

IMPORTANT: The selected valid keys and the push-get key modifier are no longer
provided as key combinations to the operating system and the applications on 
the computer.
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Administrating push-get key sets
The KVM matrix system allows you to create 20 global push-get key sets or ten 
individual push-get sets for each user.

Within push-get key sets you can define push-get keys for selected console modules 
and DWC channels to push/get the switch state of a console module or a DWC 
channel.

You can administrate push-get key sets comfortably with a wizard. Click on the 
menu Advanced features and select the entry Push-get keys. Click on Configuration to start 
the wizard.

The following paragraphs briefly summarise the wizard's configuration options.

Step 1: Select a matrix switch

 Select a matrix switch on which you want to store the configuration of the push-
get keys.

Step 2: Select a user

 Select a user account for which the configured push-get keys are available.
When selecting the entry Available for all (global), you create a global push-get key set 
that will be available for all users.

NOTE: Global push-get key sets are available for all users of the KVM matrix 
system.

NOTE: After you selected a matrix switch, you will see the current configuration of 
the Push-get key modifier and the valid push-get keys (see above). If required, you can 
change these settings directly in this menu.
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Step 3: Select push-get key set

 Select the push-get key set you want to configure.
Click on the buttons Add, Edit or Delete to add a new select key set or to edit or 
delete an existing set.

 Click on the slider Activate push-get key for current user if you want to activate the set 
for the user selected in step 2.

Step 4: Configure push-get key set

 Enter the desired key combinations for the console modules and DWC channels.

IMPORTANT: If you have selected the table entry Available for all (global) in step 2, 
click on the slider to activate the set for all users.

NOTE: Only when a push get-key set is assigned to a user account, the push get-
keys defined in the set are evaluated when entries are made at the workplace.
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IP-Control-API (optional)

After you activate the additional IP-Control-API function, you are able to access the 
KVM matrix system over a TCP/IP connection and you can use the network 
interfaces to send text-based commands in the form of XML files to the matrix switch.

Supported functions via text-based control
You can use the text-based control to perform the following functions:

 Logon User: user logon at a console module or a DWC
 Logout User: user logout at a console module or a DWC
 Connect CPU: Accesses computer module with a console module  

or a DWC channel

 Disconnect CPU: disconnects active access
 List Connections: queries connections between connected devices
 List MatrixSwitches: queries known matrix switches
 List CPUs: queries known computer modules
 List Consoles: queries known console modules
 List DWCs: queries known DWCs
 Redirection: redirects keyboard and mouse data

IMPORTANT: Using the IP-Control-API requires the purchase and activation of the 
premium function IP-Control-API.

NOTE: The structure of a valid XML document as well as possible commands and 
their syntax are desribed in the chapter XML control of a matrix switch in the separate 
Configuration and Operation Guide.

NOTE: This function can only be executed if an user with the computer module 
access rights ViewOnly or FullAccess is logged on to the console module or the 
DWC or if it is an OpenAccess console with these rights.

NOTE: Only after you have purchased the additional Tradeswitch function 
(see page 276 ff.), you are enabled to forward keyboard and mouse data to another 
console module, another DWC or another computer module.

ADVICE: On request, our support will provide you with examples for API 
encryption in the programming languages C# and C++.
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Configuring access for text-based control
Use the web application Config Panel to configure the service for text-based control. 
In the web application, you can define »remote control« accesses and their settings.

How to create a new access or edit existing accesses:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the device you want to configure and then click on Configuration.

3. Click on the tab Network and go to Remote Control.

4. To create a new access, click on Add remote control access.  
To adit an existing access, click on Edit.

IMPORTANT: Text-based control is only possible with these accesses.
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5. Enter or edit the following data:

6. Click on Save.

Port: Enter the port you want to use for text-based communication.

Ports 80, 443 and 27996 are not available for XML control.

Status: Select if the access is enabled (default) or disabled.

Encryption: The following types of encryption are supported:

 Unencrypted: Select None to transmit the data without 
encryption (default).

 Partly encrypted: Select Password: CBC-3DES, 
to transmit only login passwords with encryption. 

 Encrypted: Select CBC-3DES or TLS to transmit the data 
entirely encrypted.

Key: After enabling the encryption type CBC-3DES, enter the key 
(192 bit) in the form of 48 hex digits.

Initialization  
vector:

Enabling the encryption type CBC-3DES additionally requires 
an initialization vector. Enter the initialization vector (64 bit) 
in the form of 16 hex digits.

Certificate 
Authentication:

With TLS encryption enabled, you can additionally enable 
Certificate authentication after uploading a certificate (in the 
Remote Control section of the Network tab).
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Scripting function (optional)

The scripting function lets you create, manage and execute scripts.

A script is an XML document that contains one or more commands carried out by 
the matrix switch.

The structure of a valid XML document and any possible commands as well as their 
syntax are described in the chapter XML control of the matrix switch of the separate 
Configuration and Operation Guide.   

The scripts stored in the matrix system can be executed via the OSD of the 
KVM matrix system or the window menu of a DWC.

Configuring scripts
You can configure the »Scripting« function comfortably with a wizard. Click on the 
menu Advanced features and select the entry Scripts and script groups.

Step 1: Select the option »Scripts«

 Select the option Scripts to create, edit or merge individual scripts to control a 
device.

IMPORTANT: Using the scripting function requires the purchase and activation of 
the premium function IP-Control-API.

EXEMPLARY SCRIPT TO ESTABLISH A CONNECTION
<?xml version="1.0" encoding="utf-8"?>
<root>

<connect>
<DviConsole>0x22222222</DviConsole> <!-- ID of the console module -->
<DviCpu>0x33333333</DviCpu> <!-- ID of the computer module -->
<CloseDialogs/> <!-- Close OSD after connect

</connect>
</root>

ADVICE: Use the OSD of the matrix system to save the switching states of a 
console module/multiple console modules or of the entire system (switching 
states of a DWC are not taken into acount) in a script (see chapter Scripting function
of the separate Configuration and Operation Guidel).

ADVICE: You cannot save the switching condition in a script via the Window-
Manager on a DWC.
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Steps 2 and 3: Create, edit, merge or delete scripts

How to create a new script:

1. Click on Add script.

2. Enter the following data into the dialogue box:

3. Click on Save.

NOTE: Script commands are stored in an XML document. Each XML document 
can contain one or more commands.

The structure of a valid XML document as well as possible commands and their 
syntax are described in the chapter XML control of a matrix switch in the separate 
Configuration and Operation Guide.

NOTE: For controlling external devices HTTP requests can be used.

EXAMPLE: With the following GET request, you can switch off outlet 4 of a 
connected ePower-Switch. The two line breaks at the end are important here so 
that the target device interprets the request correctly.

GET /hidden.htm?MO:04=OFF HTTP/1.1

IMPORTANT: Only users with assigned Superuser rights are able to create, edit and 
delete scripts in the web application.

Name: Enter the desired script name.

Enabled: Enable or disable the execution and display of the script 
in the Script menu.

Execution delay: After calling the script, you can delay its execution by up 
to 999 seconds. Enter the desired delay time in seconds.

Comment: If desired, enter a comment about the script.

XML code: Enter the XML code or HTTP request using script 
commands.
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How to edit an existing script:

1. Select the script you want to edit and click on Edit.

2. Enter or update the following data into the dialogue box:

3. Click on Save.

How to delete an existing script:

1. Select the script you want to delete and click on Delete.

2. Confirm the security prompt by clicking on Yes.

Name: Enter the desired script name.

Enabled: Enable or disable the execution and display of the script 
in the Script menu.

Execution delay: After calling the script, you can delay its execution by up 
to 999 seconds. Enter the desired delay time in seconds.

Comment: If desired, enter a comment about the script.

XML code: Enter the XML code or HTTP request using script 
commands.
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How to merge existing scripts into a new script:

1. Select the existing scripts you want to merge.

2. Click on Merge.

3. Enter the following data:

4. If desired, you can change the order of the scripts you want to merge. Mark a 
script and click on  (arrow up) or  (arrow down). The selected script is moved 
either up or down.

5. Click on Save.

Step 4: Define owner

A script can be executed by users who are the owner of the script or are assigned with 
rights to execute the script.

 Activate the Owner slider in the line of the user to be entered as the owner of the 
script.

Step 5: Script availability

If a script is not assigned to a console module or a DWC, it is shown on all console 
modules and DWCs whose users are assigned with the right to execute the script.

If the script is assigned to one or several console modules or to one or several 
DWCs, it is shown only at the assigned console module(s) and DWC(s) if their users 
are assigned with the right to execute the script.

ADVICE: Press the Ctrl key to select several scripts from the list.

Name: Enter the desired script name.

Comment: If desired, enter a comment about the script.

NOTE: The XML documents of the selected scripts are copied to a new script in 
the selected order. In the new script, you can edit the XML document (created 
from the individual scripts) as required.

NOTE: Only scripts without owners can be added to script groups.
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 Activate the Available slider in the row of the console modules and DWCs on 
which to show the script.

Step 6: Target device

In the script configuration, you can specify whether the script is to be executed 
locally or on another matrix switch or device.

 Enable the Execute on this device slider or enter the IP address and port of the other 
matrix switch or device.

 Activate the Ignore device response slider if the device response should not be 
evaluated.

NOTE: Use the Available option in the column header to move the sliders of all console 
modules and DWCs.

NOTE: Use the slider in the EasyControl line to control the availability of the script in 
the EasyControl tool.

ADVICE: Do not activate any slider if you want the script to be available on all 
console modules and DWCs.

NOTE: Prerequisite for the execution on another matrix switch is that the additional 
IP-Control-API function is also activated on the target matrix switch.
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Configuring script groups
You can configure the »Scripting« function comfortably with a wizard. Click on the 
menu Advanced features and select the entry Scripts and script groups.

Step 1: Select the option »Scripts groups«

 Select the option Scripts groups to organise several existing scripts in a script group.

Steps 2 and 3: Create, edit or delete script groups

How to create a new script group:

1. Click on Add script group.

2. Enter the following data into the dialogue box:

3. Click on Save.

How to edit an existing script group:

1. Select the script group you want to edit and click on Edit.

2. Enter or update the following data into the dialogue box:

3. Click on Save.

Name: Enter the desired name of the script group.

Enabled: Enable or disable the execution and display of the script 
group in the script menu.

Execution delay: After calling the script group, you can delay its execution by 
up to 999 seconds. Enter the desired delay time in seconds.

Comment: If desired, enter a comment about the script group.

Name: Enter the desired name of the script group.

Enabled: Enable or disable the execution and display of the script 
group in the script menu.

Execution delay: After calling the script group, you can delay its execution by 
up to 999 seconds. Enter the desired delay time in seconds.

Comment: If desired, enter a comment about the script group.
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How to delete an existing script group:

1. Select the script group you want to delete and click on Delete.

2. Confirm the security prompt by clicking on Yes.

Step 4: Add scripts to group or delete them from group

The dialog lists all scripts of the matrix switch to which no owner has been assigned.

 Click on the Add slider on the row of the scripts you want to add to the group.
 Disable the Add slider on the row of the scripts you want to delete from the group.

Step 5: Define order of script execution

 If desired, you can change the order of the scripts within a group. Mark a script 
and click on  (arrow up) or  (arrow down). The selected script is moved either up 
or down.

Step 6: Script group availability

 Click on the Available slider in the row of the console modules and DWCs on 
which to show the script group.

NOTE: Use the Add option in the column header to move the sliders of all scripts.

NOTE: Use the Available option in the column header to move the sliders of all 
console modules and DWCs.

ADVICE: Do not activate any slider if you want the script to be available on all 
console modules and DWCs.
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Assigning rights to execute scripts and script 
groups

Executing a script that is not assigned to your own user account requires the right to 
execute this script. The same applies for script groups.

The right to execute scripts can be assigned in the settings of a user account. You can 
also manage this right via user groups (see Efficient rights administration on page 64).

Defining the right to execute a script

How to change the right to execute a particular script:

1. In the men, click on User or on User groups.

2. Click on the user account or the user group you want to configure and  
then click on Configuration.

3. Click on the tab KVM matrix systems and then go to Scripting rights.

4. In the list field of the Scripting rights paragraph, select the desired script from the list 
on the left-hand side.

5. In the Execution field on the right-hand side, select one of the following options:

6. Click on Save.

NOTE: Users always have the right to execute and delete their own scripts (Owner). 
This option does not require any additional rights.

ADVICE: If necessary, use the Search box to limit the scripts that appear in the 
selection window.

Activated: Allow the execution of the script.

Deactivated: Deny the execution of the script.
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Defining the right to execute a script group

How to change the right to execute a particular script group:

1. In the men, click on User or on User groups.

2. Click on the user account or the user group you want to configure and  
then click on Configuration.

3. Click on the tab KVM matrix systems and then go to Scripting group rights.

4. In the list field of the Scripting group rights paragraph, select the desired script group 
from the list on the left-hand side.

5. Select the desired script group from the list on the left-hand side.

6. Under Execution, select one of the following options:

7. Click on Save.

ADVICE: If necessary, use the Search box to limit the script groups that appear in 
the selection window.

Activated: Allows the execution of the script group.

Deactivated: Denies the execution of the script group.
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Assigning and configuring script keys
After the script key modifier(s) and a script key set have been adjusted and a script 
key set has been activated in the user account, a script can be executed by pressing 
key combinations on the console module or DWC keyboard.

Using script keys at a console module or a DWC

Opening the OSD or the window menu of a DWC is not necessary for using script 
keys to execute scripts. Hence, scripts can be executed much faster if you know the 
script keys required for the execution.

How to use script keys to execute a script:

1. Press the script key modifier key(s) defined in the matrix system and the script 
key assigned to the script.

Changing the script key modifier and the valid keys

Script keys let you execute scripts quickly with the help of hotkeys. For this, you can 
create script key sets in the matrix system.

Together with a defined script key modifier, a script key set defines the hotkey to be 
pressed to execute a script.

In addition to defining the script key modifier, you can also define keys to be used as 
script keys.

How to change the script key modifier or the valid keys:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the matrix switch and then click on Configuration.

3. Select at least one of the modifiers listed in the Script key modifier field by marking 
the respective entry:

EXAMPLE: 

 Script key modifier keys:Win+Shift
 Script key for script : 1

Press and hold the keys Win+Shift while pressing script key 1. The scrip is 
executed when releasing the keys.

 Ctrl  Win

 Alt  Shift

 Alt Gr
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4. In the Valid keys field, select one of the following options:

5. Click on OK to save your settings.

Administrating script key sets
The KVM matrix system lets you create 20 global script key sets or ten additional, 
individual script key sets for each user. 

Within script key sets you can define individual script keys to execute individual 
scrips.

You can administrate script key sets comfortably with a wizard. Click on the menu 
Advanced features and select the entry Script keys. Click on Configure to start the wizard.

The following paragraphs briefly summarise the wizard's configuration options.

Step 1: Select a device

 Select the matrix switch on which you want to store the configuration of the script 
key set.

Only numbers: only numerical keys are interpreted as script keys when 
pressed in combination with the script key modifier

Only characters: only alphabetic keys are interpreted as script keys when 
pressed in combination with the script key modifier

Numbers and 
characters:

alphabetical and numerical keys are interpreted as script keys 
when pressed in combination with the script key 
modifier

IMPORTANT: The selected valid keys and the script key modifier(s) are no longer
provided as key combinations to the operating system and the applications 
installed on the computer.

NOTE: Global script key sets are available to all users of the KVM matrix system.

NOTE: After you selected a matrix switch, you will see the current configuration of 
the script key modifier and the valid select keys (see above). If required, you can change 
these settings directly in this menu.
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Step 2: Select a user

 Select a user account for which the configured script  keys are available.
When selecting the entry Available for all (global), you create a global script key set 
that will be available to all users.

Step 3: Add or select script key sets

 Select the script key set you want to configure.
Click on the buttons Add, Edit or Delete to add a new script key set or to edit or 
delete an existing set.

 Click on the slider Activate script key set for current user if you want to activate the set 
for the user selected in step 2.

Step 4: Assign scripts and edit script key sets

 Enter the desired key combinations to execute scripts or script groups.

OSD settings fo the Scripting function

Editing the default menu mode

In the defaults, after accessing the OSD at a console module, you can select a 
computer via the Select menu. If desired, you can use your personal profile to define 
that the Script menu is shown directly after you open the OSD.

How to edit the default menu mode:

1. In the menu, click on Users.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the tabs KVM matrix systems and then go to Personal profile.

IMPORTANT: If you have selected the table entry Available for all (global) in step 2, 
clicking on the slider activates the set for all users.

NOTE: Only by assigning a script key set to a user account, the script keys defined 
in the set are accepted as inputs and execute the assigned script.

ADVICE: Independent of the default setting, you can always use the hotkey Ctrl+X
to switch between Select menu and Script menu.
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4. In the Default OSD menu field, select one of the following options:

5. Click on Save.

Switching threshold to switch the menu mode by mouse

In addition to switching the menu mode via the hotkey Ctrl+X you can also use the 
mouse to switch between menu modes.

How to activate/deactivate the switching threshold and/or adjust its sensitivity:

1. In the menu, click on Users.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the tabs KVM matrix systems and then go to Personal profile.

4. In the Select/script menu mouse switching field, select one of the following options:

5. Click on Save.

Select: The Select menu is shown after you open the OSD.

Script: The Script menu is shown after you open the OSD.

ADVICE: After the activation of the switching of the menu mode by mouse, you 
can move the mouse to the left or to the right to switch between the two modes in 
the Select menu and in the Script menu.

IMPORTANT: Switching the menu mode by mouse is not possible if the entry is not 
available in the Select menu or in the Script menu!

Off: Mouse switching of the OSD menu mode deactivated (default)

Sensitivity 1: lowest sensitivity level for mouse switching of the OSD menu 
mode

Sensitivity 10: maximum sensitivity level for mouse switching of the OSD 
menu mode

Sensitivity 2-8: further sensitivity levels for mouse switching of the OSD menu 
mode
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Tradeswitch function (optional)

The Tradeswitch function optimises the operation of workplaces monitoring 
multiple computers over multiple modules and/or DWCs.

Instead of connecting keyboard and mouse to each console module and/or each 
DWC, the Tradeswitch function provides a central keyboard/mouse for all operating 
tasks of the workplace.

In order to enable this, several console modules and/or DWCs of a KVM matrix system 
are arranged into a group. Only one of the group’s modules is provided with keyboard 
and mouse.

By using a hotkey, users are now able to switch the two input devices to the monitors of 
the other console modules and/or display areas of the DWCs. This makes it possible to 
operate the connected computer modules and computers.

Computer modules can also be integrated into the tradeswitch group and the keyboard 
and mouse signals can be switched directly to them. This makes it possible, for example, 
to operate a laptop that has its own monitor.

Changing tradeswitch key and valid key type
Tradeswitch keys allow you to switch the keyboard and mouse signals of a console 
module or a DWC to another console module, another DWC or computer module by 
entering a key combination.

You can group any console modules, DWCs and/or computer modules into a 
workplace and individually define the keys to be pressed to switch the keyboard and 
mouse signals to a specific console module, a specific DWC or computer module.

In addition to the tradeswitch key modifier, you can also define the valid key type 
for tradeswitch keys.

IMPORTANT: Using the Tradeswitch function requires the purchase and activation 
of the premium TS-Function.
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How to change tradeswitch key modifier or valid tradeswitch keys:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the matrix switch and then click on Configuration.

3. In the Tradeswitch key modifier field, select at least one of the listed key modifiers by 
checking the respective box.

4. In the Valid tradeswitch keys field, select one of the following options:

5. Click on Save.

 Ctrl

 Alt

 Alt Gr

 Win

 Shift

Only numbers: Only numerical keys are interpreted as tradeswitch keys when 
pressed in combination with the tradeswitch key modifier.

Only characters: Only alphabetic keys are interpreted as tradeswitch keys when 
pressed in combination with the tradeswitch key modifier.

Numbers and 
characters:

Alphabetical and numerical keys are interpreted as tradeswitch 
keys when pressed in combination with the tradeswitch key 
modifier

IMPORTANT: The selected keymode and tradeswitch key modifier(s) 
are no longer provided as key combinations to the operating system 
and the applications on the computer.
G&D ControlCenter-Compact · 277



Tradeswitch function (optional)
Administrating tradeswitch workplaces
You can comfortably manage the tradeswitch workplaces with a wizard. Click on 
the Advanced features menu and select Tradeswitch/FreeSeating/Cross-Display Switching. 

To start the wizard, click Configure.

The following sections briefly summarize the configuration options of the wizard.

Step 1: Select a matrix switch

 Select the matrix switch on which you want to store the configuration of the 
tradeswitch workplace.

Step 2: Tradeswitch workplace

 Select a tradeswitch workplace you want to configure.
Click on Add, Edit or Delete to create a new tradeswitch workplace or edit or delete 
existing ones.

 Click on the slider Synchronize trans. channels if all CON-2 and 2C/2F console modules 
of the tradeswitch workplace should switch when a member of the tradeswitch 
workplace switches to another transmission channel (see Channel auto-switching for 
CON-2/2C/2F console modules on page 134 ff.).

NOTE: After you selected a matrix switch, you will see the current configuration of 
the »Tradeswitch« function and »CrossDisplay-Switching« (see above). 
If required, you can change these settings directly in this menu.

NOTE: The Synchronize trans. channels slider is only relevant when using CON-2 or 
2C/2F console modules.
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Step 3: Configure tradeswitch workplace

 Entering a key combination to switch the monitor adds a module to the 
tradeswitch workplace.

 Delete an already entered key combination to delete a module from the 
tradeswitch workplace.

 Click on the slider Tradeswitch leader in the row of the module whose keyboard and 
mouse are used to operate the tradeswitch workplace.

 Click on the slider FreeSeating member in the rows of the modules to be included 
when restoring the last FreeSeating session (see Restore the last FreeSeating session on 
page 131).

Step 4: Tradeswitch configuration completed

You can now use the configured key combinations to switch between monitors 
and/or DWC display areas.

NOTE: Each console module and each DWC of a tradeswitch workplace can be 
FreeSeating member. Console modules and DWCs can be a FreeSeating member 
in several tradeswitch workplaces.

IMPORTANT: To use the FreeSeating function, at least the tradeswitch leader must 
be a FreeSeating member.
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Advanced functions

Configure Tradeswitch visualization for a console module

If you purchased the Tradeswitch function, the messages »Forwarding to...« (on the 
Tradeswitch leader) or »FORWARDED« (on the target workplace) can be displayed 
at the monitor at a console module.

Additionally (or alternatively) you can activate a frame that permanently or temporarily 
marks the monitor of the module connected via tradeswitch function.

How to configure the Tradeswitch visualization for a console module:

1. In the menu, click on KVM Matrix systems > [Name] > Console modules.

2. Click on the console module you want to configure and then click on Configuration.

3. Click on the General tab.

4. Under Tradeswitch visualization, you can select between the following options:

5. Click on Save.

No: Disable Tradeswitch visualization

Yes|OSD: The message »Forwarding to…« (at the 
Tradeswitch leader) or »FORWARDED« (at the 
target workplace) is displayed on the screen.

Yes|Frame temporary: A frame temporarily marks the monitor of the 
module connected via tradeswitch function.

Yes|Frame: A frame permanently marks the monitor of the 
module connected via tradeswitch function.

Yes|OSD+Frame temporary: The message »Forwarding to…« (at the 
Tradeswitch leader) or »FORWARDED« (at the 
target workplace) is temporarily displayed on the 
screen.

In addition, a frame temporarily marks the monitor 
of the module connected via tradeswitch function.

Yes|OSD+Frame: The message »Forwarding to…« (at the 
Tradeswitch leader) or »FORWARDED« (at the 
target workplace) is permanently displayed on the 
screen.

In addition, a frame permanently marks the monitor 
of the module connected via tradeswitch function.
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(De)activate Tradeswitch frame for a DWC

If you purchased the Tradeswitch function, you can activate a frame that permanently or 
temporarily marks the window of the module connected via tradeswitch function.

How to enable or disable the Tradeswitch frame for a DWC:

1. In the menu, click on KVM Matrix systems > [Name] > DynamicWorkplace-CONs.

2. Click on the DWC you want to configure and then click on Configuration.

3. Click on the General tab.

4. Under Tradeswitch visualization, you can select between the following options:

5. Click on Save.

IMPORTANT: This function only sets a window frame for active windows if 
keyboard/mouse operation can take place within a TradeSwitch workplace at the 
DWC.

No: Disable Tradeswitch visualization

Yes|Frame temporary: A frame temporarily marks the window of the 
module connected via tradeswitch function.

Yes|Frame: A frame permanently marks the window of the 
module connected via tradeswitch function.
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Customizing the appearance of the tradeswitch frame

You can set the display duration of the tradeswitch frame as well as its appearance 
(color settings, transparency effect and frame width) system-wide.

Each user of the matrix system can use their personal profile to change the system-
wide default by making an individual adjustment, provided they have the 
appropriate permission (see Right to change the personal profile on page 251 ff.).

How to change the system-wide appearance of the tradeswitch frame:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the matrix switch and then click on Configuration.

3. Customize the settings in the Tradeswitch frame configuration section to suit your 
needs:

4. Click on Save.

IMPORTANT: Settings of brightness, transparency effect and frame width have no 
effect at a DWC.

Temporary 
display time:

Set the temporary display duration of the tradeswitch 
frame between 0.0 (off) and 10.0 seconds.

Colour settings: Select the brightness and colour of the tradeswitch frame.

Transparency effect: Select the transparency effect (normal or high) of the 
Tradeswitch frame.

Frame width: Select the frame width (normal to quadruple) of the 
Tradeswitch frame.
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How to change the appearance of the tradeswitch frame for a specific user 

account:

1. In the menu, click on User.

2. Click on the user account you want to configure and then click on Configuration.

3. Click on the tabs KVM matrix systems and then go to Personal profile.

4. Enable the Personal tradeswitch frame display  option.

5. Customize the settings in the Tradeswitch frame configuration section  
to suit your needs:

6. Click on Save.

IMPORTANT: Settings of brightness, transparency effect and frame width have no 
effect at a DWC.

Temporary 
display time:

Set the temporary display duration of the tradeswitch 
frame between 0.0 (off) and 10.0 seconds.

Colour settings: Select the brightness and colour of the tradeswitch frame.

Transparency effect: Select the transparency effect (normal or high) of the 
Tradeswitch frame.

Frame width: Select the frame width (normal to quadruple) of the 
Tradeswitch frame.
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CrossDisplay-Switching (optional)

With CrossDisplay-Switching (CDS), you can use the mouse to switch between the 
modules of a Tradeswitch configuration (see page 276 ff.).    

IMPORTANT: Using the CrossDisplay-Switching function requires the purchase 
and activation of the premium TS-Function (see page 276 ff.).

IMPORTANT: Depending on operating system and mouse driver, there might be 
some restrictions:

 Under Mac OS, the mouse might jitter at the edge of the screen.
 Under Linux there might be some problems when placing and moving the 

mouse.

NOTE: It is possible that mouse gestures used by some programs (like Firefox) to 
run functions cannot be applied.

IMPORTANT: DWCs also support CrossDisplay-Switching. The display area of a 
DWC (see Arrange monitors/displays on page 151 ff.) is treated as one area within 
the CDS configuration, even if it extends across several monitors.
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Using »CrossDisplay-Switching«

How to use CrossDisplay-Switching to switch to another module:

Move the cursor to the edge of an active monitor placed next to another monitor.

The matrix switch switches to the module of the next monitor and positions the 
cursor. You will barely realize the switching between computers.

If you reach the outer edges (left edge of Monitor 1 or right edge of Monitor 3) 
CrossDisplay-Switching does not take place.

If you hold a mouse key while moving the mouse, switching cannot be carried out. 
However, you can still drag and drop objects.

Figure 1: Exemplary order of three monitors

EXAMPLE: If you move the cursor to the right edge of Monitor 2, the matrix switch 
switches to the module connected to Monitor 3.

If you move the cursor to the left edge of Monitor 2, the matrix switch switches to 
the module connected to Monitor 1.

ADVICE: When using multi head groups, you can enable specific mouse modes 
that allow drag and drop operations when working with Windows and Linux 
operating systems (see page 307).

NOTE: You can define the monitor order in the web application (see page 307).

� ��
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Requirements for »CrossDisplay-Switching«
Using CrossDisplay-Switching requires the following:

 Enabled premium Tradeswitch function (see page 276).
 Established and configured Tradeswitch configuration (see page 278).
 Enabled CrossDisplay-Switching (see page 291).
 Order of workplace monitors saved in the web application (see page 288).
 If a DWC is used, the order of the monitors on the DWC has been saved in the 

web application (see page 151).

IMPORTANT: Only USB computer modules connected to the computer by USB 
cables support CrossDisplay-Switching.
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Order and proportions of monitors
Figure 1 shows three monitors placed in a row.

In addition to monitors placed next to each other, any combinations are supported. 
Even the monitors’ proportions can vary. The following table shows some examples 
and describes special features.      

NOTE: In the web application you can save the order and proportions of your 
monitors according to how they are placed on the desk.

IMPORTANT: DWCs also support CrossDisplay-Switching. The display area of a 
DWC (see Arrange monitors/displays on page 151 ff.) is treated as one area within 
the CDS configuration, even if it extends across several monitors.

In addition to switching to a monitor 
placed on the left or the right side of 
the active monitor, you can also switch 
to monitors placed above or below the 
active monitor:

Move the cursor to one of the edges 
between monitors 1 and 3 or 2 and 4 to 
switch from an upper monitor to a 
lower monitor (or vice versa).

If the monitors are placed as shown on 
the left, it is important to mind the exact 
vertical cursor position when reaching 
the lower edge of Monitor 1:

 In the first third you can switch to 
monitor 2.

 In the second third you can switch to 
monitor 3.

 In the last third you can switch to 
monitor 4.

If the monitors are placed as shown on 
the left, it is important to mind the exact 
horizontal cursor position when reaching 
the left or right edge of Monitor 3:

 In the upper half you can switch to 
monitors 1 or 4.

 In the lower half you can switch to 
monitors 2 or 5.

� �
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Implementing multi-head monitors

Matrix systems support computers whose desktop is displayed on multiple monitors 
(see page 226 ff.). These computers are called multi-head computers.

By default, the monitor of a multi-head computer is displayed in the standard 
monitor size. However, you can change the size (monitor 2 in the example below) 
to the proportions of the other monitors:

NOTE: A description on how to create CDS multihead groups is given on 
page 301. For CDS with multihead groups, the individual channels are not managed, 
configured and switched as group, but individually in the KVM matrix system.

Figure 2: Two monitors of a multi-head computer between other monitors

NOTE: Install the driver CrossDisplay-Switching - Multi-Monitor Support if you cannot 
move the cursor across the two monitors of a multi-head computer.

You can download the driver from www.gdsys.com/en under Service, Downloads and 
Tools & Drivers.

� � �
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The »CrossDisplay-Switching« view
In the web application, you can save the order and proportions of console monitors. 
Based on these information, the matrix switch switches to the desired monitor if you 
move the cursor to the edge of a monitor. 

The tab is divided into four parts. The following paragraphs provide detailed 
information about each part.

List of modules

The left column lists all console modules, DWCs and computer modules that are 
assigned to the tradeswitch workplace and not yet placed in the workspace.

Click on Add to move the selected module to the display range.

Figure 3: The view »CrossDisplay-Switching«

IMPORTANT: DWCs also support CrossDisplay-Switching. The display area of a 
DWC (see Arrange monitors/displays on page 151 ff.) is treated as one area within 
the CDS configuration, even if it extends across several monitors.

ADVICE: You can also drag and drop the modules by mouse to move the module 
to the display range.
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Workspace

The right column (in the following called workspace) shows monitors of modules you 
can switch by using CrossDisplay-Switching.

Monitors are displayed as rectangles. Both the module name and the assigned 
tradeswitch key are displayed in the rectangle. You can use the handles and the Size
buttons underneath the grid to change the rectangles’ height and width.

Click on Remove to remove the selected rectangle from the workspace.

The workspace’s standard zoom level shows 20 × 15 units. However, you can adjust 
the size of the workspace:

 Press  (zoom in) to maximize the workspace. The maximum zoom level shows a 
workspace of 4 × 3 units.

 Press  (zoom out) to minimize the workspace. In the minimum zoom level, the 
workspace is displayed as 38 × 28 units (default setting).

ADVICE: You can also use »drag and drop« mouse operations to delete rectangles 
from the workspace.

NOTE: The maximum size of the workspace is adjusted dynamically if you drag an 
element beyond the available workspace.

You can increase the original size of 20 × 15 units as required.
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Basic configuration

Enabling CrossDisplay-Switching for the entire system

If you want to use the CrossDisplay-Switching function, we recommend that you activate 
the function for the entire system. This affects all computer modules that use the system-
wide setting (default).

You can override the system-wide settings for each computer module and enable or 
disable CrossDisplay-Switching for certain computer modules only.

How to change the CrossDisplay-Switching system settings:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the matrix switch and then click on Configuration.

3. Click on the General tab.

4. In the field Mouse mode | CrossDisplay-Switching, you can select between the  
following options:

5. Click on Save.

IMPORTANT: Before you can configure the CrossDisplay-Switching feature, you need 
to enable the premium Tradeswitch function (see page 276) and create a Tradeswitch 
configuration (see page 278).

ADVICE: You can also disable the system settings and enable CrossDisplay-Switching
only in the settings of computer modules on which you want to use the function.

Relative mouse  
coordingates |  
CDS disabled:

Disable CrossDisplay-Switching for the entire system.

Absolute mouse  
coordinates |  
CDS activated:

Enable CrossDisplay-Switching for the entire system.

ADVICE: You can enable or disable CrossDisplay-Switching for certain modules 
independently of the selected system settings (see below).
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Adjusting the general CDS mouse speed

If CrossDisplay-Switching is enabled, the mouse speed is not controlled by the 
operating system of the computer, but by the matrix switch.

If the cursor moves too fast or too slow, you can adjust the speed in the matrix 
switch.

You can adjust the mouse speed for the entire system or for one computer module 
only.

How to change the system settings of the mouse speed:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the matrix switch and then click on Configuration.

3. Click on the General tab.

4. Move the CDS mouse speed slider to the desired value.

5. Click on Save.

CDS mouse positioning

When moving the mouse cursor to an edge of the active monitor or the active DWC 
window with a second monitor or a second DWC window placed next to the active 
monitor or DWC window, the mouse cursor remains at the position at which the 
switching to the module of the second monitor or second DWC window takes 
place.

In addition, when leaving the monitor or DWC window, the matrix switch can 
position the mouse cursor so that it is barely visible. For this, you can use the 
settings Right and Bottom.

You can define this setting for the entire system. By default, all CDS modules use the 
system-wide setting. However, you can also individually define the mouse position for 
each CDS module.

How to change the system setting of the mouse position:

1. In the menu, click on Matrix systems > [Name] > Matrix.

2. Click on the matrix switch and then click on Configuration.

3. Click on the General tab.

NOTE: When using CDS for switching, a mouse cursor may be visible on several 
monitors or DWC windows.
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4. In the CDS mouse positioning field, you can select between the following options:

5. With activated CDS mouse positioning, you can select between the following 
options in the CDS mouse hideout field:

6. Click on Save.

Off: The mouse cursor remains at the position at which the switching 
to the module of the next monitor or next DWC window takes 
place (default).

On: According to the CDS mouse hideout setting the mouse cursor is 
positioned so that it is barely visible.

Only during multi-user access, the cursor remains at the position at 
which the switching to the next monitor or next DWC window
takes place.

On (multi 
access:

According to the CDS mouse hideout setting, even during multi-user 
access, the mouse cursor is positioned so that it is barely visible.

ADVICE: You can enable or disable this function for particular modules 
independently from the selected system setting.

Right: The mouse cursor is placed on the right edge of the monitor or 
DWC window so that it is barely visible.

Bottom: The mouse cursor is placed on the bottom edge of the monitor or 
DWC window so that it is barely visible.
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Enabling CrossDisplay-Switching for a specific computer module

How to change the CrossDisplay-Switching settings for a specific computer module:

1. In the menu, click on Matrix systems > [Name] > Computer modules.

2. Click on the computer module you want to configure and then  
click on Configuration.

3. Click on the General tab.

4. In the field Mouse mode | CrossDisplay-Switching, you can select between  
the following options:

5. If you select Absolute mouse coordinates|CDS activated for this specific  
computer module, then select the desired options in the fields CDS mouse speed,  
CDS mouse positioning and CDS mouse hideout as described in the system settings  
(see page 292 ff.).

6. Click on Save.

System: The system settings are adopted (default)

Relative mouse  
coordingates |  
CDS disabled:

Disable CrossDisplay-Switching for the specific computer 
module.

Absolute mouse  
coordinates |  
CDS activated:

Enable CrossDisplay-Switching for the specific computer
module.
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Configuring the CrossDisplay-Switching function
You can configure the CrossDisplay-Switching function comfortably with a wizard. 
Click on the menu Advanced features and select the entry Tradeswitch/FreeSeating/
CrossDisplay-Switching. Click on Configure to start the wizard.

Step 5: Position displays 

How to add monitors to the workspace:

1. In the left column, select a console module, a DWC or a computer module.

2. Click on the Add icon.

In the workspace, each added module is displayed as a grey rectangle (4 × 3 units) 
with a black frame and is placed on a free position.

The rectangle symbolises the monitor of the module placed on your desk. The 
name of the connected module and the assigned tradeswitch key are displayed in 
the rectangle.

How to remove monitors from the workspace:

1. In the right column, select the rectangle of the monitor you want to remove.

2. Click on the Remove icon.

Each removed module monitor is added to the list of modules in the left column.

NOTE: Steps 1 through 4 (see page 278 ff.) of the wizard show you how to create a 
tradeswitch workplace.

NOTE: A tradeswitch workplace is a basic requirement to set up the »CrossDisplay-
Switching« function.

IMPORTANT: DWCs also support CrossDisplay-Switching. The display area of a 
DWC (see Arrange monitors/displays on page 151 ff.) is treated as one area within 
the CDS configuration, even if it extends across several monitors.

ADVICE: You can also drag and drop monitors by mouse.

ADVICE: You can also drag and drop monitors by mouse.
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How to move monitors within the workspace:

1. Move the mouse over the rectangle of the monitor you want to move.

2. Press and hold the left mouse key while dragging the rectangle to the desired  
position.

If the frame of the rectangle turns red while dragging it, the current position is 
(partly) occupied and therefore the rectangle cannot be placed there.

Drag the handle beyond the right or left edge if the workspace is too small for the 
monitor size you want to adjust. The workspace maximizes automatically.

3. Release the left mouse key when a green frame is displayed.

How to adjust proportions among monitors:

1. Click on the rectangle of the monitor for which you want to change the size.

On each of the rectangle’s corners and in the middle between the two corners you 
can see adjustment handles (small black squares).

2. Click one of the handles and hold the left mouse key while dragging the handle to 
the desired position.

If the frame of the rectangle turns red while dragging it, the position is (partly) 
occupied and therefore the rectangle cannot be placed there.

Drag the handle beyond the right or left edge if the workspace is too small for the 
monitor size you want to adjust. The workspace maximizes automatically.

IMPORTANT: Exact switching is only possible if the monitors shown in the web 
application are placed in the same order as on your desk.

NOTE: Spaces between the monitors in the workspace are skipped during
CrossDisplay-Switching.

ADVICE: For finetuning and as an alternative to mouse operations, you can use 
the Position buttons below the grid after clicking a rectangle.

NOTE: Adjust the monitor proportions exactly to be able to position the mouse 
precisely and switch between monitors.

The monitor resolution is not important for this step.
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3. Release the left mouse key after a green frame is displayed.

4. If required, repeat steps 2 and 3 with the other handles of the rectangle.

Step 6: Configure CDS settings of computer modules

How the change »CrossDisplay Switching« settings of computer modules:

1. Click on the computer module you want to configure and then click on Edit.

2. In the CrossDisplay-Switching field, you can select between the following options:

3. Click on Save.

How to change the mouse speed of computer modules:

1. Click on the computer module you want to configure and then click on Edit.

2. In the CDS mouse speed field, you can select between the following options:

a. If you want to apply the system settings of the mouse speed to the  
computer module, enable the option System.

b. If you want to set an individual mouse speed, disable the System option  
and set the desired value.

3. Click on Save.

ADVICE: For finetuning and as an alternative using a mouse, you can use the 
Position buttons below the grid after clicking on a rectangle.

System: The matrix switch settings are applied to the entire system  
(see above).

Disabled: CrossDisplay-Switching is disabled for this computer module.  
The system settings are ignored.

Enabled: CrossDisplay-Switching is enabled for this computer module.  
The system settings are ignored.
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How to adjust the CrossDisplay resolution of a computer module:

1. Click on the computer module you want to configure and then click on Edit.

2. Disable the Auto option in the CDS resolution field.

3. Enter the vertical and horizontal resolution in the input boxes.

4. Click on Save.

NOTE: With active CrossDisplay-Switching, the mouse speed is not controlled by the 
operating system of the computer but by the matrix switch.

If the cursor speed changes between horizontal and vertical mouse movements, 
the monitor resolution could not be auto detected.

In such cases, a resolution of 1680 × 1050 pixels applies. If the monitor’s 
resolution differs from this resolution, the mouse moves as described above.

In this case, you can adjust the monitor resolution manually.
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How to change the mouse position of a particular computer module:

1. Click on the computer module you want to configure and then click on Edit.

2. In the CDS mouse positioning field, you can select between the following options:

3. With activated CDS mouse positioning, you can select between the following 
options in the CDS mouse hideout field:

4. Click on Save.

System: Use systemwide (see above) setting (default).

Off: The mouse cursor remains at the position at which the switching 
to the module of the next monitor takes place.

On: According to the CDS mouse hideout setting the mouse cursor is 
positioned so that it is barely visible.

Only during multi-user access, the cursor remains at the position at 
which the switching to the next monitor takes place.

On+Multi: According to the CDS mouse hideout setting, even during multi-user 
access, the mouse cursor is positioned so that it is barely visible.

Right: The mouse cursor is placed at the right edge of the monitor so that 
it is barely visible.

Bottom: The mouse cursor is placed at the bottom edge of the monitor so 
that it is barely visible.
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Messages
In some cases CrossDisplay-Switching cannot be used.

In such cases, a message is displayed on the monitor of the console module. The 
messages have the following meaning:

Message Meaning

No CDS: Globally disabled No CDS possible as the function is deactivated for the 
entire system (see Enabling CrossDisplay-Switching for the 
entire system on page 291)

No CDS: Disabled No CDS possible as the computer module uses relative 
mouse coordinates (see Enabling CrossDisplay-Switching 
for a specific computer module on page 294).

No CDS: No Tradeswitch modifier No CDS possible because no tradeswitch key modifier (see 
How to change tradeswitch key modifier or valid trade-
switch keys: on page 277) has been configured.

No CDS: Computer module not found No CDS possible because the computer module was not 
found.

No CDS: Computer module multiuser 
mode

No CDS possible as a user is already connected to the 
computer module and this does not support MultiAccess 
(see Access mode for simultaneous access to computer 
modules on page 94).

No CDS: Computer module not  
supported

No CDS possible as the computer module does not support 
switching via CDS.

Contact our support team for more information.

No CDS: Console not found No CDS possible because the console module does not 
exist in the matrix switch database (anymore).

No CDS: Console MultiAccess mode No CDS possible because the console module is included 
in several Workplaces (Tradeswitch configurations) and 
does not support multiuser CDS.

No CDS: Unknown error No CDS possible.

Contact our support team for more information.
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CDS multihead groups
CDS multihead groups let you create a CDS workplace. You can switch any video channel 
to the monitors of this workplace.

The video channel can be either the (only) video channel of a computer with one 
graphics output only or a given video channel of a computer with multiple graphics 
outputs.

The configuration settings of a CDS multihead group provide the matrix switch with 
the resolutions and order of connected video channels belonging to one display range 
of a computer. These information allow flexible switching via CDS.

Differences between CDS modes
CDS multihead groups expand the functional range of CrossDisplay-Switching (CDS):

 In CDS with channel grouping mode, the matrix switch can display an additional 
video channel (added via channel group) of a computer with multiple graphics 
outputs only on monitors of console modules that also have a compatible channel 
group 
Showing the first video channel of another computer module on an additional monitor 
of a channel group is not possible.

 CDS with multihead groups lets you display on every monitor either the (only) video 
channel of a computer with one graphics output or a given video channel of a 
computer with multiple graphics outputs.

Example of use
The following example shows the difference between the two CDS modes:

IMPORTANT: If two different users operate two different computer modules of a CDS 
multihead group at the same time, the mouse jumps between the affected video 
channels of both users.

IMPORTANT: In CDS with channel grouping mode, connect each computer module 
within the group to the computer using a USB cable.

EXAMPLE: A display range of 
3840×1200 pixels is defined in the 
graphics settings of a computer. The 
computer uses two video channels 
with 1920×1200 pixels each to 
transmit the display range to two 
monitors.

Monitor  1
1920×1200

Monitor 2
1920×1200
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CDS with channel groups

The chapter Implementation of multihead monitors (see page 288) describes how to 
implement multihead computers with channel groups into the CDS configuration.

In the CDS configuration, the combined size of the monitors belonging to a channel 
group (monitors 2a and 2b in the example below) is adjusted so that their size ratio 
fits the other monitors:

At the CDS workplace, when moving the mouse cursor to the right-hand margin of 
monitor 1, the matrix switch switches to monitor 2a and places the cursor in a way 
that you barely realise the changing between the cursors of both computers.

When moving the mouse cursor to the right-hand margin of monitor 2a, the matrix 
switch detects with the help of the CDS configuration that the next monitor 2b is 
connected to another graphics output of the already accessed computer. Therefore, 
a switching does not take place and the mouse cursor is not positioned.

When switching a computer with only one video channel to monitor 2a, you need to 
drag the mouse through the unused display range of monitor 2b before using CDS 
switching to switch to monitor 3.

IMPORTANT: Only monitor 2b of the CDS workplace can display the second video 
channel of a multihead computer!

It is not possible to display the first video channel of a computer module on this 
monitor.

NOTE: This type of CDS configuration is recommended when you always switch 
multihead computers to particular monitors of the CDS workplace (2a and 2b in 
the example).

1 2a 32b
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CDS with mulithead groups

CDS with multihead groups allows you to display the individual video channels of 
multihead computers on any monitor of the CDS workplace.

You can switch the two display ranges of the multihead computer mentioned in the 
example above to monitors 1 and 2, monitors 2 and 3 or monitors 3 and 4.

You can switch any video channel to each monitor of the CDS workplace.The channel 
can be either the (only) video channel of a computer with one graphics output or a given
video channel of a computer with multiple graphics outputs..

According to the configuration of the CDS multi head group, the matrix switch 
detects the order of the devices and the resolution of each channel. This way, 
switching via CDS takes place reliably at the margins of the display range.

NOTE: For CDS with multihead groups, instead of being grouped, individual channels 
are managed, configured and switched within the KVM matrix system.

NOTE: CDS with multihead groups requires additional configuration settings.

1 2 43
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Requirements
 Enabled premium Tradeswitch function (see page 276).
 Established and configured Tradeswitch configuration (see page 278 ff.).
 Enabled CrossDisplay-Switching (see page 291).
 The channels of multihead computers must not be part of channel groups  

(see page 227). If necessary, delete the channel groups of the computer modules 
you want to configure.

 Order and size ratio of the monitors at the CDS workplace are saved in the web 
application (see page 289).

 The computer modules used at the individual video channels of a computer are all 
individually connected to the computer via USB.

IMPORTANT: Channel groups are required to implement multihead computers 
as described in the chapter Implementation of multihead monitors (see page 288).

Both CDS operating modes can be used at the same time in a KVM matrix system. 
However, you can use only one operating mode per computer and per CDS 
workplace.

ADVICE: When using MC console modules, you can use the temporary logon 
(see OSD Operation Menu) and the rights given to your user account to log on to 
each additional channel of the console module.

Afterwards, you can operate the additional video channels like an independent 
channel.
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The Member configuration view 
During basic CDS configuration you already defined order and size ratio of the 
monitors belonging to the CDS workplace (see page 289).

When configuring CDS multihead groups, you first reproduce the computer’s display 
ranges and then enter their resolutions.

The following screenshot shows two adjoining video channels (1920×1200 each) of 
a multihead computer (see example on page 301). The combined display range of 
the CDS multihead group has a resolution of 3840×1200 pixels.

The tab is divided into two parts The following paragraphs provide a detailed 
description of these parts.

List of computer modules

The table on the left-hand side lists all computer modules that are not part of a CDS 
multihead group.

By clicking on Add you can move the highlighted module into the display range.

IMPORTANT: The configuration of CDS multihead groups must comply with the 
configuration of the computer’s graphics settings!

ADVICE: You can also use »drag and drop« mouse operations to move modules to 
the display range.
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Workspace

The workspace on the right-hand side shows the display ranges of video channels of 
multihead computers. Each display range is transmitted by a separate computer 
module.

The display ranges are displayed as rectangles. The name of the computer module 
and the resolution of its display range is displayed inside of the rectangle.

You can arrange the individual display ranges in horizontal or vertical order or in 
blocks. Blocks must be put together to form complete quadrangles. L-shaped 
arrangements are not supported.

Click on Remove to delete the selected rectangle from the workspace.

At default zoom level, the workplace is displayed in units of 4 × 4. You can adjust 
the size of the display range:

 Click on  (zoom in) to maximize the workspace. At maximum zoom level,  
the workspace is displayed in units of 2 × 2.

 Click on  (zoom out) to minimize the workspacer. At minimum zoom level,  
the workspace is displayed in units of 20 × 20 (default).

IMPORTANT: The display range entered in the workspace must reflect the computer’s 
entire display range.

ADVICE: You can also use »drag and drop« mouse operations to delete rectangles 
from the workspace.

NOTE: The maximum size of the workspace adjusts dynamically when you move 
an element over the available workspace.

You can expand the default size of 16 ×16 units as far as you wish.
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Configuring CDS multihead groups
You can configure the CDS multihead groups comfortably with a wizard. Click on the 
menu Advanced features and select the entry CDS multihead groups. Click on Configure to 
start the wizard.

Step 1: Administrate CDS multihead groups

How to create a new CDS multihead group:

1. Click on Add.

2. In the Name field, you can enter the name of the group.

3. Optional: In the Comment field, you can enter a comment about the group.

4. Select one of the options listed in the CDS mouse mode field:

5. Click on Save.

How to change the settings of a CDS multihead group:

1. Click on the group you want to configure and then click on Edit.

2. In the Name field, you can change the name of the group.

NOTE: Steps 1 through 4 (see page 278 ff.) of the Tradeswitch function/CrossDisplay-
Switching wizard show you how to create a tradeswitch workplace.

NOTE: Steps 5 and 6 (see page 295 ff.) of the Tradeswitch function/CrossDisplay-Switching 
wizard show you how to set up the CrossDisplay-Switching function.

NOTE: By default, when reaching one of the edges of the active monitor, 
switching does not take place if a mouse button is pressed while moving the 
mouse.

When working with Windows and Linux operating systems, you can enable 
specific mouse modes that allow drag and drop operations.

Standard: When reaching one of the edges of the active monitor, switching 
does not take place if a mouse button is pressed while moving the 
mouse.

Windows: Under Windows operating systems switching takes place even 
when pressing a mouse key while moving the mouse to the edge 
of the active monitor.

Linux: Under Linux operating systems switching takes place even when 
pressing a mouse key while moving the mouse to the edge of the 
active monitor.
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3. Optional: In the Comment field, you can change or enter a comment about the group.

4. Select one of the options listed in the CDS mouse mode field:

5. Click on Save.

How to delete a CDS multihead group:

1. Click on the group you want to delete and then click on Delete.

2. Confirm the security prompt by clicking on Yes or cancel the process  
by clicking on No.

Step 2: Configure CDS multihead groups

Saving order and resolutions of workspaces

Arrange the display ranges of the graphics cards installed in the multihead computer as 
they are displayed in the computer’s graphics configuration.

NOTE: By default, when reaching one of the edges of the active monitor, 
switching does not take place if a mouse button is pressed while moving the 
mouse.

When working with Windows and Linux operating systems, you can enable 
specific mouse modes that allow drag and drop operations.

Standard: When reaching one of the edges of the active monitor, switching 
does not take place if a mouse button is pressed while moving the 
mouse.

Windows: Under Windows operating systems switching takes place even 
when pressing a mouse key while moving the mouse to the edge 
of the active monitor.

Linux: Under Linux operating systems switching takes place even when 
pressing a mouse key while moving the mouse to the edge of the 
active monitor.

IMPORTANT: You can arrange the individual display ranges into horizontal or 
vertical order or in blocks. Blocks must be put together to form complete 
quadrangles. L-shaped arrangements are not supported.
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How to add a workspace to the display range:

1. Select a computer module from the left column.

2. Click on Add.

In the workspace, each added computer module is displayed as a grey rectangle 
(1 × 1 units) with a black frame and is placed on a free position.

The name of the computer module and the resolution of its display range are dis-
played inside the rectangle.

How to remove a display range from the workspace:

1. On the right-hand side of the workspace, select the rectangle symbolizing the 
display range you want to delete.

2. Click on Remove.

How to move a display range within the workspace:

1. Move the mouse over the rectangle symbolizing the display range you want to 
move.

2. Press and hold the left mouse key while dragging the rectangle to the desired 
position within the workspace.

If the frame of the rectangular turns red while dragging it, the position is already 
occupied and therefore not valid.

Drag the over the right or the bottom frame if the workspace is too small for the 
desired position. This way, the workspace becomes automatically larger.

3. Release the left mouse key when a green frame is displayed.

ADVICE: You can also drag and drop computer modules by mouse.

ADVICE: You can also drag and drop display ranges by mouse.

IMPORTANT: Exact switching is possible only if the monitor arrangement stored in 
the web application complies with the arrangement at the workstation.

NOTE: Empty spaces between display ranges are not valid.

ADVICE: as an alternative to using a mouse, you can use the Position buttons below 
the grid after clicking on a rectangle.
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How to adjust the resolution of a display range:

1. In the table on the left, enter the resolutions of the computer modules of the CDS 
multihead group.

2. Click on Save and continue.
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Connecting analogue matrix switches 
(Bridging)

With the bridging function, you can integrate analog matrix switches of the 
CATCenter NEO series into the digital KVM matrix system.

Operation
Using a DVI-I-CPU or VGA-CPU computer module, the digital matrix switch 
ControlCenter-Digital or ControlCenter-Compact establishes a connection to one of the 
UCON console modules connected to the analog matrix switch CATCenter NEO.

The computer module DVI-I-CPU or VGA-CPU is directly connected to the signal line of the 
console module UCON. The matrix switches communicate over a TCP/IP connection.

The digital matrix switch can use every established Bridge line to switch to any computer 
module of the analog matrix switch.

The computer modules of the analog matrix switch are listed in the OSD and in the 
web application of the digital matrix switch. Here, they can be configured 
(see page 59 ff.) and grouped (see page 227 ff.).

IMPORTANT: Bridge mode cannot be used within a KVM Matrix-Grid™ 
(see page 314 ff.)!

Figure 1: Connection of a digital and an analog matrix switch

EXAMPLE: A user uses the OSD of the digital matrix switch ControlCenter-Digital 
(CCD) or ControlCenter-Compact (CCC) to access a computer module of the anaolog 
matrix switch CATCenter NEO.

 Over the TCP/IP connection, the digital matrix switch CCD/CCC transmits the 
switching command to the analog matrix switch CATCenter NEO.

 The digital matrix switch CCD/CCC switches the user to the computer module  
DVI-I-CPU/VGA-CPU of the Bridge line.

 The analog matrix switch CATCenter NEO switches the computer to the console 
module UCON of the Bridge line.

ControlCenter-Digital
or

ControlCenter-Compact
CATCenter NEO

DVI-I-CPU
or

VGA-CPU
UCON
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Requirements
You can use a console connected to the digital matrix switch to access a computer 
module connected to the analogue matrix switch if the following requirements are met:

1. The matrix switches and the modules of the Bridge line are placed in the correct 
order (see figure) and are properly connected.

2. The DVI-I-CPU or VGA-CPU computer module is connected to a port operated in 
Down mode (see Configuring ports on page 17).

3. Both matrix switches are connected to the same TCP/IP network.

4. Set the system time of both matrix switches correctly, or use an NTP server for 
automatic time adjustment.

5. The premium function IP-Control-API is enabled for the analog matrix switch 
CATCenter NEO.

6. The Bridge mode of the computer module DVI-I-CPU or VGA-CPU is configured.

Particularities
 Bridge lines can be connected only to the digital Leader matrix switch of the  

KVM system.
 Computer modules (CATpro2) of an analog matrix switch cannot be used for the 

Tradeswitch function (see page 276 ff.).

Configuration

You can configure the Bridge mode conveniently with a wizard. Click on the menu 
Advanced features and select Bridge. 

To start the wizard, click on Configuration.

Step 1: Check matrix switch settings

 Make sure that each of the prerequisites listed is fulfilled, and click OK each time.
 When all checks are complete, click Continue.

IMPORTANT: When used in Bridge mode, the console module UCON automatically 
switches to Open Access mode (see OpenAccess operating mode on page 118).

At this console module, access is not protected through authentication!
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Step 2: Configure bridge connections

 The table lists all known modules of the DVI-I-CPU and VGA-CPU variants that are 
compatible for establishing a bridge connection.

 To activate the bridge mode of one of these modules, select the desired module and 
click Edit.
Then enter the Device ID of the UCON device and the IP address of the CATCenter-NEO 
device.
Finish your entry by pressing the green button.

 To deactivate the bridge mode of one of these modules, select the desired module 
and click Edit.
Then delete the Device ID of the UCON device and the IP address of the CATCenter-NEO 
device.
Finish your entry by pressing the green button.

 Click Save and continue.
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KVM Matrix-Grid™ (optional)

Purpose

After purchasing and activating the function (for every matrix switch), you can 
combine up to 24 digital matrix switches to a complex network called matrix grid.

By combining matrix switches, you can increase the number of connectable console 
modules, DWCs and computer modules. Due to the bidirectional communication 
between devices included in the matrix grid, console modules, DWCs and computer 
modules can be connected to any port available within the matrix grid.

Due to the high transmission ranges of the fibre components used for the matrix 
switches of the ControlCenter-Compact series, the matrix grid can bridge distances up 
to 10 kilometres between two matrix switches.

Difference between cascade and Matrix-Grid
The default settings of the matrix switches lets you increase the number of connectable 
computers through cascading (see Special functions for cascaded KVM matrix systems on 
page 223 ff.).

Cascade

To establish a cascade connect a follower matrix switch to the leader matrix switch. 
Connect either several computer modules or further follower matrix switches (max. 
two cascade levels) to the follower matrix switch.

IMPORTANT: Using the Matrix-Grid function requires the purchase and activation 
of the premium Matrix-Grid Function.

ADVICE: You can use the MatrixGuard function (see page 327) to protect a 
configured KVM Matrix-Grid™ against failure of the database leader.
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Due to the top-down structure of the cascade, console modules and DWCs can access 
only computer modules connected to the same matrix switch as the console module or 
DWC or to a matrix switch that is subordinate in the tree structure (cascaded).

Matrix-Grid

The premium function KVM Matrix-Grid™ allows you to use each matrix port within 
the Matrix-Grid to connect either console modules, DWCs, computer modules or 
grid lines (see below). While a cascade increases only the number of connectable 
computers, the matrix grid allows the universal expansion of existing KVM installa-
tions.

Additionally, the function removes the limitations of the top-down structure within 
cascades and enables bidirectional communication between console modules, 
DWCs and computer modules connected to different matrix switches. This allows you 
to combine several digital matrix switches to one large network of matrix switches. 
Console modules, DWCs and computer modules can be connected to any matrix 
switch included in the Matrix-Grid.

All console modules and DWCs can access any computer module (independently of 
the matrix switch to which they are connected).

The system takes over the (bidirectional) routing of KVM signals and chooses the 
ideal signal path between modules.
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Technical implementation
You can flexibly arrange up to 24 digital matrix switches into different topologies 
and connect them by using grid lines (see below):

All matrix switches included in a Matrix-Grid store their data in one shared data-
base, which all matrix switches can access via the grid network.

Direct connections between individual matrix switches (called grid lines) are used 
dynamically to establish KVM connections across matrix switches as well as for 
communication.

Figure 2: Example “Simple line”

Figure 3: Example “Ring”
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If the console module or DWC to be connected and the computer module are 
connected to different matrix switches within a Matrix-Grid, each simultaneous, 
KVM connection across matrices requires a free grid line between all matrix 
switches involved.

Multi user accesses to a computer module are transmitted via the same grid line(s) if 
the console modules or DWCs are connected to the same matrix switch or to 
another matrix switch included in an already established signal path.

The USB signal between console modules or DWCs and computer modules including 
integrated USB can be transmitted over up to four matrix switches (three grid lines).

Shared database for all matrix switches
The heart of the KVM Matrix-Grid is the database all matrix switches share within 
the Matrix-Grid.

The most powerful matrix switch (the matrix switch with the most ports) is the 
database leader of the network and administrates the shared database. All matrix 
switches included in the Matrix-Grid must be connected to the database leader via 
network.

IMPORTANT: Make sure to carefully plan the number of grid lines required 
between the individual matrix switches to avoid blocked signal paths.

ADVICE: Make regular backups (see page 85) of the shared database. If required, 
you can restore the backup on the same or a new device.
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Database settings within the Matrix-Grid
The matrix switches connected to the database leader via network are configured to 
use the database of the database leader. For this, two database settings are provided:

Follower (recommended): When activating this database setting, the connected matrix 
switch uses the database of the database leader. Additionally, this database is 
replicated on the follower matrix switch.

If the database leader fails, any components and connections not affected by the 
failure of the leader still work thanks to the replication of the database. Ideally, all 
matrix switches (that are set to Follower) included in the Matrix-Grid as well as the 
console modules, DWCs and computer modules connected to them are still ready 
for operation if the database leader fails. Whenever the grid lines of the database 
leader fail, it might be possible that its computer modules can no longer be accessed 
from all matrix switches!

Forwarder: When activating this database setting, the connected matrix switch also uses 
the database of the database leader. However, the database of the leader is not 
replicated. Instead, the local database is maintained.

IMPORTANT: The database setting Follower can be activated only if the connected 
matrix switch is at least as powerful as the database leader. 

If the connected matrix switch is less powerful than the database leader, the setting 
Follower is automatically changed to Forwarder (see below).

After changing the database settings and expanding the Matrix-Grid with a more 
powerful database leader make sure that the selected database setting is applied as 
desired.

IMPORTANT: The local database of the matrix switch is overwritten due to the 
replication. Any matrix switches that are operated with the database setting 
Follower therefore actively require access to the database leader during the booting 
process.

If this access is not possible, a follower matrix switch cannot boot.
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Tips and important instructions
In case the database leader fails, many parts of the Matrix-Grid can still be operated 
if they are operated via the database setting Follower. We strongly recommend setting 
the connected matrix switches to Follower.

 The local database of a connected matrix switch that is set to Follower is over-
written due to the replication. The connected matrix switch can be rebooted only 
if it has access to the database of the database leader.

 In case the database leader fails, you can configure one of the connected matrix 
switches that are set to Follower as the new database leader.
For this, first change the database setting to Leader (see page 325) and assign the 
matrix switch with the IP address of the failed database leader. After an automatic 
reboot of all components, the Matrix-Grid is ready for use again.
If the failure of the original database leader leads to a fundamental change in the 
topology and there are no alternatives for the failed grid lines, operation might be 
restricted.
Before you integrate the failed matrix switch back into the network, change its IP 
address to avoid a conflict in IP addresses.

 When replacing the database leader with a new device, the database of the new 
devices is replicated on the connected matrix switches that are set to Follower.
If the replacement device is a new matrix switch with an empty database, all 
settings of the Matrix-Grid are lost!

 When replacing a matrix switch of the Matrix-Grid please consider that when 
transmitting the configuration settings (Get config from ...) of a matrix switch to a 
new matrix switch, the configuration settings are not joined.
The data of the old device completely overwrite the data of the new device!

 To remove a Matrix-Grid member from the Matrix-Grid, first change the data-
base setting to Leader (see page 325).Then, deactivate the Grid mode (see page 325).

IMPORTANT: It is important to mind the tips and instructions listed below.

ADVICE: You can use the MatrixGuard function (see page 327) to protect a 
configured KVM Matrix-Grid™ against failure of the database leader.
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 The database operating mode of a matrix switch is stored in the network database 
of the device. When restoring the application settings, it is essential to check the 
adjusted operating mode.
You can also restore the network settings in addition to the application settings.

 The matrix switches provide a Fail LED that lights up if the database leader is not 
available.

Special features of the KVM Matrix-Grid
Planning and installing a Matrix-Grid is a challenging task.

Therefore, make sure to carefully plan the design of the Matrix-Grid and the number 
of required grid lines between the individual matrix switches.

If you want to turn your existing KVM matrix system into a Matrix-Grid, you 
should schedule a reasonable downtime to configure and wire the Matrix-Grid.

Restrictions

 The USB signal between console modules, DWCs and computer modules 
including integrated USB can be transmitted over up to four matrix switches  
(three grid lines).

 Like in a cascade, the functions TradeSwitch, CrossDisplay-Switching, Channel grouping 
of workstations as well as Push/Get can be used only if the console modules and 
DWCs are connected to the same matrix switch.

Installing devices
1. Install the matrix switches as well as the console modules, DWCs and  

computer modules as described in the installation guides.

2. Configure the network settings of each matrix switch as described  
under Configuring the network interfaces on page 19.

NOTE: The support team gladly helps you with installing your Matrix-Grid. If 
required, request a quote for on-site support.
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Establishing an autarchic grid network
The autarchic grid network connects all matrix switches to the shared database of a 
Matrix-Grid.

1. Prepare the autarchic grid network for the KVM Matrix-Grid.

All matrix switches included in a Matrix-Grid use this network to  
communicate with the database leader.

2. Connect one network interface (e.g. Network B) of each matrix switch  
to the autarchic grid network.

ADVICE: Use one network interface of each matrix switch to access the 
web application. Use the other network interface to connect the matrix 
switch to the autarchic grid network.

After you used the web applications of the matrix switches to set up 
the Matrix-Grid, activate link aggregation to increase the reliability and 
connect both network interfaces to the grid network (see page 16).
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Preparations in the web application
Start the web application of each matrix switch and check the following requirements to 
activate a Matrix-Grid:

1. Check the firmware version installed on the matrix switch (see page 224).

2. You received a feature key after you purchased the function. If you ordered the 
function together with a matrix switch, the feature key is already activated.

Instructions on how to activate the feature key are given under Activating premium 
functions on page 90.

Database configuration of the Matrix-Grid member
The configuration of each matrix switch of the Matrix-Grid is conveniently done 
with a wizard. In the ConfigPanel of the matrix switch to be configured, click on the 
Advanced features menu and select KVM Matrix-Grid™.

To start the wizard, click on Configuration.
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The following sections briefly summarize the wizard's configuration options.

Step 1: Set system time

How to change the NTP time sync settings:

1. Under NTP server, enter the following data:

2. Click on Save and continue.

How to manually set the time and date of the device:

1. Go to NTP server.

2. In the Time field of the Time/date paragraph, enter the time in the format hh:mm:ss.

3. In the Date field of the Time/date paragraph, enter the current date in the format 
DD.MM.YYYY.

4. Click on Save and continue.

IMPORTANT: If the time difference between the matrix switches is too large, 
an encrypted connection cannot be established between the matrix switches.

Therefore, we strongly recommend using an NTP server for automatic time 
alignment.

NTP time sync: Select the respective entry from the pull-down menu to 
enable or disable the time sync:

 Enabled
 Disabled

NTP server 1: Enter the address of a time server.

NTP server 2: Optionally, you can enter the address of a second time server.

Time zone: Select the time zone of your location from the pull-down 
menu.

IMPORTANT: If necessary, disable the option NTP time sync. Otherwise, it is not 
possible to set the time and date manually.

ADVICE: Click on Accept local date to copy the current system date of the 
computer on which the web application was opened into the fields Time and 
Date.
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Step 2: Set certificate

Communication between matrix switches is possible only if all devices use certificates
of the same Certificate Authority.

For self-created certificates, be sure to use the same certificate authority or alternatively 
use Certificate #1 (preferred) or Certificate #2 for all matrix switches.

How to select the SSL certificate to be used:

1. Select the SSL certificate you want to use:

3. Click on Save and continue.

IMPORTANT: After activating another certificate, close any active »Config Panel« 
sessions and start new sessions.

G&D certificate #1: This certificate is enabled for new devices.

G&D certificate #2: This certificate is supported by some older G&D devices 
with integrated web application.

User certificate: Select this option if you want to use a certificate 
purchased from a certificate authority or if you want to 
use a user certificate.

Now you can import and upload the certificate: 
Click on Import certificate from file and select the .pem file 
you want to import.

You can also copy the plain text of the server 
certificate, the server’s private key and the certificate 
of the certificate authority to the text box.

2. Click on Upload and activate to store and activate the  
imported certificate for the device.

NOTE: Make sure that you use the same certificate for all devices within the 
KVM system.
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Step 3: Device role in Grid system

1. Select the role of this matrix switch within the Matrix-Grid:

2. Enter the following data to the Leader connection paragraph:

3. Click on Save and continue.

Step 4: (De)Activate grid

1. Select whether grid mode is Enabled or Disabled.

2. Click on Save and continue.

Leader: The KVM system database is stored in this device..

Follower: The database of the KVM system is stored in the database 
leader (see above) and mirrored to this device.

Forwarder: The database of the KVM system is stored in the 
database leader..

Port: Enter the port (usually 27996) of this device.

Leader IP: If you selected the Follower or Forwarder type, enter the IP address 
of the device in which the database is administered.

Leader port: If you selected the Follower or Forwarder type, enter the port 
(usually 27996) of the device in which the database is 
administered.

IMPORTANT: Only one matrix switch can be used as leader in a Matrix-Grid.

NOTE: A Matrix-Grid may contain between 0 and 23 follower.

NOTE: A Matrix-Grid may contain between 0 and 23 forwarders.
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Connecting matrix switches to grid lines

1. Plug the desired number of grid lines (direct connections) between the individual 
matrix switches.

Functional test
After you installed the Matrix-Grid, make sure that the system is working. Check, 
for example, the following functions and settings:

 Can you switch to computer modules (even across several grid lines)?
 Are the rights for users and devices within the Matrix-Grid properly assigned?
 Are the monitoring values of the Matrix-Grid components complete and  

plausible?
 Is it possible to correctly and completely carry out a controlled booting process for 

the entire Matrix-Grid (e. g. after a power failure)?
 Does switching between channels via CrossDisplay-Switching work at the  

configured CDS workstations?
 Can the system be operated via IP-Control-API or XML control?

NOTE: Connect the grid lines between the matrix switches only after the Matrix-
Grid is completely installed and configured.
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MatrixGuard (optional)

If the current database leader is unavailable, the MatrixGuard function organises 
the forwarding of the leader role to another, available matrix switch of the Matrix-
Guard.

All matrix switches of a MatrixGuard system share a common (virtual) MatrixGuard 
address. The MatrixGuard automatically determines the database leader based on the 
availability and priority of its members.

Rules for the assignment of the leader role
1. When negotiating the leader role, the assigned priorities are taken into account 

(see page 334). 

If several matrix switches have the highest priority, the MatrixGuard function 
decides which matrix switch is assigned the leader role.

2. When restarting a matrix switch that used to be the database leader before the restart, 
the system checks whether a new leader exists in the MatrixGuard system.

If this is the case, the booting matrix switch is downgraded to follower during the 
restart.

3. If a leader matrix switch becomes available again without restarting the device  
(e.g. after a temporary failure of a network component), the leader role is 
renegotiated if a new leader has become available in the MatrixGuard system  
in the meantime.

Example 1: Restart of all components

If all KVM components of the KVM matrix grid are restarted (e.g. after a power 
failure), each matrix switch checks whether one or more matrix switches of the 
MatrixGuard system are available as soon as it has initialized its network functions.

The first available matrix switch automatically becomes the database leader, since 
no other matrix switch of the MatrixGuard is available at this time.

The then starting matrix switches are automatically downgraded to follower during 
the boot process (see rule no. 2).

IMPORTANT: Using the MatrixGuard function requires the purchase and activation
of the premium MatrixGuard Function.

IMPORTANT: Configure the same MatrixGuard address on each matrix switch of 
the MatrixGuard system (see page 334).
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Example 2: Failure of the current database leader

All matrix switches in the MatrixGuard system regularly check whether the database 
leader is available. As soon as the database leader is no longer available, the remaining 
matrix switches renegotiate the leader role based on the assigned priorities.

Example 3: Recognition of another database leader

A MatrixGuard system may contain only one available database leader.

If, for example, after the network connection of the previously active database 
leader has been restored, another database leader becomes available within the 
MatrixGuard system, the leader matrix switches renegotiate the leader role based on 
the assigned priorities.

Example 4: Failure of a network component

If a network component fails, it is possible to separate a MatrixGuard system into 
several individual parts.

If the network switch fails, none of the matrix switches reaches another matrix 
switch included in the MatrixGuard system.

The current follower matrix switches therefore renegotiate the leader role. Since 
each follower matrix switch cannot reach another matrix switch due to the missing 
network connection, each matrix switch takes over the leader role for itself.

As soon as the network component is available again, the matrix switches renegotiate 
the roles as described in example 3.

IMPORTANT: When another matrix switch takes over the leader role, all end 
devices briefly lose the connection to the KVM matrix system and all open Config 
Panel sessions are terminated.

IMPORTANT: When another matrix switch takes over the leader role, all end 
devices briefly lose the connection to the KVM matrix system and all open Config 
Panel sessions are terminated.
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Important notes
 Each matrix switch manages its MatrixGuard settings autonomously.

When setting up the MatrixGuard function, it is therefore necessary to separately 
configure the settings in all matrix switches of the group via the web application of 
the individual matrix switches.

 The Forwarder database mode is not available for the matrix switches of the Matrix-
Guard group.
The group automatically negotiates the leader role. The other matrix switches are 
automatically configured as database follower.

 All matrix switches of the MatrixGuard group are assigned the same virtual 
network interface.
The web application of the current leader can be reached via the IP address of the 
virtual network interface.

 After setup, the current MatrixGuard role of a matrix switch is displayed on the 
overview page of the MatrixGuard function.
You can also display the Database mode column in the web application under  
Matrix systems > Matrix (see page 8) and get the status from there.

Requirements
Before configuring the MatrixGuard function, make sure to meet the following 
requirements:

 A functioning KVM matrix system is available.
 The matrix switches are in the same subnet.
 The network switches are able to forward multicast packets.
 The MatrixGuard feature is enabled for all matrix switches.

 The KVM matrix grid feature (see page 314 ff.) is enabled for all matrix switches.
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Configuring a MatrixGuard member

You can configure each MatrixGuard member conveniently with a wizard. Click on the 
menu Advanced features and select MatrixGuard. To start the wizard, click on Configure.

The following sections briefly summarize the wizard's configuration options.

Overview: Configuration of a MatrixGuard member

If you have already configured the member's MatrixGuard function, the wizard 
starts with an overview of the member's most important settings.

You can find the following information in the overview:

 Priority: User-defined priority of this matrix switch

 MatrixGuard member: Name of this matrix switch

 MatrixGuard role: Role this matrix switch currently has in the MatrixGuard group.

You can perform the following actions on the overview page of the wizard: 

 Remove member: After clicking this button you will be prompted to select the 
future operating mode and to configure the connection to the leader.

 Assign leader role: If the member is currently operated as follower  
(see column MatrixGuard role), you can click on this button to make it the leader.

 Configure: Click on this button to go to configuration steps 1 to 3 (see below).

Step 1: Set system time

IMPORTANT: Each matrix switch manages its MatrixGuard settings autonomously.

When setting up the MatrixGuard function, it is therefore necessary to separately 
configure the settings in all matrix switches of the group via the web application of 
the individual matrix switches.

NOTE: When configuring the MatrixGuard function for the first time, the wizard 
immediately starts with step 1 (see below).

IMPORTANT: If the time difference between the matrix switches is too large, an 
encrypted connection cannot be established between the matrix switches.

Therefore, we strongly recommend using an NTP server for automatic time 
alignment.
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How to change the NTP time sync settings:

1. Under NTP server, enter the following data:

2. Click on Save and continue.

General

NTP time sync: By selecting the corresponding entry in the pull-down menu, 
you can enable or disable the time synchronization:

 Disabled (default)
 Enabled

Time zone: Use the pull-down menu to select the time zone of your 
location.

NTP server 1

Address: Enter the IP address of a time server.

Authentication: By selecting the corresponding entry in the pull-down menu, 
you can enable or disable the authentication:

 Disabled (default)
 SHA1

Key ID: After enabling the authentication, enter the key ID that can 
be used for key authentication with the NTP server.

Key: Enter the key in the form of up to 40 hex digits.

NTP server 2

Address: Optionally enter the IP address of a second time server.

Authentication: By selecting the corresponding entry in the pull-down menu, 
you can enable or disable the authentication:

 Disabled (default)
 SHA1

Key ID: After enabling the authentication, enter the key ID that can 
be used for key authentication with the NTP server.

Key: Enter the key in the form of up to 40 hex digits.
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How to manually set the time and date of the device:

1. Go to NTP server.

2. In the Time field of the Time/date paragraph, enter the time in the format hh:mm:ss.

3. In the Date field of the Time/date paragraph, enter the current date in the format 

DD.MM.YYYY.

4. Click on Save and continue.

IMPORTANT: If necessary, disable the option NTP time sync. Otherwise, it is not 
possible to set the time and date manually.

ADVICE: Click on Accept local date to copy the current system date of the 
computer on which the web application was opened into the fields Time and 
Date.
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Step 2: Set certificate

Communication between matrix switches is possible only if all devices use certificates of 
the same Certificate Authority.

For self-created certificates, be sure to use the same certificate authority or alternatively 
use Certificate #1 (preferred) or Certificate #2 for all matrix switches.

How to select the SSL certificate to be used:

1. Select the SSL certificate you want to use:

3. Click on Save and continue.

IMPORTANT: After activating another certificate, close any active »Config Panel« 
sessions and start new sessions.

G&D certificate #1: This certificate is enabled for new devices.

G&D certificate #2: This certificate is supported by some older G&D devices 
with integrated web application.

User certificate: Select this option if you want to use a certificate 
purchased from a certificate authority or if you want to 
use a user certificate.

Now you can import and upload the certificate:

1. Click on Import certificate from file and select the .pem file 
you want to import.

You can also copy the plain text of the server 
certificate, the server’s private key and the certificate 
of the certificate authority to the text box.

2. Click on Upload and activate to store and activate the 
imported certificate for the device.

NOTE: Make sure that you use the same certificate for all devices within the 
KVM system.
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Step 3: Configure members

In this step, you configure the MatrixGuard settings of the matrix switch whose web 
application you have opened:

 Priority: Assign this matrix switch a priority between 1 (high) and 10 (low).

 Interface: Select the network interface via which this matrix switch is available in 
the MatrixGuard group.
You can select the physical network interfaces and (if configured) also the  
link aggregation interface.

 MatrixGuard address: Assign the matrix switch an IP address that is not assigned in 
the subnet.

 MatrixGuard netmask: Enter the netmask of the subnet.

 Port (»local« and »remote«): Define the port (usually 27996) through which this 
device communicates with the other devices of the MatrixGuard group.

Click on Save and continue to add this device to the MatrixGuard system.

NOTE: The matrix switches negotiate the leader role based on the defined priorities.

The matrix switch with the highest priority is assigned the leader role. If this priority is 
assigned to several matrix switches, the MatrixGuard function decides which of these 
matrix switches gets the leader role.

IMPORTANT: Assign the same virtual IP address to all matrix switches included in 
the MatrixGuard group.

IMPORTANT: The MatrixGuard function requires all matrix switches to be on the 
same subnet.

NOTE: A virtual network interface is set up using the parameters MatrixGuard address
and MatrixGuard network.

The current leader of the MatrixGuard system is available under this virtual 
IP address.

NOTE: Assign the same port to all devices included in the MatrixGuard group.
334 · G&D ControlCenter-Compact



SyncSwitching (optional)
SyncSwitching (optional)

With the SyncSwitching function, switching states can be synchronized between up to 
three redundant, yet otherwise independently operating matrix switches. This way, 
you can synchronize the switching conditions of several matrix switches. Unlike 
with the MatrixGuard (see page 327 ff.), the systems do not share a database and 
communication does not take place between matrix switches within a Matrix-Grid 
(see page 314 ff.).

For using the SyncSwitching function, you can configure up to two matrix switches as 
syncFollowers, which follow the switching states of the syncLeader matrix switch.

The commands Login, Connect and Redirect of the syncLeader matrix switch are also 
executed on the syncFollower matrix switch.

IMPORTANT: Using the SyncSwitching function requires the purchase and 
activation of the premium function IP-Control-API (see page 260) on the 
syncFollower matrix switch(es).

NOTE: Synchronization can only take place with other matrix systems.

It is not possible to send switching states to a matrix switch within a 
shared database.

ADVICE: Contact our support team if you want to set up more than two 
syncFollowers or if you want to use the SyncSwitching function in combination 
with Matrix-Grid (see page 314 ff.) and MatrixGuard (see page 327 ff.) function.

The command Disconnect is not synchronised.
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Requirements
Before configuring the SyncSwitching function, make sure to meet the following 
requirements:

 A network connection is established between the matrix switches.
 The matrix switches use the same certificate (see page 39).
 The system times of the matrix switches are synchronised (see page 44).
 The SyncSwitching user is activated on each syncFollower matrix switch 

and a password is assigned.
 The IP API switching feature (see page 260) is activated on the syncFollower matrix 

switch(es).

Configuring the SyncSwitching function
You can configure the SyncSwitching function conveniently with a wizard. Click on 
the menu Advanced features and select SyncSwitching. 

To start the wizard, click on Configuration.

The following sections briefly summarize the wizard's configuration options.

Step 1: Select a matrix switch

1. Select the matrix switch for which you want to configure  
the SyncSwitching function.

This matrix switch is assigned the syncLeader role. Any syncFollower matrix 
switches will copy its switching conditions.

2. Click on Continue.
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Step 2: Enable/disable syncFollower matrix switches

1. Click on the slider in the line Synchronization of user-initiated logoff (green) to 
synchronize user-initiated logouts.

2. Click on the slider in the line Ignore user authorizations on the target system (green) to 
ignore user authorizations on the target system.

3. Click on the slider of syncFollower matrix switch 1 (green) to activate this  
matrix switch for SyncSwitching.

Click the slider again (grey) to deactivate it.

4. Click on the slider of syncFollower matrix switch 2 (green) to activate this  
matrix switch for SyncSwitching.

Click the slider again (grey) to deactivate it.

5. Click on Save and continue.

IMPORTANT: Only user-initiated logouts are taken into account. If, for example a 
device is switched off or the connection is interrupted, this is not taken into 
account.

IMPORTANT: Logouts at an OpenAccess console module (see page 118 ff.) and an 
OpenAccess DWC (see page 144 ff.) are not synchronized.

NOTE: If the user authorizations on the target system are ignored, synchronization 
of user-initiated logoff should be enabled.

NOTE: Click on Delete syncFollower to delete the stored configuration 
of a syncFollower matrix switch.
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Schritte 3/5: Configure syncFollower matrix switches

1. Configure the syncFollower settings of matrix switch 1 (step 3) or  
matrix switch 2 (step 5):

IP address/ 
DNS name:

Enter the IP address or the DNS name of the target matrix 
switch.

Port: Enter the database port of the target matrix switch 
(default: 27996).

Password 
syncSwitching

Enter the password of the syncSwitching user of the target 
matrix switch.

Switching of  
end devices

Select the mode according to which the end devices are 
switched.

 Device names: When synchronizing by name, the user-
assigned names of the console modules, DWCs and 
computer modules of the syncLeader and syncFollower
matrix switches must be identical.

You can use this if you have a redundant system without 
any end devices that are connected to both systems.

 Device IDs: Synchronization via ID requires that any 
console modules and computer modules use the same UID
for both the syncFollower matrix switch  and the syncLeader
matrix switch.

This is the case, for example, for redundant systems that share 
UC-CPU/2C/2F computer modules and CON-2/2C/2F console 
modules.

IMPORTANT: If you also use the optional MatrixGuard function 
(see page 327 ff.), enter the real IP address of the target matrix switch here 
and not the virtual MatrixGuard address.(see page 327 ff.).

IMPORTANT: The switching commands are only executed if the password 
entered here matches the password of the syncSwitching user on the target 
matrix switch.

IMPORTANT: Switching of remote targets is only synchronized by device 
names.
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2. Click on Save and continue.

Step 4/6: Check settings on the matrix switches

1. Open the Config Panel of matrix switch 1 (step 4) or  
matrix switch 2 (step 6) and check the requirements:

2. Click on Continue to finish the check.

Synchronise  
syncFollower 
matrix switches

Select when the synchronisation takes place:

 Only manually via OSD: This default setting of requires 
manual synchronization via the Operation menu (F9) 
of the OSD.

 Automatic + manually via OSD: When selecting this setting, 
synchronization is event-driven as soon as a Login, Connect
or Redirect command is executed on the syncLeader matrix 
switch.

Manual synchronization via the Operation menu (F9) of the 
OSD is also possible in this mode.
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EasyControl (optional)

You can use the EasyControl tool integrated in the web application to connect a console 
module to a specific computer module or to execute an existing script or script group.

After activating the IP-Control-API (see page 340 ff.), all users who assigned with the 
right to access the tool (see page 83) can use it.

Starting the »EasyControl« tool

How to start the tool:

1. Enter the following URL in the address line:

https://[IP address of the device]

2. Enter the following data in the login mask:  

3. Click on Login.

4. Click on the EasyControl icon.

IMPORTANT: Using the EasyControl tool requires the purchase and activation of 
the premium IP-Control-API (see page 340 ff.).

Agree to the terms 
of use:

Click on the text to read the terms of use. Click on the 
checkbox to accept the terms of use.

Username: Enter a username.

Password: Enter a password for your user account.

2-Factor Auth Code 
(TOTP):

Enter the 2-Factor Auth Code (TOTP) from 
two-factor authentication.

NOTE: The terms of use only appear if a corresponding configuration has been 
made (see Showing terms of use on page 13 ff.).

NOTE: The 2-Factor Auth Code (TOTP) is only requested if 
two-factor authentication has been configured (see page 53 f.) 
and activated (see page 68 ff.).
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Establishing and disconnecting a connection
Use the tool in Connection mode to connect a console module to a computer module.

The left column lists the console modules on which you are logged in at the moment.

The right column lists all computer modules you can access according to the access 
rights assigned to your account.

If a console or computer module has an active connection to a remote terminal, 
a short note indicates this condition in the list:

 Console modules: Connected to [name of computer module]

 Computer modules: [x] console(s) connected

NOTE: The following console modules are not listed here:

 Grouped console modules (except main channel 1),
 CON modules of U2-, U2+ or U2-LAN variants,
 DynamicWorkplace-CONs and DWC channels.

ADVICE: You can use scripts (see below) to log on to other console modules without 
having to log on to the OSD.

NOTE: The following computer modules are not listed here:

 Grouped computer modules (except main channel 1),
 CPU modules of U2-, U2+ or U2-LAN variants,
 Digital CPU modules that are used as a connection to an analog matrix switch 

via bridge function (see page 311 ff.).
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Switching functions

How to connect a console module and a computer module:

1. Click on Connection.

2. Successively click the buttons of the console module and the computer module 
which you want to connect with each other.

The two devices connected via mouse click remain marked until the  
next click is made.

How to disconnect a console module from a computer module:

1. Click on the button of the console module you want to disconnect from a  
computer module.

2. Click on Disconnect.

How to show the remote station of the connected computer module:

1. Click on the button of the console module or computer module whose remote station 
you want to show.

The selected module and the module connected to it are now marked in the lists.

Hiding modules on the user interface

How to show or hide console or computer modules from the list:

1. Click on the gears icon at the bottom right ( ).

Each entry in the list of the console or computer modules contains  
the slider Hide device.

2. Activate the sliders of modules you want to hide from the list.

Deactivate the sliders of modules you want to show on the list.

3. Click the gears icon again ( ).

NOTE: The last clicked button is displayed as marked. 
Click anywhere outside of the button or on the button to cancel the mark.
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Executing scripts
Use the tool in Script mode to execute an existing script or script group.

Each page of the user interface contains 12 buttons. Each of these buttons can be 
assigned a script or a script group.

To be able to call a script or a script group using the tool, the following requirements 
must be met:

 The user logged in to EasyControl is assigned the right to execute a script or script 
groups.

 In the settings of the script or the script group the use in EasyControl is permitted.

IMPORTANT: When opening the script view of the tool for the first time, no buttons 
are configured yet.

You can only execute scripts or script groups after you have configured the buttons.
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Configuring the interface

How to assign a script or a script group to an unconfigured button:

1. Click on the gears icon at the bottom right ( ).

All available buttons are displayed in the middle of the view.

2. Click on an unconfigured button marked with Configure.

3. Select the script or script group you want to execute using this button.

How to assign a colour to a configured button:

1. Click on the gears icon at the bottom right ( ).

All available buttons are displayed in the middle of the view.

2. Click on a configured button.

3. Select the desired colour of this button.

How to add a page to or delete it from the view:

1. Click on the gears icon at the bottom right ( ).

2. Click on Add in the middle of the footer to add another empty page.

Click on Delete to delete the currently displayed page.

How to delete the configuration of a configured button:

1. Click on the gears icon at the bottom right ( ).

2. Click on the [X] in the upper right corner of a configured button.

IMPORTANT: Unconfigured buttons are only visible in the configuration view. 
These buttons are not visible in the user view.

NOTE: Buttons that have already been configured show the name of the assigned 
script or script group.

Unconfigured buttons are marked with Configure.

NOTE: Buttons that have already been configured show the name of the assigned 
script or script group.

Unconfigured buttons are marked with Configure.

NOTE: Only empty pages can be deleted.
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Operating the user interface

How to execute a script or a script group:

1. Click on Script.

All configured buttons are displayed in the middle of the view.

2. If necessary, use the page selection in the middle of the footer to select the page 
containing the desired button.

3. Click on the desired button.
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General configuration settings

Showing all notifications or only errors

1. Click on the gears icon at the bottom right ( ).

2. Select one of the given options:

3. Click the gears icon again ( ).

Changing the colour scheme of the tool

How to change the colour scheme:

1. Click on the gears icon at the bottom right ( ).

2. Click on the button of the colour scheme you want to use 
(Skin 1, Skin 2 or Skin 3).

3. Each colour scheme is available in a variant for light and dark working  
environments. Select the desired variant:

4. Click the gears icon again ( ).

Closing the tool

How to close the tool:

1. Click on the Exit ( ) icon at the bottom right.

All notifications: Show all status and error notifications

Only errors: Show only error notifications

NOTE: The selected colour scheme is saved in the user settings of the active user. 
When using the tool the next time, the previously selected colour scheme 
is applied.

Bright: Apply variant for bright surroundings

Dark: Apply variant for dark surroundings
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Possible messages and their meanings
There are various messages that can appear on the monitor of the console module in 
certain cases. You have the option of adjusting or deactivating these information 
displays (see Adjusting the information display on page 216 ff.).

Below you find a selection of possible messages and their meanings:

Message Meaning

Forwarding to ... The console module is the leader workplace of the 
Tradeswitch workplace (see Administrating tradeswitch 
workplaces on page 278). This message appears when the 
input devices are switched to another console module or 
DWC.

You can switch this message off if you want  
(see Configure Tradeswitch visualization for a console 
module on page 280).

FORWARDED The console module is a target workplace of the 
Tradeswitch workplace. This message appears when the 
input devices are switched from the leader workplace to 
this console module.

You can switch this message off if you want  
(see Configure Tradeswitch visualization for a console 
module on page 280).

No CDS: Globally disabled No CDS possible as the function is deactivated for the 
entire system (see Enabling CrossDisplay-Switching for the 
entire system on page 291 ff.).

No CDS: Disabled No CDS possible as the computer module uses relative 
mouse coordinates (see Enabling CrossDisplay-Switching 
for a specific computer module on page 294 ff.).

No CDS: No Tradeswitch modifier No CDS possible because no tradeswitch key modifier  
(see Changing tradeswitch key and valid key type on 
page 276 ff.) has been configured.

No CDS: Computer module not found No CDS possible because the computer module was not 
found.

No CDS: Computer module multiuser 
mode

No CDS possible as a user is already connected to the 
computer module and this does not support MultiAccess 
(see Access mode for simultaneous access to computer 
modules on page 94 ff.).

No CDS: Computer module not  
supported

No CDS possible as the computer module does not support 
switching via CDS.

Contact our support team for more information.

No CDS: Console not found No CDS possible because the console module does not 
exist in the matrix switch database (anymore).

No CDS: Console MultiAccess mode No CDS possible because the console module is included 
in several Workplaces (Tradeswitch configurations) and 
does not support multiuser CDS.

No CDS: Unknown error No CDS possible.

Contact our support team for more information.
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Not connected The console module is not connected to any computer 
module (for detailed information, please refer to the 
separate manual Configuration and operation).

Computer module not available The console module should be connected to a computer 
module. However, this computer module is not available 
in the system.

No user logged in The console module should be connected to a computer 
module. However, no user is logged on (for detailed 
information, please refer to the separate manual 
Configuration and operation).

Insufficient access rights The console module should be connected to a computer 
module. However, the user rights do not allow this  
(see Adjusting access and configuration rights on 
page 91 ff.).

No MultiAccess right The console module should be connected to a computer 
module. However, another user is already connected and 
the user does not have MultiAccess rights  
(see Access mode for simultaneous access to computer 
modules on page 94 ff.).

Unknown route to computer module The console module should be connected to a computer 
module. However, the matrix switch does not know where 
the computer module is connected (for detailed 
information, please refer to the separate manual 
Configuration and operation).

No route to computer module available The console module should be connected to a computer 
module. The matrix switch knows how to reach the 
computer module. However, there is no free line via which 
the computer module can be reached (for detailed 
information, please refer to the separate manual 
Configuration and operation).

Connection failed The console module should be connected to a computer 
module. However, the router was unable to fulfill its task.

VIEW ONLY Operation of the connected computer module is disabled 
(see Adjusting access and configuration rights on 
page 91 ff.).

You can switch this message off if you want  
(see How to change the general settings of the information 
display for computer modules with view right: on 
page 217).

MULTIUSER If several users are connected to a computer module, the 
number of connected users is displayed.

You can switch this message off if you want  
(see Multi-user information on page 111 ff.).

AUTOSCAN The computer module uses the autoscan function  
(see Auto scanning all computer modules (Autoscan) on 
page 206 ff.).

AUTOSKIP The computer module uses the autoskip function  
(see Auto scanning all active computer modules (Autoskip)  
on page 208 ff.).

Message Meaning
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STEPSCAN The console module uses the stepscan function and the 
keys to scan the computer modules manually are active 
(see Scanning computer modules manually (Stepscan) on 
page 209 ff.).

HDCP content suppressed The connected computer module has detected HDCP-
protected image data that may not be displayed.

Frozen for ... When using freeze mode, the image last received is either 
highlighted by a coloured frame and/or the note Frozen 
and the time past since the loss of connection  
(see Freeze mode on page 246 ff.)

Please reconnect A disconnection has been detected. Check the cables.

Communication was interrupted
Auto-switched to channel ...

A CON-2/2C/2F console module was automatically 
switched to the specified channel due to a connection 
failure.

Stream CPU ... Index of the displayed video stream when switching of the 
video stream (when connected to a DH computer module)

Illegal format Problem with video parameters: Incorrect data format

Pixel clock too high Problem with video parameters: Pixel clock higher than 
supported by the current console module

Resolution too high Problem with video parameters: Image width or image 
hight greater than supported by the current console 
module

Pixel clock too low Problem with video parameters: Pixel clock below the 
minimum clock rate

Resolution too low Problem with video parameters: Image width or image 
height less than required for output

Invalid parameter Problem with video parameters: Image parameters 
inconsistent or incorrect
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